aboutsummaryrefslogtreecommitdiffstats
path: root/databases/gigabase
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-06-18 15:41:51 +0800
committermiwi <miwi@FreeBSD.org>2014-06-18 15:41:51 +0800
commitb0c0292e3f46108c71e789a9b9a55367b3c4913c (patch)
treef97b0dcb66d761c5696598c87f0a5629b6f8dfd9 /databases/gigabase
parent7a35bbf1971907ac1d4d0805aa04fdd9dc861ef7 (diff)
downloadfreebsd-ports-gnome-b0c0292e3f46108c71e789a9b9a55367b3c4913c.tar.gz
freebsd-ports-gnome-b0c0292e3f46108c71e789a9b9a55367b3c4913c.tar.zst
freebsd-ports-gnome-b0c0292e3f46108c71e789a9b9a55367b3c4913c.zip
- Update to 3.91
PR: 190893
Diffstat (limited to 'databases/gigabase')
-rw-r--r--databases/gigabase/Makefile22
-rw-r--r--databases/gigabase/distinfo4
-rw-r--r--databases/gigabase/files/patch-Makefile.in48
-rw-r--r--databases/gigabase/pkg-descr34
-rw-r--r--databases/gigabase/pkg-plist4
5 files changed, 60 insertions, 52 deletions
diff --git a/databases/gigabase/Makefile b/databases/gigabase/Makefile
index dba5abbfc5ff..8b96fc5f1390 100644
--- a/databases/gigabase/Makefile
+++ b/databases/gigabase/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gigabase
-PORTVERSION= 3.86
-PORTREVISION= 1
+PORTVERSION= 3.91
CATEGORIES= databases
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-src/${PORTVERSION} \
http://www.garret.ru/
@@ -11,14 +10,21 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-src/${PORTVERSION} \
MAINTAINER= ports@FreeBSD.org
COMMENT= Object-Relational Database Management System
+LICENSE= MIT
+
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= dos2unix gmake
-DOS2UNIX_FILES= Makefile.in
-USE_AUTOTOOLS= libtool
-CPPFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS}
+USES= dos2unix gmake libtool
+DOS2UNIX_FILES= Makefile.in *.cpp *.h
+USE_GCC= any
+USE_AUTOTOOLS= libtoolize aclocal autoconf
+LIBTOOLIZE_ARGS=--copy --force
USE_LDCONFIG= yes
-NO_STAGE= yes
+LDFLAGS+= -pthread
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|-lpthread|-pthread|' ${WRKSRC}/GiST/Makefile
+
.include <bsd.port.mk>
diff --git a/databases/gigabase/distinfo b/databases/gigabase/distinfo
index 2ea9b58a61c7..0978e0cefbbd 100644
--- a/databases/gigabase/distinfo
+++ b/databases/gigabase/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gigabase-3.86.tar.gz) = 3b47a99c7525ba14f98438dafd5235f143b1b16bf5b09f3f18660b040b770c85
-SIZE (gigabase-3.86.tar.gz) = 3723385
+SHA256 (gigabase-3.91.tar.gz) = 94120c969cf94426498a7f22300ab0d1ae275f7c7ed50b026a2f1e9d7edee254
+SIZE (gigabase-3.91.tar.gz) = 3561700
diff --git a/databases/gigabase/files/patch-Makefile.in b/databases/gigabase/files/patch-Makefile.in
index 482c79587cfb..aaf5e0d7a13f 100644
--- a/databases/gigabase/files/patch-Makefile.in
+++ b/databases/gigabase/files/patch-Makefile.in
@@ -1,28 +1,26 @@
--- Makefile.in.orig 2012-05-14 15:11:18.000000000 +0600
+++ Makefile.in 2012-05-14 15:14:15.000000000 +0600
-@@ -5,8 +5,9 @@
- prefix = @prefix@
+@@ -6,7 +6,8 @@
exec_prefix = @exec_prefix@
VPATH = @srcdir@
--LIBTOOL = ./libtool
+ LIBTOOL = ./libtool
-INSTALL = @INSTALL@
-+LIBTOOL = @LIBTOOL@
+INSTALL_PROGRAM = @INSTALL_PROGRAM@
+INSTALL_DATA = @INSTALL_DATA@
-
+
# Coment this for AIX/xlC 5.0
LIBEXT=la
@@ -41,7 +42,7 @@
SUFF=@SUFF@
-
+
GB_LIB = libgigabase$(SUFF).${LIBEXT}
-CLI_LIB = libcli$(SUFF).${LIBEXT}
+CLI_LIB = libcligb$(SUFF).${LIBEXT}
EXES = subsql
-
+
EXAMPLES = guess testdb testjoin testddl testperf testspat testperf2 testsync testiref testtrav testidx testidx2 clitest testblob testleak testsession testtimeseries testtl
@@ -49,7 +50,7 @@
-
+
CXX = @CXX@
CC = @CC@
-DEFS = @DEFS@
@@ -31,7 +29,7 @@
CFLAGS = @CFLAGS@ $(DEFS)
LD = $(CXX)
@@ -70,7 +71,7 @@
-
+
$(GB_LIB): $(OBJS)
# Coment this for AIX/xlC 5.0
- $(LIBTOOL) --mode=link $(CXX) -o $@ $(OBJS) $(LDFLAGS) @LTHREADSLIB@ -rpath $(libdir) -version-info $(VERSION)
@@ -40,7 +38,7 @@
# mkdir .libs
# xlC_r -qmkshrobj=-10 -o .libs/gigabase.so $(OBJS)
@@ -80,7 +81,7 @@
-
+
$(CLI_LIB): $(CLI_OBJS)
# Coment this for AIX/xlC 5.0
- $(LIBTOOL) --mode=link $(CXX) -o $@ $(CLI_OBJS) $(LDFLAGS) @LTHREADSLIB@ -rpath $(libdir) -version-info $(VERSION)
@@ -48,22 +46,26 @@
# Uncoment this for AIX/xlC 5.0
# xlC_r -qmkshrobj=-10 -o .libs/cli.so $(CLI_OBJS)
# ar rv .libs/libcli_r.a .libs/cli.so
-@@ -155,14 +156,14 @@
-
+@@ -154,15 +155,15 @@
+ $(LIBTOOL) --mode=link $(LD) $(LDFLAGS) -o testleak testleak.o $(GB_LIB) $(SLHACK)
+
install: subsql $(GB_LIB) $(CLI_LIB)
- mkdir -p $(includedir)
+- mkdir -p $(includedir)
- cp $(INCS) $(CLI_INCS) $(includedir)
-+ $(INSTALL_DATA) $(INCS) $(CLI_INCS) $(includedir)
- mkdir -p $(libdir)
+- mkdir -p $(libdir)
- $(LIBTOOL) --mode=install $(INSTALL) $(GB_LIB) $(CLI_LIB) $(libdir)
-+ $(LIBTOOL) --mode=install $(INSTALL_DATA) $(GB_LIB) $(CLI_LIB) $(libdir)
- mkdir -p $(bindir)
- if test -x .libs/subsql ; then \
+- mkdir -p $(bindir)
++ mkdir -p $(DESTDIR)$(includedir)
++ $(INSTALL_DATA) $(INCS) $(CLI_INCS) $(DESTDIR)$(includedir)
++ mkdir -p $(DESTDIR)$(libdir)
++ $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $(GB_LIB) $(CLI_LIB) $(DESTDIR)$(libdir)
++ mkdir -p $(DESTDIR)$(bindir)
+ if test -x .libs/subsql ; then \
- cp .libs/subsql $(bindir); \
-+ ${INSTALL_PROGRAM} .libs/subsql $(bindir)/subsql_gb; \
- else \
++ $(INSTALL_PROGRAM) .libs/subsql $(DESTDIR)$(bindir)/subsql_gb; \
+ else \
- cp subsql $(bindir); \
-+ $(INSTALL_PROGRAM) subsql $(bindir)/subsql_gb; \
- fi
++ $(INSTALL_PROGRAM) subsql $(DESTDIR)$(bindir)/subsql_gb; \
+ fi
# strip $(bindir)/subsql
-
+
diff --git a/databases/gigabase/pkg-descr b/databases/gigabase/pkg-descr
index fd6ea8cf9141..92cc9b5081b6 100644
--- a/databases/gigabase/pkg-descr
+++ b/databases/gigabase/pkg-descr
@@ -1,23 +1,23 @@
GigaBASE: Object-Relational Database Management System
-GigaBASE inherits most of the features of FastDB, but uses page pool instead
-of direct mapping of file on virtual memory. So GigaBASE is able to handle
-database, which size significantly exceeds size of computer physical memory.
-Convenient and flexible C++ interface makes development of application for
-GigaBASE very easy and automatic scheme evaluation simplifies maintenance
-and modification of the system. GigaBASE merges best features of relational
-(simple data structure and non-procedural query language) and object-oriented
-(direct object references, user defined types and methods) databases.
-GigaBASE is primary oriented on application requiring fast data retrieving
-by means of indices and direct object references, such as Web Server databases
-applications.
+GigaBASE inherits most of the features of FastDB, but uses page pool
+instead of direct mapping of file on virtual memory. So GigaBASE is able
+to handle database, which size significantly exceeds size of computer
+physical memory. Convenient and flexible C++ interface makes development
+of application for GigaBASE very easy and automatic scheme evaluation
+simplifies maintenance and modification of the system. GigaBASE merges
+best features of relational (simple data structure and non-procedural
+query language) and object-oriented (direct object references, user
+defined types and methods) databases. GigaBASE is primary oriented on
+application requiring fast data retrieving by means of indices and
+direct object references, such as Web Server databases applications.
-SUBSQL utility can be used for database browsing and inspection, performing
-online backups, database recovery, importing data to and exporting data from
-database. GigaBASE will perform automatic recovery after system or application
-crash, you should not worry about it. The only thing you can have to do manually
-is stopping all database application if one of them is crashed leaving database
-blocked.
+SUBSQL utility can be used for database browsing and inspection,
+performing online backups, database recovery, importing data to and
+exporting data from database. GigaBASE will perform automatic recovery
+after system or application crash, you should not worry about it. The
+only thing you can have to do manually is stopping all database
+application if one of them is crashed leaving database blocked.
Author: Konstantin Knizhnik <knizhnik@garret.ru>
WWW: http://www.garret.ru/gigabase.html
diff --git a/databases/gigabase/pkg-plist b/databases/gigabase/pkg-plist
index af75059de2cb..2f081a8f79ff 100644
--- a/databases/gigabase/pkg-plist
+++ b/databases/gigabase/pkg-plist
@@ -24,11 +24,11 @@ include/gigabase/sync.h
include/gigabase/timeseries.h
include/gigabase/wwwapi.h
lib/libcligb_r.a
-lib/libcligb_r.la
lib/libcligb_r.so
lib/libcligb_r.so.2
+lib/libcligb_r.so.2.0.0
lib/libgigabase_r.a
-lib/libgigabase_r.la
lib/libgigabase_r.so
lib/libgigabase_r.so.2
+lib/libgigabase_r.so.2.0.0
@dirrm include/gigabase