aboutsummaryrefslogtreecommitdiffstats
path: root/databases/hk_classes
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /databases/hk_classes
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'databases/hk_classes')
-rw-r--r--databases/hk_classes/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/databases/hk_classes/Makefile b/databases/hk_classes/Makefile
index cad6975eda9f..4bdada294746 100644
--- a/databases/hk_classes/Makefile
+++ b/databases/hk_classes/Makefile
@@ -22,9 +22,9 @@ USE_PYTHON= yes
USE_GNOME= pkgconfig
USE_GETTEXT= yes
CXXFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS= ${PTHREAD_LIBS} -L${LOCALBASE}/lib -largp -lintl
+LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib -largp -lintl
USE_AUTOTOOLS= libtool
-CONFIGURE_ENV+= PYTHON_VERSION=${PYTHON_VERSION:S/python//} LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV+= PYTHON_VERSION=${PYTHON_VERSION:S/python//}
CONFIGURE_ARGS+=--with-python-libdir=${PYTHON_LIBDIR} \
--with-python-incdir=${PYTHON_INCLUDEDIR} \
--with-fontconfig-incdir=${LOCALBASE}/include/fontconfig \
@@ -56,8 +56,8 @@ USE_MYSQL= yes
CONFIGURE_ARGS+= --with-mysql-dir=${LOCALBASE} \
--with-mysql-incdir=${LOCALBASE}/include/mysql \
--with-mysql-libdir=${LOCALBASE}/lib/mysql
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -L${LOCALBASE}/lib/mysql"
+CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -L${LOCALBASE}/lib/mysql"
+CPPFLAGS+= -I${LOCALBASE}/include
PLIST_SUB+= MYSQL=""
.else
CONFIGURE_ARGS+= --without-mysql
@@ -68,7 +68,8 @@ PLIST_SUB+= MYSQL="@comment "
USE_PGSQL= yes
CONFIGURE_ARGS+= --with-postgres-incdir=${LOCALBASE}/include/ \
--with-postgres-libdir=${LOCALBASE}/lib
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
PLIST_SUB+= POSTGRESQL=""
.else
CONFIGURE_ARGS+= --without-postgres