aboutsummaryrefslogtreecommitdiffstats
path: root/databases/leveldb
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-12-07 22:04:16 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-12-07 22:04:16 +0800
commit057ed5f62f0529925425214a8017e638cbfea16a (patch)
treed04940e1b9285a19006937488b0b709903a034c6 /databases/leveldb
parentbab83492877642622c79bc5ba4ff504bea6ad933 (diff)
downloadfreebsd-ports-gnome-057ed5f62f0529925425214a8017e638cbfea16a.tar.gz
freebsd-ports-gnome-057ed5f62f0529925425214a8017e638cbfea16a.tar.zst
freebsd-ports-gnome-057ed5f62f0529925425214a8017e638cbfea16a.zip
- Update to 1.2.20111130
Changes: http://code.google.com/p/leveldb/source/list http://code.google.com/p/leveldb/source/detail?r=c8c5866a86c8d4a3e80d8708d14a06776fb683d1 Feature safe: yes
Diffstat (limited to 'databases/leveldb')
-rw-r--r--databases/leveldb/Makefile2
-rw-r--r--databases/leveldb/distinfo4
-rw-r--r--databases/leveldb/files/patch-Makefile23
3 files changed, 10 insertions, 19 deletions
diff --git a/databases/leveldb/Makefile b/databases/leveldb/Makefile
index 7abd52324dc0..3109de90e09a 100644
--- a/databases/leveldb/Makefile
+++ b/databases/leveldb/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= leveldb
-PORTVERSION= 1.2.20111114
+PORTVERSION= 1.2.20111130
CATEGORIES= databases
MASTER_SITES= LOCAL/sunpoet
diff --git a/databases/leveldb/distinfo b/databases/leveldb/distinfo
index 99168b5ff9b5..bdf3ab39cf2c 100644
--- a/databases/leveldb/distinfo
+++ b/databases/leveldb/distinfo
@@ -1,2 +1,2 @@
-SHA256 (leveldb-1.2.20111114.tar.xz) = 139ad4936168c9560d96fe374175808d2bfbeee3aa4b619bd16737b5c4c01fc4
-SIZE (leveldb-1.2.20111114.tar.xz) = 143072
+SHA256 (leveldb-1.2.20111130.tar.xz) = 1c9d0fb59dc0d40ab3ee28327afb27f142cca53ffe84b92c8f2385e4495ee0ee
+SIZE (leveldb-1.2.20111130.tar.xz) = 143204
diff --git a/databases/leveldb/files/patch-Makefile b/databases/leveldb/files/patch-Makefile
index 72826e21186b..cb63d0f4790d 100644
--- a/databases/leveldb/files/patch-Makefile
+++ b/databases/leveldb/files/patch-Makefile
@@ -1,15 +1,6 @@
---- Makefile.orig 2011-11-21 14:58:22.000000000 +0800
-+++ Makefile 2011-11-21 15:12:50.189222302 +0800
-@@ -2,7 +2,7 @@
- # Use of this source code is governed by a BSD-style license that can be
- # found in the LICENSE file. See the AUTHORS file for names of contributors.
-
--CC = g++
-+CC ?= g++
-
- #-----------------------------------------------
- # Uncomment exactly one of the lines labelled (A), (B), and (C) below
-@@ -36,7 +36,7 @@
+--- Makefile.orig 2011-12-07 20:27:41.000000000 +0800
++++ Makefile 2011-12-07 20:53:25.265313302 +0800
+@@ -37,7 +37,7 @@
GOOGLE_PERFTOOLS_LDFLAGS=
endif
@@ -18,7 +9,7 @@
LDFLAGS += $(PLATFORM_LDFLAGS) $(SNAPPY_LDFLAGS) $(GOOGLE_PERFTOOLS_LDFLAGS)
-@@ -103,15 +103,18 @@
+@@ -104,15 +104,18 @@
BENCHMARKS = db_bench_sqlite3 db_bench_tree_db
LIBRARY = libleveldb.a
@@ -39,14 +30,14 @@
-rm -rf ios-x86/* ios-arm/*
-rm build_config.mk
-@@ -119,6 +122,10 @@
+@@ -120,6 +123,10 @@
rm -f $@
$(AR) -rs $@ $(LIBOBJECTS)
+$(SHARED_LIBRARY): $(LIBOBJECTS)
+ rm -f $@
-+ $(CC) -shared -Wl,-soname,$@.$(SHARED_LIBRARY_VER) -o $@.$(SHARED_LIBRARY_VER) $(LDFLAGS) $(LIBOBJECTS)
++ $(CXX) -shared -Wl,-soname,$@.$(SHARED_LIBRARY_VER) -o $@.$(SHARED_LIBRARY_VER) $(LDFLAGS) $(LIBOBJECTS)
+
db_bench: db/db_bench.o $(LIBOBJECTS) $(TESTUTIL)
- $(CC) $(LDFLAGS) db/db_bench.o $(LIBOBJECTS) $(TESTUTIL) -o $@
+ $(CXX) $(LDFLAGS) db/db_bench.o $(LIBOBJECTS) $(TESTUTIL) -o $@