aboutsummaryrefslogtreecommitdiffstats
path: root/databases/libgda4
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2010-05-11 05:19:08 +0800
committerkwm <kwm@FreeBSD.org>2010-05-11 05:19:08 +0800
commit6a2a890c5cd397f9f0287409c2aa0244d50f3573 (patch)
treefc02bcba8bfa155b5cf452d6bafe1cb06aca4848 /databases/libgda4
parent0e415a93a0424a4b284c88c39b19d93d80b66c8a (diff)
downloadfreebsd-ports-gnome-6a2a890c5cd397f9f0287409c2aa0244d50f3573.tar.gz
freebsd-ports-gnome-6a2a890c5cd397f9f0287409c2aa0244d50f3573.tar.zst
freebsd-ports-gnome-6a2a890c5cd397f9f0287409c2aa0244d50f3573.zip
Presenting GNOME 2.30.1 for FreeBSD. The offical release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.30/ . This release brings initial PackageKit support, Upower (replaces power management part of hal), cuse4bsd integration with HAL and cheese, and a faster Evolution. Sadly GNOME 2.30.x will be the last release with FreeBSD 6.X support. This will also be the last of the 2.x releases. The next release will be the highly-anticipated GNOME 3.0 which will bring with it a new UI experience. Currently, there are a few bugs with GNOME 2.30 that may be of note for our users. Be sure to consult the UPGRADING note or the 2.30 upgrade FAQ at http://www.freebsd.org/gnome/docs/faq230.html for specific upgrading instructions, and the up-to-date list of known issues. This release features commits by avl, ahze, bland, marcus, mezz, and myself. The FreeBSD GNOME Team would like to thank Anders F Bjorklund for doing the initual packagekit porting. And the following contributors & testers for there help with this release: Eric L. Chen Vladimir Grebenschikov Sergio de Almeida Lenzi DomiX walder crsd Kevin Oberman Michal Varga Pavel Plesov Bapt kevin and ITetcu for two exp-run PR: ports/143852 ports/145347 ports/144980 ports/145830 ports/145511
Diffstat (limited to 'databases/libgda4')
-rw-r--r--databases/libgda4/Makefile11
-rw-r--r--databases/libgda4/distinfo6
-rw-r--r--databases/libgda4/files/patch-libgda_Makefile.in12
-rw-r--r--databases/libgda4/pkg-plist2
4 files changed, 24 insertions, 7 deletions
diff --git a/databases/libgda4/Makefile b/databases/libgda4/Makefile
index 8150342718d9..2ce848039d61 100644
--- a/databases/libgda4/Makefile
+++ b/databases/libgda4/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/databases/libgda4/Makefile,v 1.2 2009/04/18 20:16:29 marcus Exp $
+# $MCom: ports/databases/libgda4/Makefile,v 1.5 2010/03/14 19:24:27 marcus Exp $
#
PORTNAME= libgda4
-PORTVERSION?= 4.0.7
-PORTREVISION?= 1
+PORTVERSION?= 4.0.8
+PORTREVISION?= 0
CATEGORIES= databases gnome
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/4$//}/${PORTVERSION:R}
@@ -23,9 +23,11 @@ LIBGDA4_SLAVE?= no
.if !defined(REFERENCE_PORT)
+BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
soup-2.4.1:${PORTSDIR}/devel/libsoup \
json-glib-1.0.0:${PORTSDIR}/devel/json-glib
+RUN_DEPENDS= ${LOCALBASE}/lib/girepository-1.0/GObject-2.0.typelib:${PORTSDIR}/devel/gobject-introspection
USE_AUTOTOOLS= libtool:22
USE_GETTEXT= yes
@@ -33,7 +35,8 @@ USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack glib20 libxslt intlhack referencehack
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --without-sybase
+CONFIGURE_ARGS= --without-sybase \
+ --enable-introspection
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl"
diff --git a/databases/libgda4/distinfo b/databases/libgda4/distinfo
index 0c6322167af2..eed091dfa0ea 100644
--- a/databases/libgda4/distinfo
+++ b/databases/libgda4/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/libgda-4.0.7.tar.bz2) = 875e41166eecde04b075fa451a6773ad
-SHA256 (gnome2/libgda-4.0.7.tar.bz2) = dffffc6524ecac05a4c891a9c3fca99abce9fb1bc368933a542d6afaf3ba8240
-SIZE (gnome2/libgda-4.0.7.tar.bz2) = 8198052
+MD5 (gnome2/libgda-4.0.8.tar.bz2) = 3e4a55f370805cda9ac415211da4aacc
+SHA256 (gnome2/libgda-4.0.8.tar.bz2) = c731cd8015f63a3bff37341cb8ffc4d8086a535d960af098194968ac87555788
+SIZE (gnome2/libgda-4.0.8.tar.bz2) = 8229914
diff --git a/databases/libgda4/files/patch-libgda_Makefile.in b/databases/libgda4/files/patch-libgda_Makefile.in
new file mode 100644
index 000000000000..e33d5924a1d5
--- /dev/null
+++ b/databases/libgda4/files/patch-libgda_Makefile.in
@@ -0,0 +1,12 @@
+--- libgda/Makefile.in.orig 2010-03-21 03:57:28.000000000 -0400
++++ libgda/Makefile.in 2010-03-21 03:58:29.000000000 -0400
+@@ -1349,7 +1349,8 @@ dist-hook:
+ @HAVE_INTROSPECTION_TRUE@ --include=GL-1.0 \
+ @HAVE_INTROSPECTION_TRUE@ --include=GObject-2.0 \
+ @HAVE_INTROSPECTION_TRUE@ --include=libxml2-2.0 \
+-@HAVE_INTROSPECTION_TRUE@ --library=gda-@GDA_ABI_VERSION@ \
++@HAVE_INTROSPECTION_TRUE@ --libtool="$(LIBTOOL)" \
++@HAVE_INTROSPECTION_TRUE@ --library=libgda-@GDA_ABI_VERSION@.la \
+ @HAVE_INTROSPECTION_TRUE@ $(INCLUDE_CFLAGS) \
+ @HAVE_INTROSPECTION_TRUE@ --output $@ \
+ @HAVE_INTROSPECTION_TRUE@ $(addprefix $(srcdir)/, $(gda_headers)) \
diff --git a/databases/libgda4/pkg-plist b/databases/libgda4/pkg-plist
index cdd203c443ca..90fa9176857d 100644
--- a/databases/libgda4/pkg-plist
+++ b/databases/libgda4/pkg-plist
@@ -103,6 +103,7 @@ include/libgda-%%VERSION%%/libgda/virtual/gda-virtual-provider.h
include/libgda-%%VERSION%%/libgda/virtual/gda-vprovider-data-model.h
include/libgda-%%VERSION%%/libgda/virtual/gda-vprovider-hub.h
include/libgda-%%VERSION%%/libgda/virtual/libgda-virtual.h
+lib/girepository-1.0/Gda-4.0.typelib
lib/libgda-%%VERSION%%.a
lib/libgda-%%VERSION%%.la
lib/libgda-%%VERSION%%.so
@@ -122,6 +123,7 @@ libdata/pkgconfig/libgda-%%VERSION%%.pc
libdata/pkgconfig/libgda-report-%%VERSION%%.pc
libdata/pkgconfig/libgda-sqlite-%%VERSION%%.pc
libdata/pkgconfig/libgda-xslt-%%VERSION%%.pc
+share/gir-1.0/Gda-4.0.gir
share/libgda-%%VERSION%%/dtd/libgda-array.dtd
share/libgda-%%VERSION%%/dtd/libgda-paramlist.dtd
share/libgda-%%VERSION%%/dtd/libgda-server-operation.dtd