aboutsummaryrefslogtreecommitdiffstats
path: root/databases/mysql_last_value
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-24 14:24:58 +0800
committeredwin <edwin@FreeBSD.org>2003-08-24 14:24:58 +0800
commitf48d2fb44368d5f64ca86fd7e4b7d5b2764ff7f6 (patch)
treeebb6c5cecad21582b2bd373f54986f8f3ed98f0b /databases/mysql_last_value
parentf89810a319a030875464f2f1b38fef0ae89bd409 (diff)
downloadfreebsd-ports-gnome-f48d2fb44368d5f64ca86fd7e4b7d5b2764ff7f6.tar.gz
freebsd-ports-gnome-f48d2fb44368d5f64ca86fd7e4b7d5b2764ff7f6.tar.zst
freebsd-ports-gnome-f48d2fb44368d5f64ca86fd7e4b7d5b2764ff7f6.zip
New port: Replaces NULL MySQL Field with value from top records
Replaces NULL column(s) with value from last available column value PR: ports/55649 Submitted by: Aftab Jahan Subedar <jahan@geocities.com>
Diffstat (limited to 'databases/mysql_last_value')
-rw-r--r--databases/mysql_last_value/Makefile24
-rw-r--r--databases/mysql_last_value/distinfo1
-rw-r--r--databases/mysql_last_value/pkg-descr7
-rw-r--r--databases/mysql_last_value/pkg-plist1
4 files changed, 33 insertions, 0 deletions
diff --git a/databases/mysql_last_value/Makefile b/databases/mysql_last_value/Makefile
new file mode 100644
index 000000000000..773ca6ab99c6
--- /dev/null
+++ b/databases/mysql_last_value/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: mysql_last_value
+# Date created: 14th Aug 2003
+# Whom: Aftab Jahan Subedar
+# $FreeBSD$
+
+PORTNAME= mysql_last_value
+PORTVERSION= 3.2
+CATEGORIES= databases
+MASTER_SITES= http://www.geocities.com/jahan.geo/
+
+MAINTAINER= jahan@bol-online.com
+COMMENT= Replaces NULL value of current column with value from top row
+
+LIB_DEPENDS= mysqlclient.14:${PORTSDIR}/databases/mysql41-client
+
+USE_REINPLACE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/mysql_last_value ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/databases/mysql_last_value/distinfo b/databases/mysql_last_value/distinfo
new file mode 100644
index 000000000000..2668840fde6f
--- /dev/null
+++ b/databases/mysql_last_value/distinfo
@@ -0,0 +1 @@
+MD5 (mysql_last_value-3.2.tar.gz) = 5e079427683e11f3edbde6e02913518e
diff --git a/databases/mysql_last_value/pkg-descr b/databases/mysql_last_value/pkg-descr
new file mode 100644
index 000000000000..00ef11fa62bb
--- /dev/null
+++ b/databases/mysql_last_value/pkg-descr
@@ -0,0 +1,7 @@
+mysql_last_value() replace null value of column from row above the current row.
+Its like "same as above".
+
+WWW: http://www.geocities.com/jahan.geo
+
+-Aftab Jahan Subedar
+jahan@bol-online.com jahan@geocities.com
diff --git a/databases/mysql_last_value/pkg-plist b/databases/mysql_last_value/pkg-plist
new file mode 100644
index 000000000000..176bdefefcf3
--- /dev/null
+++ b/databases/mysql_last_value/pkg-plist
@@ -0,0 +1 @@
+bin/mysql_last_value