aboutsummaryrefslogtreecommitdiffstats
path: root/databases/mysqlsla
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-24 06:22:24 +0800
committerMartin Wilke <miwi@FreeBSD.org>2006-11-24 06:22:24 +0800
commit89ac7314a9c188e275e7abd07b74d704ce78eb70 (patch)
treefc30ab9d0344713eaf6949e1953dc9a275c5d271 /databases/mysqlsla
parent00fac2543edcd3e3876e2f26036c8392acccfe3e (diff)
downloadfreebsd-ports-gnome-89ac7314a9c188e275e7abd07b74d704ce78eb70.tar.gz
freebsd-ports-gnome-89ac7314a9c188e275e7abd07b74d704ce78eb70.tar.zst
freebsd-ports-gnome-89ac7314a9c188e275e7abd07b74d704ce78eb70.zip
mysqlsla analyzes general, slow, and raw MySQL statement logs.
mysqlsla can read multiple MySQL general and slow logs (and logs containing raw SQL statements), combine them, then run various analyses on all the queries. In addition, mysqlsla can correlate the analyses so that the queries in one analysis are used as the basis for subsequent analyses. Other options include limiting the output of each analysis to the top N queries, averaging execution time over N runs, customizing the order in which the analyses are ran, statement filtering, statement pattern matching, and mysqldumpslow-like formatting. WWW: http://hackmysql.com/mysqlsla PR: ports/105788 Submitted by: Alexander Zhuravlev <zaa at zaa.pp.ru>
Diffstat (limited to 'databases/mysqlsla')
-rw-r--r--databases/mysqlsla/Makefile43
-rw-r--r--databases/mysqlsla/distinfo3
-rw-r--r--databases/mysqlsla/files/patch-mysqlsla11
-rw-r--r--databases/mysqlsla/pkg-descr12
4 files changed, 69 insertions, 0 deletions
diff --git a/databases/mysqlsla/Makefile b/databases/mysqlsla/Makefile
new file mode 100644
index 000000000000..b508a2781002
--- /dev/null
+++ b/databases/mysqlsla/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: mysqlsla
+# Date created: 2006-11-23
+# Whom: Alexander Zhuravlev <zaa@zaa.pp.ru>
+#
+# $FreeBSD$
+
+PORTNAME= mysqlsla
+PORTVERSION= 1.3
+CATEGORIES= databases
+MASTER_SITES= http://hackmysql.com/scripts/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= zaa@zaa.pp.ru
+COMMENT= Mysqlsla analyzes general, slow, and raw MySQL statement logs
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
+ ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+
+USE_PERL5= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= bin/mysqlsla
+PORTDOCS= mysqlsladoc.html
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500805
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+.endif
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/mysqlsla ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
+ @${MKDIR} ${DOCSDIR}
+. for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/mysqlsla/distinfo b/databases/mysqlsla/distinfo
new file mode 100644
index 000000000000..3a6b09e71b34
--- /dev/null
+++ b/databases/mysqlsla/distinfo
@@ -0,0 +1,3 @@
+MD5 (mysqlsla-1.3.tgz) = fc426c50e084e3be5aedfccd6f395fac
+SHA256 (mysqlsla-1.3.tgz) = bd286d4071de17a04cfafaccae05bdab9fb9089cafe626d0b6fba14b46eba7a0
+SIZE (mysqlsla-1.3.tgz) = 14372
diff --git a/databases/mysqlsla/files/patch-mysqlsla b/databases/mysqlsla/files/patch-mysqlsla
new file mode 100644
index 000000000000..70e9bffbe096
--- /dev/null
+++ b/databases/mysqlsla/files/patch-mysqlsla
@@ -0,0 +1,11 @@
+--- mysqlsla.orig Thu Nov 23 18:31:31 2006
++++ mysqlsla Thu Nov 23 18:31:47 2006
+@@ -115,7 +115,7 @@ if( (!$op{'general'} && !$op{'slow'} &&
+
+ $op{'host'} ||= 'localhost';
+ $op{'port'} ||= 3306;
+-$op{'socket'} ||= '/var/run/mysqld/mysqld.sock';
++$op{'socket'} ||= '/tmp/mysql.sock';
+ $op{'avg'} ||= 1;
+ $op{'top'} ||= 0;
+ if(have_op 'safe') { $op{'filter'} = "-*,+SELECT,+USE"; }
diff --git a/databases/mysqlsla/pkg-descr b/databases/mysqlsla/pkg-descr
new file mode 100644
index 000000000000..e45f297ee1fb
--- /dev/null
+++ b/databases/mysqlsla/pkg-descr
@@ -0,0 +1,12 @@
+mysqlsla analyzes general, slow, and raw MySQL statement logs.
+mysqlsla can read multiple MySQL general and slow logs (and logs
+containing raw SQL statements), combine them, then run various
+analyses on all the queries. In addition, mysqlsla can correlate
+the analyses so that the queries in one analysis are used as the
+basis for subsequent analyses. Other options include limiting the
+output of each analysis to the top N queries, averaging execution
+time over N runs, customizing the order in which the analyses are
+ran, statement filtering, statement pattern matching, and
+mysqldumpslow-like formatting.
+
+WWW: http://hackmysql.com/mysqlsla