aboutsummaryrefslogtreecommitdiffstats
path: root/databases/opendbx/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-05-03 03:17:12 +0800
committermiwi <miwi@FreeBSD.org>2008-05-03 03:17:12 +0800
commit6a9dd2079daae911fdc3f21ee4c8bad5da6fe064 (patch)
tree5d38e9a6d56d1722c9afdb14959d6516130aca68 /databases/opendbx/Makefile
parent34e992b1ff90d50e8ca3b222032703201cbc4310 (diff)
downloadfreebsd-ports-gnome-6a9dd2079daae911fdc3f21ee4c8bad5da6fe064.tar.gz
freebsd-ports-gnome-6a9dd2079daae911fdc3f21ee4c8bad5da6fe064.tar.zst
freebsd-ports-gnome-6a9dd2079daae911fdc3f21ee4c8bad5da6fe064.zip
- Update to 1.2.6
PR: 123232 Submitted by: Ralf van der Enden <tremere@cainites.net> (maintainer)
Diffstat (limited to 'databases/opendbx/Makefile')
-rw-r--r--databases/opendbx/Makefile23
1 files changed, 12 insertions, 11 deletions
diff --git a/databases/opendbx/Makefile b/databases/opendbx/Makefile
index b4bf37184682..604360fc417c 100644
--- a/databases/opendbx/Makefile
+++ b/databases/opendbx/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= opendbx
-PORTVERSION= 1.2.5
+PORTVERSION= 1.2.6
CATEGORIES= databases
MASTER_SITES= http://www.linuxnetworks.de/opendbx/download/
DISTNAME= ${PORTNAME}-${PORTVERSION}
@@ -14,24 +14,23 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= tremere@cainites.net
COMMENT= A C library for accessing databases with a single API
-USE_GMAKE= YES
-USE_AUTOTOOLS= libtool:15
+USE_GMAKE= YES
+USE_AUTOTOOLS= libtool:15
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS} -L../lib -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS} -L../lib -L${LOCALBASE}/lib
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --with-backends="${CONFIGURE_MODULES}"
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-USE_LDCONFIG= ${PREFIX}/lib/opendbx
+USE_LDCONFIG= ${PREFIX}/lib/opendbx
OPTIONS= MYSQL "Support for the MySQL database" on \
PGSQL "Support for the PostgreSQL database" off \
SQLITE "Support for the SQLite 2 database" off \
SQLITE3 "Support for the SQLite 3 database" off \
MSSQL "Support for the MSSQL database" off \
- SYBASE "Support for the Sybase database" off \
- GETTEXT "Support for the gettext library" off
+ SYBASE "Support for the Sybase database" off
.include <bsd.port.pre.mk>
@@ -89,10 +88,12 @@ PLIST_SUB+= WITHSYBASE=""
PLIST_SUB+= WITHSYBASE="@comment "
.endif
-.if defined(WITH_GETTEXT)
-USE_GETTEXT= YES
-.else
+.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
.endif
.include <bsd.port.post.mk>