aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-DBD-mysql
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-02-08 21:00:30 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-02-08 21:00:30 +0800
commit5a213cb7d2d2b86d245aa40554069825f9cbeca8 (patch)
tree7d4f363e58815d4b67975176e3aaf6f9da579f01 /databases/p5-DBD-mysql
parentf69bae67a071558f1fd288d3113bb2d75e4c5b18 (diff)
downloadfreebsd-ports-gnome-5a213cb7d2d2b86d245aa40554069825f9cbeca8.tar.gz
freebsd-ports-gnome-5a213cb7d2d2b86d245aa40554069825f9cbeca8.tar.zst
freebsd-ports-gnome-5a213cb7d2d2b86d245aa40554069825f9cbeca8.zip
Update to 4.045
Changes: http://search.cpan.org/dist/DBD-mysql/Changes
Diffstat (limited to 'databases/p5-DBD-mysql')
-rw-r--r--databases/p5-DBD-mysql/Makefile2
-rw-r--r--databases/p5-DBD-mysql/distinfo6
-rw-r--r--databases/p5-DBD-mysql/files/patch-dbdimp.c32
3 files changed, 4 insertions, 36 deletions
diff --git a/databases/p5-DBD-mysql/Makefile b/databases/p5-DBD-mysql/Makefile
index 94a06ba454a9..01bf2dabc47d 100644
--- a/databases/p5-DBD-mysql/Makefile
+++ b/databases/p5-DBD-mysql/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= DBD-mysql
-PORTVERSION= 4.044
+PORTVERSION= 4.045
CATEGORIES= databases perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:CAPTTOFU
diff --git a/databases/p5-DBD-mysql/distinfo b/databases/p5-DBD-mysql/distinfo
index 9dcbb7a749c4..f42f755e1bf2 100644
--- a/databases/p5-DBD-mysql/distinfo
+++ b/databases/p5-DBD-mysql/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1517047512
-SHA256 (DBD-mysql-4.044.tar.gz) = 913d569a5eb018883c1dbe97315f21b002fdf8db4e5731db458d8807a1c828ae
-SIZE (DBD-mysql-4.044.tar.gz) = 155006
+TIMESTAMP = 1518091786
+SHA256 (DBD-mysql-4.045.tar.gz) = b0382f7c64b95b1f73f6c9b0f8b380f2cc225968667ef168875c6f11c34ef669
+SIZE (DBD-mysql-4.045.tar.gz) = 155241
diff --git a/databases/p5-DBD-mysql/files/patch-dbdimp.c b/databases/p5-DBD-mysql/files/patch-dbdimp.c
deleted file mode 100644
index a6b71dc3bd13..000000000000
--- a/databases/p5-DBD-mysql/files/patch-dbdimp.c
+++ /dev/null
@@ -1,32 +0,0 @@
-From 9ea49043522f1f1387384edf42ced7ad3ec44d3a Mon Sep 17 00:00:00 2001
-From: Georg Richter <georg@mariadb.com>
-Date: Sun, 28 May 2017 15:22:09 +0200
-Subject: [PATCH] Fix for builing DBD-mysql together with MariaDB Connector/C.
- Use mysql_option function instead of accessing internal members of MYSQL
- structure.
-
----
- dbdimp.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/dbdimp.c b/dbdimp.c
-index da428ed..763b9fa 100644
---- dbdimp.c.orig 2017-02-28 13:36:40 UTC
-+++ dbdimp.c
-@@ -2139,6 +2139,7 @@ MYSQL *mysql_dr_connect(
-
- if (result)
- {
-+ my_bool reconnect= 0;
- #if MYSQL_VERSION_ID >=SERVER_PREPARE_VERSION
- /* connection succeeded. */
- /* imp_dbh == NULL when mysql_dr_connect() is called from mysql.xs
-@@ -2155,7 +2156,7 @@ MYSQL *mysql_dr_connect(
- we turn off Mysql's auto reconnect and handle re-connecting ourselves
- so that we can keep track of when this happens.
- */
-- result->reconnect=0;
-+ mysql_options(result, MYSQL_OPT_RECONNECT, &reconnect);
- }
- else {
- /*