aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-DBI/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-06-17 10:37:15 +0800
committerwill <will@FreeBSD.org>2000-06-17 10:37:15 +0800
commit6dd7168cddcf03645b7b524d0eaec762ba4a5c26 (patch)
treedde5ee054b255f449dc09b875bfef1cb678c4d3e /databases/p5-DBI/Makefile
parent09860925596143f36628cd7f462f54e90412d7ae (diff)
downloadfreebsd-ports-gnome-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.tar.gz
freebsd-ports-gnome-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.tar.zst
freebsd-ports-gnome-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.zip
Lots and lots of cleanups. Teach p5-* in general about PKGNAMEPREFIX.
Add some missing/wrong dependencies. Show how to respect CC/CFLAGS. Many miscellaneous modifications. I used more excessive hacks to force p5-Jcode and p5-WWW-Search to respect CC/CFLAGS. Patches largely done by: Christian Weisgerber <naddy@mips.inka.de>
Diffstat (limited to 'databases/p5-DBI/Makefile')
-rw-r--r--databases/p5-DBI/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/databases/p5-DBI/Makefile b/databases/p5-DBI/Makefile
index c599b36f97a1..c687ab6ceb7d 100644
--- a/databases/p5-DBI/Makefile
+++ b/databases/p5-DBI/Makefile
@@ -5,19 +5,18 @@
# $FreeBSD$
#
-PORTNAME= p5-DBI
+PORTNAME= DBI
PORTVERSION= 1.13
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DBI
-DISTNAME= DBI-${PORTVERSION}
+PKGNAMEPREFIX= p5-
MAINTAINER= vanilla@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/RPC/PlServer.pm:${PORTSDIR}/net/p5-PlRPC
-USE_PERL5= YES
-CONFIGURE_ARGS= PREFIX=${PREFIX}
+USE_PERL5= yes
MAN1= dbiproxy.1 \
dbish.1
@@ -35,6 +34,7 @@ MAN3= Bundle::DBI.3 \
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL ${CONFIGURE_ARGS}
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ PREFIX="${PREFIX}" CC="${CC}" CCFLAGS="${CFLAGS}"
.include <bsd.port.mk>