aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-DBIx-Class-BitField
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2014-07-19 01:54:31 +0800
committerzi <zi@FreeBSD.org>2014-07-19 01:54:31 +0800
commit04544da84abe791f830959783590f41fcaccb2ab (patch)
treec15a139f74a5688103cd0b2e716b362c854de507 /databases/p5-DBIx-Class-BitField
parentadea0037309964bfcccceb261a7538eaaf8579b7 (diff)
downloadfreebsd-ports-gnome-04544da84abe791f830959783590f41fcaccb2ab.tar.gz
freebsd-ports-gnome-04544da84abe791f830959783590f41fcaccb2ab.tar.zst
freebsd-ports-gnome-04544da84abe791f830959783590f41fcaccb2ab.zip
New port: databases/p5-DBIx-Class-BitField:
This module is useful if you manage data which has a lot of on/off attributes like active, inactive, deleted, important, etc. If you do not want to add an extra column for each of those attributes you can easily specify them in one integer column. A bit field is a way to store multiple bit values on one integer field. The main benefit from this module is that you can add additional attributes to your result class whithout the need to deploy or change the schema on the data base. WWW: http://search.cpan.org/dist/DBIx-Class-BitField/
Diffstat (limited to 'databases/p5-DBIx-Class-BitField')
-rw-r--r--databases/p5-DBIx-Class-BitField/Makefile21
-rw-r--r--databases/p5-DBIx-Class-BitField/distinfo2
-rw-r--r--databases/p5-DBIx-Class-BitField/pkg-descr12
-rw-r--r--databases/p5-DBIx-Class-BitField/pkg-plist6
4 files changed, 41 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Class-BitField/Makefile b/databases/p5-DBIx-Class-BitField/Makefile
new file mode 100644
index 000000000000..afb6db64092b
--- /dev/null
+++ b/databases/p5-DBIx-Class-BitField/Makefile
@@ -0,0 +1,21 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= DBIx-Class-BitField
+PORTVERSION= 0.13
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Store multiple boolean fields in one integer field
+
+RUN_DEPENDS= p5-DBIx-Class>=0:${PORTSDIR}/databases/p5-DBIx-Class
+BUILD_DEPENDS= ${RUN_DEPENDS}
+TEST_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
+ p5-File-Find-Rule>=0:${PORTSDIR}/devel/p5-File-Find-Rule
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Class-BitField/distinfo b/databases/p5-DBIx-Class-BitField/distinfo
new file mode 100644
index 000000000000..8b2d7703e32f
--- /dev/null
+++ b/databases/p5-DBIx-Class-BitField/distinfo
@@ -0,0 +1,2 @@
+SHA256 (DBIx-Class-BitField-0.13.tar.gz) = dea328c7e5e1807826c7e0b4f4c8290d967ebd0fdb970fd6939e13e3b4c539fa
+SIZE (DBIx-Class-BitField-0.13.tar.gz) = 8052
diff --git a/databases/p5-DBIx-Class-BitField/pkg-descr b/databases/p5-DBIx-Class-BitField/pkg-descr
new file mode 100644
index 000000000000..8ce32d04876a
--- /dev/null
+++ b/databases/p5-DBIx-Class-BitField/pkg-descr
@@ -0,0 +1,12 @@
+This module is useful if you manage data which has a lot of on/off attributes
+like active, inactive, deleted, important, etc. If you do not want to add an
+extra column for each of those attributes you can easily specify them in one
+integer column.
+
+A bit field is a way to store multiple bit values on one integer field.
+
+The main benefit from this module is that you can add additional attributes
+to your result class whithout the need to deploy or change the schema on the
+data base.
+
+WWW: http://search.cpan.org/dist/DBIx-Class-BitField/
diff --git a/databases/p5-DBIx-Class-BitField/pkg-plist b/databases/p5-DBIx-Class-BitField/pkg-plist
new file mode 100644
index 000000000000..6ce305430765
--- /dev/null
+++ b/databases/p5-DBIx-Class-BitField/pkg-plist
@@ -0,0 +1,6 @@
+%%PERL5_MAN3%%/DBIx::Class::BitField.3.gz
+%%PERL5_MAN3%%/DBIx::Class::ResultSet::BitField.3.gz
+%%SITE_PERL%%/DBIx/Class/BitField.pm
+%%SITE_PERL%%/DBIx/Class/ResultSet/BitField.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Class/BitField/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Class/BitField