aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-Dancer-Plugin-DBIC/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-02-13 11:25:08 +0800
committermiwi <miwi@FreeBSD.org>2011-02-13 11:25:08 +0800
commit56b360b1c03442fc4996cf2d802cf4653b803a98 (patch)
treec848d8e28185b4b0391594a8c4ac96e086f9df4a /databases/p5-Dancer-Plugin-DBIC/Makefile
parent1718c65986345348349a6aad5c68fe412460a6eb (diff)
downloadfreebsd-ports-gnome-56b360b1c03442fc4996cf2d802cf4653b803a98.tar.gz
freebsd-ports-gnome-56b360b1c03442fc4996cf2d802cf4653b803a98.tar.zst
freebsd-ports-gnome-56b360b1c03442fc4996cf2d802cf4653b803a98.zip
DBIx::Class interface for Dancer applications
WWW: http://search.cpan.org/dist/Dancer-Plugin-DBIC/ PR: ports/154725 Submitted by: "ports@c0decafe.net" <ports@c0decafe.net
Diffstat (limited to 'databases/p5-Dancer-Plugin-DBIC/Makefile')
-rw-r--r--databases/p5-Dancer-Plugin-DBIC/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/databases/p5-Dancer-Plugin-DBIC/Makefile b/databases/p5-Dancer-Plugin-DBIC/Makefile
new file mode 100644
index 000000000000..4067b6c8e8c4
--- /dev/null
+++ b/databases/p5-Dancer-Plugin-DBIC/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Dancer-Plugin-DBIC
+# Date created: 2011-02-13
+# Whom: <ports@c0decafe.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Dancer-Plugin-DBIC
+PORTVERSION= 0.1504
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@c0decafe.net
+COMMENT= DBIx::Class interface for Dancer applications
+
+BUILD_DEPENDS= p5-DBIx-Class>=0:${PORTSDIR}/databases/p5-DBIx-Class\
+ p5-DBIx-Class-Schema-Loader>=0.07002:${PORTSDIR}/databases/p5-DBIx-Class-Schema-Loader\
+ p5-Dancer>=0:${PORTSDIR}/www/p5-Dancer
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Dancer::Plugin::DBIC.3
+
+.include <bsd.port.mk>