aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-Mysql
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2007-04-03 01:54:43 +0800
committergabor <gabor@FreeBSD.org>2007-04-03 01:54:43 +0800
commit6ac2593e279e4667075e7f256a649135679c7b67 (patch)
treed4dc8901060e5ed8345db8afc0f53eb8ce647379 /databases/p5-Mysql
parenta10cdc0f9c205c26d0cc10db4811aa1d3397afa2 (diff)
downloadfreebsd-ports-gnome-6ac2593e279e4667075e7f256a649135679c7b67.tar.gz
freebsd-ports-gnome-6ac2593e279e4667075e7f256a649135679c7b67.tar.zst
freebsd-ports-gnome-6ac2593e279e4667075e7f256a649135679c7b67.zip
- Remove old Perl support from unmaintained ports in categories starting
with letter b-f
Diffstat (limited to 'databases/p5-Mysql')
-rw-r--r--databases/p5-Mysql/Makefile15
1 files changed, 3 insertions, 12 deletions
diff --git a/databases/p5-Mysql/Makefile b/databases/p5-Mysql/Makefile
index e33b6e033414..c5def43af3d4 100644
--- a/databases/p5-Mysql/Makefile
+++ b/databases/p5-Mysql/Makefile
@@ -16,7 +16,8 @@ DISTNAME= Msql-Mysql-modules-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl5 modules for accessing MySQL databases
-BUILD_DEPENDS= ${SITE_PERL}/Data/ShowTable.pm:${PORTSDIR}/devel/p5-Data-ShowTable
+BUILD_DEPENDS= ${SITE_PERL}/Data/ShowTable.pm:${PORTSDIR}/devel/p5-Data-ShowTable \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= ${BUILD_DEPENDS}
CONFLICTS= p5-DBD-mysql-* p5-DBD-mysql4[0-9]-* p5-DBD-mysql5[0-9]-*
@@ -37,14 +38,4 @@ MAN3= Bundle::DBD::mysql.3 \
pre-configure:
@${PERL} -p -i -e 's| -lgz||' ${WRKSRC}/lib/DBD/mysql/Install.pm
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-.else
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>