aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-Mysql
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>1999-01-15 05:22:29 +0800
committerdirk <dirk@FreeBSD.org>1999-01-15 05:22:29 +0800
commitab00ea47fccc9e23b676c4de97a59b629323e81f (patch)
treef34a291259b41401d1f6a6d8ffe116bd4857facb /databases/p5-Mysql
parent9c0370e88ff70c4ae290e9f21dfbf24a0ca9f2f7 (diff)
downloadfreebsd-ports-gnome-ab00ea47fccc9e23b676c4de97a59b629323e81f.tar.gz
freebsd-ports-gnome-ab00ea47fccc9e23b676c4de97a59b629323e81f.tar.zst
freebsd-ports-gnome-ab00ea47fccc9e23b676c4de97a59b629323e81f.zip
Change the dependencies to MySQL:
The default is mysql322 now, but take mysql321 if it is installed. (mysql321 installs a static libmysqlclient.a only, mysql322 installs a static and shared version of the library. Note that the build dependency to mysql321 is a no op actually. It is in there to improve understanding(?).)
Diffstat (limited to 'databases/p5-Mysql')
-rw-r--r--databases/p5-Mysql/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/databases/p5-Mysql/Makefile b/databases/p5-Mysql/Makefile
index 6ff7a2f69ffe..59c9d1772fab 100644
--- a/databases/p5-Mysql/Makefile
+++ b/databases/p5-Mysql/Makefile
@@ -3,7 +3,7 @@
# Date created: September 29th 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
-# $Id: Makefile,v 1.13 1998/12/26 21:28:59 asami Exp $
+# $Id: Makefile,v 1.14 1999/01/08 20:33:45 billf Exp $
#
DISTNAME= Msql-Mysql-modules-1.2003
@@ -14,9 +14,13 @@ MASTER_SITE_SUBDIR= DBD
MAINTAINER= vanilla@FreeBSD.ORG
-BUILD_DEPENDS= ${PREFIX}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql321 \
- ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/Data/ShowTable.pm:${PORTSDIR}/devel/p5-Data-ShowTable \
+BUILD_DEPENDS= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/Data/ShowTable.pm:${PORTSDIR}/devel/p5-Data-ShowTable \
${PREFIX}/lib/perl5/site_perl/${PERL_VER}/i386-freebsd/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.if !exists(${PREFIX}/lib/mysql/libmysqlclient.a) || exists(${PREFIX}/lib/mysql/libmysqlclient.so)
+LIB_DEPENDS= mysqlclient.5:${PORTSDIR}/databases/mysql322
+.else
+BUILD_DEPENDS+= ${PREFIX}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql321
+.endif
CONFIGURE_ENV= PREFIX=${PREFIX} MYSQL_HOME=${PREFIX} IN_MYSQL_DISTRIBUTION=1
USE_PERL5= YES