aboutsummaryrefslogtreecommitdiffstats
path: root/databases/pecl-mongo/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2015-02-20 00:53:39 +0800
committervanilla <vanilla@FreeBSD.org>2015-02-20 00:53:39 +0800
commitf0e335f00da1e955419b131d3d594c817265debe (patch)
tree9b4aaad42372ce101e32074c80f1481f8aa149cd /databases/pecl-mongo/Makefile
parent24ca89460a971fe8c1159df4d1292d27447bfd81 (diff)
downloadfreebsd-ports-gnome-f0e335f00da1e955419b131d3d594c817265debe.tar.gz
freebsd-ports-gnome-f0e335f00da1e955419b131d3d594c817265debe.tar.zst
freebsd-ports-gnome-f0e335f00da1e955419b131d3d594c817265debe.zip
1: Upgrade to 1.6.3.
2: strip binary. 3: switch to USES=tar:tgz
Diffstat (limited to 'databases/pecl-mongo/Makefile')
-rw-r--r--databases/pecl-mongo/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/databases/pecl-mongo/Makefile b/databases/pecl-mongo/Makefile
index 1937caa4ee63..8c940d21379c 100644
--- a/databases/pecl-mongo/Makefile
+++ b/databases/pecl-mongo/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= mongo
-PORTVERSION= 1.6.2
+PORTVERSION= 1.6.3
CATEGORIES= databases pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
-EXTRACT_SUFX= .tgz
DIST_SUBDIR= PECL
MAINTAINER= ports@FreeBSD.org
@@ -14,10 +13,14 @@ COMMENT= PECL classes for Mongo Database Driver
LICENSE= APACHE20
+USES= tar:tgz
USE_PHP= spl
USE_PHP_BUILD= yes
USE_PHPEXT= yes
CONFIGURE_ARGS= --enable-mongo
SUB_FILES= pkg-message
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/php/${PHP_EXT_DIR}/mongo.so
+
.include <bsd.port.mk>