aboutsummaryrefslogtreecommitdiffstats
path: root/databases/pgrouting/Makefile
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2014-01-17 23:59:52 +0800
committerdanilo <danilo@FreeBSD.org>2014-01-17 23:59:52 +0800
commitfcf3fec0437bd2b43f31ad8bcea80df32391bf13 (patch)
treea4882752dbe130cc0adfaf28f29c90c2958105d8 /databases/pgrouting/Makefile
parent52a138d545d70be02dda493976221004a285af6c (diff)
downloadfreebsd-ports-gnome-fcf3fec0437bd2b43f31ad8bcea80df32391bf13.tar.gz
freebsd-ports-gnome-fcf3fec0437bd2b43f31ad8bcea80df32391bf13.tar.zst
freebsd-ports-gnome-fcf3fec0437bd2b43f31ad8bcea80df32391bf13.zip
- Add new port databases/pgrouting
pgRouting extends the PostGIS / PostgreSQL geospatial database to provide geospatial routing functionality. PR: ports/185483 Submitted by: lbartoletti <coder@tuxfamily.org>
Diffstat (limited to 'databases/pgrouting/Makefile')
-rw-r--r--databases/pgrouting/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/databases/pgrouting/Makefile b/databases/pgrouting/Makefile
new file mode 100644
index 000000000000..8c8dc14b554f
--- /dev/null
+++ b/databases/pgrouting/Makefile
@@ -0,0 +1,52 @@
+# Created by: lbartoletti <coder@tuxfamily.org>
+# $FreeBSD$
+
+PORTNAME= pgrouting
+PORTVERSION= 2.0.0
+CATEGORIES= databases geography
+MASTER_SITES= https://github.com/pgRouting/${PORTNAME}/archive/
+DISTFILES= v${PORTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= coder@tuxfamily.org
+COMMENT= Extension to PostGIS to provide geospatial routing functionality
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libboost_system.so:${PORTSDIR}/devel/boost-libs\
+ libCGAL.so:${PORTSDIR}/math/cgal \
+ libgmp.so:${PORTSDIR}/math/gmp
+RUN_DEPENDS= ${LOCALBASE}/share/postgresql/contrib/postgis-2.1/postgis.sql:${PORTSDIR}/databases/postgis21
+
+USES= cmake pkgconfig
+USE_PGSQL= yes
+USE_LDCONFIG= yes
+
+FETCH_ARGS= -Fpr
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PGSQL_VER= ${DEFAULT_PGSQL_VER}
+
+.if ${PGSQL_VER} >= 91
+EXT_FILES= pgrouting--2.0.0.sql \
+ pgrouting.control \
+ pgrouting_dd_legacy.sql \
+ pgrouting--2.0.0.sql.in \
+ pgrouting.sql \
+ pgrouting_legacy.sql
+PLIST_DIRSTRY+= share/postgresql/extension
+.for f in ${EXT_FILES}
+PLIST_FILES+= share/postgresql/extension/${f}
+.endfor
+.endif
+
+post-install:
+.if ${PGSQL_VER} >= 91
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/postgresql/extension
+.for f in ${EXT_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/lib/${f} ${STAGEDIR}${PREFIX}/share/postgresql/extension/
+.endfor
+.endif
+
+.include <bsd.port.mk>