aboutsummaryrefslogtreecommitdiffstats
path: root/databases/php52-sqlite
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-04-24 06:25:27 +0800
committerdinoex <dinoex@FreeBSD.org>2010-04-24 06:25:27 +0800
commite31bdca8b45a588f5dd0e8381dc0e5166fc688a2 (patch)
tree8f14052759d5cd5489c0c7e5ca0b7722fa746f3c /databases/php52-sqlite
parent4a5ff575aab5a6961ca7f693683d3e394a032b43 (diff)
downloadfreebsd-ports-gnome-e31bdca8b45a588f5dd0e8381dc0e5166fc688a2.tar.gz
freebsd-ports-gnome-e31bdca8b45a588f5dd0e8381dc0e5166fc688a2.tar.zst
freebsd-ports-gnome-e31bdca8b45a588f5dd0e8381dc0e5166fc688a2.zip
- PHP 5.2 slave port
PR: 145772 Submitted by: Alex Keda
Diffstat (limited to 'databases/php52-sqlite')
-rw-r--r--databases/php52-sqlite/Makefile14
-rw-r--r--databases/php52-sqlite/files/patch-config.m444
2 files changed, 58 insertions, 0 deletions
diff --git a/databases/php52-sqlite/Makefile b/databases/php52-sqlite/Makefile
new file mode 100644
index 000000000000..044c6bd3c69a
--- /dev/null
+++ b/databases/php52-sqlite/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-sqlite
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -sqlite
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php52-sqlite/files/patch-config.m4 b/databases/php52-sqlite/files/patch-config.m4
new file mode 100644
index 000000000000..c8cf2bc00557
--- /dev/null
+++ b/databases/php52-sqlite/files/patch-config.m4
@@ -0,0 +1,44 @@
+--- config.m4.orig Wed Nov 30 05:50:03 2005
++++ config.m4 Tue Jan 17 12:51:21 2006
+@@ -48,14 +48,6 @@
+
+
+ if test "$PHP_SQLITE" != "no"; then
+- if test "$PHP_PDO" != "no"; then
+- PHP_CHECK_PDO_INCLUDES([], [AC_MSG_WARN([Cannot find php_pdo_driver.h.])])
+- if test -n "$pdo_inc_path"; then
+- AC_DEFINE([PHP_SQLITE2_HAVE_PDO], [1], [Have PDO])
+- pdo_inc_path="-I$pdo_inc_path"
+- fi
+- fi
+-
+ if test "$PHP_SQLITE" != "yes"; then
+ SEARCH_PATH="/usr/local /usr"
+ SEARCH_FOR="/include/sqlite.h"
+@@ -85,13 +77,12 @@
+ -L$SQLITE_DIR/$PHP_LIBDIR -lm
+ ])
+ SQLITE_MODULE_TYPE=external
+- PHP_SQLITE_CFLAGS=$pdo_inc_path
+ sqlite_extra_sources="libsqlite/src/encode.c"
+ else
+ # use bundled library
+ PHP_PROG_LEMON
+ SQLITE_MODULE_TYPE=builtin
+- PHP_SQLITE_CFLAGS="-I@ext_srcdir@/libsqlite/src -I@ext_builddir@/libsqlite/src $pdo_inc_path"
++ PHP_SQLITE_CFLAGS="-I@ext_srcdir@/libsqlite/src -I@ext_builddir@/libsqlite/src"
+ sqlite_extra_sources="libsqlite/src/opcodes.c \
+ libsqlite/src/parse.c libsqlite/src/encode.c \
+ libsqlite/src/auth.c libsqlite/src/btree.c libsqlite/src/build.c \
+@@ -109,10 +100,9 @@
+ dnl
+ dnl Common for both bundled/external
+ dnl
+- sqlite_sources="sqlite.c sess_sqlite.c pdo_sqlite2.c $sqlite_extra_sources"
++ sqlite_sources="sqlite.c sess_sqlite.c $sqlite_extra_sources"
+ PHP_NEW_EXTENSION(sqlite, $sqlite_sources, $ext_shared,,$PHP_SQLITE_CFLAGS)
+ PHP_ADD_EXTENSION_DEP(sqlite, spl, true)
+- PHP_ADD_EXTENSION_DEP(sqlite, pdo, true)
+
+ PHP_ADD_MAKEFILE_FRAGMENT
+ PHP_SUBST(SQLITE_SHARED_LIBADD)