aboutsummaryrefslogtreecommitdiffstats
path: root/databases/postgresql-pltcl
diff options
context:
space:
mode:
authorgirgen <girgen@FreeBSD.org>2011-07-26 21:13:53 +0800
committergirgen <girgen@FreeBSD.org>2011-07-26 21:13:53 +0800
commit2001607b74746e03ba4d79731f60e4cfa4897aea (patch)
tree39c19f4ef3202665c076bc2eae71bf68c48ceffc /databases/postgresql-pltcl
parenta12822e550b1fa90c32dda6be243620554558b58 (diff)
downloadfreebsd-ports-gnome-2001607b74746e03ba4d79731f60e4cfa4897aea.tar.gz
freebsd-ports-gnome-2001607b74746e03ba4d79731f60e4cfa4897aea.tar.zst
freebsd-ports-gnome-2001607b74746e03ba4d79731f60e4cfa4897aea.zip
accept version 9.1beta3
PR: 158740
Diffstat (limited to 'databases/postgresql-pltcl')
-rw-r--r--databases/postgresql-pltcl/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/databases/postgresql-pltcl/Makefile b/databases/postgresql-pltcl/Makefile
index 93941f186270..1a7e5e64b3af 100644
--- a/databases/postgresql-pltcl/Makefile
+++ b/databases/postgresql-pltcl/Makefile
@@ -28,9 +28,9 @@ SED?= /usr/bin/sed
# Setting/finding PostgreSQL version we want.
.if exists(${LOCALBASE}/bin/postmaster)
-PGSQL_VER!= ${LOCALBASE}/bin/postmaster -V | ${SED} -n 's/.*PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\2/p'
+PGSQL_VER!= ${LOCALBASE}/bin/postmaster -V | ${SED} -n 's/.*PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)[^0-9].*/\1\2/p'
.elif exists(${LOCALBASE}/bin/pg_config)
-PGSQL_VER!= ${LOCALBASE}/bin/pg_config --version | ${SED} -n 's/PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\2/p'
+PGSQL_VER!= ${LOCALBASE}/bin/pg_config --version | ${SED} -n 's/PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)[^0-9].*/\1\2/p'
.else
PGSQL_VER= ${DEFAULT_PGSQL_VER}
.endif