aboutsummaryrefslogtreecommitdiffstats
path: root/databases/py-MySQL
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2000-04-24 00:24:06 +0800
committervanilla <vanilla@FreeBSD.org>2000-04-24 00:24:06 +0800
commit8dd2e7ab0bcef41e345c264e872a95560f946742 (patch)
tree067538c158d8c084fa8ae8acfe06395c8cd033bd /databases/py-MySQL
parentefa4365dfb821ed213df1a1369696e6f32cc3605 (diff)
downloadfreebsd-ports-gnome-8dd2e7ab0bcef41e345c264e872a95560f946742.tar.gz
freebsd-ports-gnome-8dd2e7ab0bcef41e345c264e872a95560f946742.tar.zst
freebsd-ports-gnome-8dd2e7ab0bcef41e345c264e872a95560f946742.zip
Cleanup of build process of the py-MySQL port. Previously port used
custom Makefile for this purpose, which led to resulting module being bloated (~600K) by linking all Python code from libpython1.5 into it. With this patch the module will use standard Python's way to build supplemental modules, which should generally be cleaner. Other good sideeffect is that after this patch resulting module is only 20K in size. PR: ports/17893 Submitted by: Maxim Sobolev <sobomax@altavista.net>
Diffstat (limited to 'databases/py-MySQL')
-rw-r--r--databases/py-MySQL/Makefile17
-rw-r--r--databases/py-MySQL/files/Setup2
2 files changed, 11 insertions, 8 deletions
diff --git a/databases/py-MySQL/Makefile b/databases/py-MySQL/Makefile
index 14bff0feb40e..bbb83917508c 100644
--- a/databases/py-MySQL/Makefile
+++ b/databases/py-MySQL/Makefile
@@ -17,18 +17,19 @@ BUILD_DEPENDS= python:${PORTSDIR}/lang/python
LIB_DEPENDS= mysqlclient.6:${PORTSDIR}/databases/mysql322-client
RUN_DEPENDS= python:${PORTSDIR}/lang/python
-pre-build:
- ${CP} ${FILESDIR}/Makefile ${WRKSRC}/Makefile
+ALL_TARGET= MySQLmodule.so
+
+pre-configure:
+ ${CP} ${FILESDIR}/Setup ${WRKSRC}/Setup
+ ${LN} -s ${LOCALBASE}/lib/python1.5/config/Makefile.pre.in ${WRKSRC}/
+
+do-configure:
+ cd ${WRKSRC} && ${MAKE} -f Makefile.pre.in boot
-do-install:
- ${INSTALL_DATA} ${WRKSRC}/MySQLmodule.so ${PREFIX}/lib/python1.5/site-packages
.if !defined(NOPORTDOCS)
+post-install:
${MKDIR} ${PREFIX}/share/doc/py-MySQL
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/py-MySQL
-.endif
-
-post-install:
-.if !defined(NOPORTDOCS)
${ECHO} "share/doc/py-MySQL/README" >> ${TMPPLIST}
${ECHO} "@dirrm share/doc/py-MySQL" >> ${TMPPLIST}
.endif
diff --git a/databases/py-MySQL/files/Setup b/databases/py-MySQL/files/Setup
new file mode 100644
index 000000000000..bc8973ba58f9
--- /dev/null
+++ b/databases/py-MySQL/files/Setup
@@ -0,0 +1,2 @@
+*shared*
+MySQL MySQLmodule.c -I${LOCALBASE}/include/mysql -L${LOCALBASE}/lib/mysql -lmysqlclient