aboutsummaryrefslogtreecommitdiffstats
path: root/databases/py-sqlobject
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-11-11 05:16:00 +0800
committeritetcu <itetcu@FreeBSD.org>2006-11-11 05:16:00 +0800
commit8c3522b842d1c08691497e1e758e879387bfe96a (patch)
tree790ab56b6bdd388f8a56b0397beff41319a90c10 /databases/py-sqlobject
parenta1e794b7a070b755786074e4259f24daca8905cd (diff)
downloadfreebsd-ports-gnome-8c3522b842d1c08691497e1e758e879387bfe96a.tar.gz
freebsd-ports-gnome-8c3522b842d1c08691497e1e758e879387bfe96a.tar.zst
freebsd-ports-gnome-8c3522b842d1c08691497e1e758e879387bfe96a.zip
OPTIONally depend on PostgreSQL, MySQL, SQLite
PR: ports/104726 Submitted by: "Choe, Cheng-Dae" (maintainer)
Diffstat (limited to 'databases/py-sqlobject')
-rw-r--r--databases/py-sqlobject/Makefile34
1 files changed, 27 insertions, 7 deletions
diff --git a/databases/py-sqlobject/Makefile b/databases/py-sqlobject/Makefile
index cb6960ce58c2..9e9977a8dc35 100644
--- a/databases/py-sqlobject/Makefile
+++ b/databases/py-sqlobject/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sqlobject
PORTVERSION= 0.7.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases python
MASTER_SITES= http://cheeseshop.python.org/packages/source/S/SQLObject/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,11 +16,6 @@ DISTNAME= SQLObject-${PORTVERSION}
MAINTAINER= whitekid@gmail.com
COMMENT= A python object for manipulation with SQL table row
-# Someone will add SQLite, Firebird and DBMConnection support things.
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/formencode/__init__.py:${PORTSDIR}/www/py-formencode \
- ${PYTHON_SITELIBDIR}/MySQLdb/__init__.py:${PORTSDIR}/databases/py-MySQLdb \
- ${PYTHON_SITELIBDIR}/psycopgmodule.so:${PORTSDIR}/databases/py-psycopg
-
USE_PYTHON= yes
USE_PYDISTUTILS= yes
@@ -29,6 +24,31 @@ EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
PORTDOCS= *
+OPTIONS= MYSQL "MySQL supports" off \
+ PGSQL "PostgreSQL Supports" off \
+ SQLITE "SQLite Supports" off
+
+.include <bsd.port.pre.mk>
+
+# bypass infrastructure bug
+OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
+
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/formencode/__init__.py:${PORTSDIR}/www/py-formencode
+
+.if defined(WITH_MYSQL)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/MySQLdb/__init__.py:${PORTSDIR}/databases/py-MySQLdb
+.endif
+
+.if defined(WITH_PGSQL)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psycopgmodule.so:${PORTSDIR}/databases/py-psycopg
+.endif
+
+.if defined(WITH_SQLITE)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite20
+.endif
+
+# currently FireBird, MaxDB(SAP), Sybase, MSSQL, ADODB are not supported
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
@@ -36,4 +56,4 @@ post-install:
${CP} -r ${WRKSRC}/docs/* ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>