aboutsummaryrefslogtreecommitdiffstats
path: root/databases/redis-devel
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2019-11-06 05:38:26 +0800
committerSergey A. Osokin <osa@FreeBSD.org>2019-11-06 05:38:26 +0800
commit41e56db75f1139b60b505a970726239ea732be5a (patch)
tree15a63789ec33f44f173727b7638f2c132f72efd4 /databases/redis-devel
parent43636d3ec6bf879461f4a5f0114151256f803f61 (diff)
downloadfreebsd-ports-gnome-41e56db75f1139b60b505a970726239ea732be5a.tar.gz
freebsd-ports-gnome-41e56db75f1139b60b505a970726239ea732be5a.tar.zst
freebsd-ports-gnome-41e56db75f1139b60b505a970726239ea732be5a.zip
Update from 5.0.5 to 5.0.6.
Regenerate the patches to make portlint(1) happier. <ChangeLog> Upgrade urgency CRITICAL: Only in case of exposed instances to untrusted users. This Redis release, 5.0.6, is a bugfix and enhancement release. The most important bugfix is a corruption related to the HyperLogLog. A malformed HyperLogLog string could cause an invalid access to the memory. At a first glance the vulnerability appears to be not exploitable but just a DoS. The way to trigger the issue is complex, we'll not provide any information about how to do that for the users safety. Other significant changes in this release: * New modules APIs merged from Redis unstable to Redis 5. * Some memory optimization related to objects creation. * Fixes to flushSlaveOutputBuffer() that make sure that SHUTDOWN will transfer pending buffers to replicas. </ChangeLog>
Diffstat (limited to 'databases/redis-devel')
-rw-r--r--databases/redis-devel/Makefile7
-rw-r--r--databases/redis-devel/distinfo6
-rw-r--r--databases/redis-devel/files/patch-deps-Makefile8
-rw-r--r--databases/redis-devel/files/patch-deps-hiredis-Makefile16
-rw-r--r--databases/redis-devel/files/patch-deps-hiredis-net.c12
-rw-r--r--databases/redis-devel/files/patch-deps-linenoise-Makefile4
-rw-r--r--databases/redis-devel/files/patch-deps_lua_src_lua__cjson.c (renamed from databases/redis-devel/files/patch-src-lua_cjson.c)4
-rw-r--r--databases/redis-devel/files/patch-redis.conf12
-rw-r--r--databases/redis-devel/files/patch-src-Makefile26
-rw-r--r--databases/redis-devel/files/patch-src-mkreleasehdr.sh4
10 files changed, 49 insertions, 50 deletions
diff --git a/databases/redis-devel/Makefile b/databases/redis-devel/Makefile
index 0e253364f3d0..7108890743db 100644
--- a/databases/redis-devel/Makefile
+++ b/databases/redis-devel/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= redis
-DISTVERSION= 5.0.5
-PORTREVISION= 1
+DISTVERSION= 5.0.6
CATEGORIES= databases
MASTER_SITES= http://download.redis.io/releases/
PKGNAMESUFFIX= -devel
@@ -97,7 +96,7 @@ post-patch:
.if ${PORT_OPTIONS:MJEMALLOC}
@${REINPLACE_CMD} '35s!Linux!FreeBSD!g' ${WRKSRC}/src/Makefile
.endif
-.if ${PORT_OPTIONS:MLUAJIT} || ${PORT_OPTIONS:MLUA}
+.if ${PORT_OPTIONS:MLUA} || ${PORT_OPTIONS:MLUAJIT}
@cd ${WRKSRC}/deps/lua/src && ${CP} fpconv.* lua_* strbuf.* ${WRKSRC}/src/
.endif
.if ${CHOSEN_COMPILER_TYPE} == gcc && ${COMPILER_VERSION} <= 42
@@ -122,4 +121,4 @@ do-install:
do-test:
@cd ${WRKSRC} && ${TCLSH} tests/test_helper.tcl
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/databases/redis-devel/distinfo b/databases/redis-devel/distinfo
index cdcc4f60fde9..7e271b43b140 100644
--- a/databases/redis-devel/distinfo
+++ b/databases/redis-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1558004355
-SHA256 (redis-5.0.5.tar.gz) = 2139009799d21d8ff94fc40b7f36ac46699b9e1254086299f8d3b223ca54a375
-SIZE (redis-5.0.5.tar.gz) = 1975750
+TIMESTAMP = 1572268200
+SHA256 (redis-5.0.6.tar.gz) = 6624841267e142c5d5d5be292d705f8fb6070677687c5aad1645421a936d22b3
+SIZE (redis-5.0.6.tar.gz) = 1979873
diff --git a/databases/redis-devel/files/patch-deps-Makefile b/databases/redis-devel/files/patch-deps-Makefile
index e252c929c246..385f0a116c6d 100644
--- a/databases/redis-devel/files/patch-deps-Makefile
+++ b/databases/redis-devel/files/patch-deps-Makefile
@@ -1,6 +1,6 @@
---- deps/Makefile.orig 2016-02-02 19:38:43.438304000 -0500
-+++ deps/Makefile 2016-02-02 19:40:05.911356000 -0500
-@@ -59,7 +59,7 @@
+--- deps/Makefile.orig 2019-09-25 10:40:18 UTC
++++ deps/Makefile
+@@ -58,7 +58,7 @@ ifeq ($(uname_S),SunOS)
LUA_CFLAGS= -D__C99FEATURES__=1
endif
@@ -9,7 +9,7 @@
LUA_LDFLAGS+= $(LDFLAGS)
# lua's Makefile defines AR="ar rcu", which is unusual, and makes it more
# challenging to cross-compile lua (and redis). These defines make it easier
-@@ -69,7 +69,7 @@
+@@ -68,7 +68,7 @@ ARFLAGS=rcu
lua: .make-prerequisites
@printf '%b %b\n' $(MAKECOLOR)MAKE$(ENDCOLOR) $(BINCOLOR)$@$(ENDCOLOR)
diff --git a/databases/redis-devel/files/patch-deps-hiredis-Makefile b/databases/redis-devel/files/patch-deps-hiredis-Makefile
index 705bc2fb97e0..a74d7b4cc81c 100644
--- a/databases/redis-devel/files/patch-deps-hiredis-Makefile
+++ b/databases/redis-devel/files/patch-deps-hiredis-Makefile
@@ -1,6 +1,6 @@
---- deps/hiredis/Makefile.orig 2017-05-01 19:46:31.733229000 -0400
-+++ deps/hiredis/Makefile 2017-05-01 19:48:37.150358000 -0400
-@@ -15,7 +15,7 @@
+--- deps/hiredis/Makefile.orig 2019-09-25 10:40:18 UTC
++++ deps/hiredis/Makefile
+@@ -15,7 +15,7 @@ HIREDIS_PATCH=$(shell grep HIREDIS_PATCH hiredis.h | a
HIREDIS_SONAME=$(shell grep HIREDIS_SONAME hiredis.h | awk '{print $$3}')
# Installation related variables and target
@@ -9,7 +9,7 @@
INCLUDE_PATH?=include/hiredis
LIBRARY_PATH?=lib
PKGCONF_PATH?=pkgconfig
-@@ -38,10 +38,10 @@
+@@ -38,10 +38,10 @@ export REDIS_TEST_CONFIG
# Fallback to gcc when $CC is not in $PATH.
CC:=$(shell sh -c 'type $(CC) >/dev/null 2>/dev/null && echo $(CC) || echo gcc')
CXX:=$(shell sh -c 'type $(CXX) >/dev/null 2>/dev/null && echo $(CXX) || echo g++')
@@ -23,10 +23,11 @@
REAL_LDFLAGS=$(LDFLAGS) $(ARCH)
DYLIBSUFFIX=so
-@@ -60,6 +60,15 @@
+@@ -59,6 +59,15 @@ ifeq ($(uname_S),SunOS)
+ REAL_LDFLAGS+= -ldl -lnsl -lsocket
DYLIB_MAKE_CMD=$(CC) -G -o $(DYLIBNAME) -h $(DYLIB_MINOR_NAME) $(LDFLAGS)
INSTALL= cp -r
- endif
++endif
+ifeq ($(uname_S),FreeBSD)
+ CFLAGS?=$(CFLAGS)
+ CCLINK?=-pthread
@@ -35,7 +36,6 @@
+ DYLIB_MAKE_CMD?=$(CC) -o ${DYLIBNAME} ${OBJ}
+ STLIBNAME?=libhiredis.a
+ STLIB_MAKE_CMD?=ar rcs ${STLIBNAME} ${OBJ}
-+endif
+ endif
ifeq ($(uname_S),Darwin)
DYLIBSUFFIX=dylib
- DYLIB_MINOR_NAME=$(LIBNAME).$(HIREDIS_SONAME).$(DYLIBSUFFIX)
diff --git a/databases/redis-devel/files/patch-deps-hiredis-net.c b/databases/redis-devel/files/patch-deps-hiredis-net.c
index b230b0b91e4c..dc390fab3057 100644
--- a/databases/redis-devel/files/patch-deps-hiredis-net.c
+++ b/databases/redis-devel/files/patch-deps-hiredis-net.c
@@ -1,6 +1,6 @@
---- deps/hiredis/net.c.orig 2017-04-22 07:23:27.000000000 -0400
-+++ deps/hiredis/net.c 2017-05-05 20:02:09.292479000 -0400
-@@ -135,13 +135,12 @@
+--- deps/hiredis/net.c.orig 2019-09-25 10:40:18 UTC
++++ deps/hiredis/net.c
+@@ -135,13 +135,12 @@ int redisKeepAlive(redisContext *c, int interval) {
val = interval;
@@ -16,7 +16,7 @@
val = interval;
if (setsockopt(fd, IPPROTO_TCP, TCP_KEEPIDLE, &val, sizeof(val)) < 0) {
__redisSetError(c,REDIS_ERR_OTHER,strerror(errno));
-@@ -160,6 +159,27 @@
+@@ -160,6 +159,27 @@ int redisKeepAlive(redisContext *c, int interval) {
__redisSetError(c,REDIS_ERR_OTHER,strerror(errno));
return REDIS_ERR;
}
@@ -44,7 +44,7 @@
#endif
#endif
-@@ -431,7 +451,7 @@
+@@ -431,7 +451,7 @@ int redisContextConnectUnix(redisContext *c, const cha
struct sockaddr_un sa;
long timeout_msec = -1;
@@ -53,7 +53,7 @@
return REDIS_ERR;
if (redisSetBlocking(c,0) != REDIS_OK)
return REDIS_ERR;
-@@ -456,7 +476,7 @@
+@@ -456,7 +476,7 @@ int redisContextConnectUnix(redisContext *c, const cha
if (redisContextTimeoutMsec(c,&timeout_msec) != REDIS_OK)
return REDIS_ERR;
diff --git a/databases/redis-devel/files/patch-deps-linenoise-Makefile b/databases/redis-devel/files/patch-deps-linenoise-Makefile
index 8f39994aa201..aef0f10966af 100644
--- a/databases/redis-devel/files/patch-deps-linenoise-Makefile
+++ b/databases/redis-devel/files/patch-deps-linenoise-Makefile
@@ -1,5 +1,5 @@
---- deps/linenoise/Makefile.orig 2015-01-17 22:13:25.000000000 +0300
-+++ deps/linenoise/Makefile 2015-01-17 22:13:45.000000000 +0300
+--- deps/linenoise/Makefile.orig 2019-09-25 10:40:18 UTC
++++ deps/linenoise/Makefile
@@ -1,10 +1,10 @@
STD=
WARN= -Wall
diff --git a/databases/redis-devel/files/patch-src-lua_cjson.c b/databases/redis-devel/files/patch-deps_lua_src_lua__cjson.c
index e4b95cb884ff..0bb150504c67 100644
--- a/databases/redis-devel/files/patch-src-lua_cjson.c
+++ b/databases/redis-devel/files/patch-deps_lua_src_lua__cjson.c
@@ -1,5 +1,5 @@
---- deps/lua/src/lua_cjson.c.orig 2016-12-04 20:49:41.925218000 -0500
-+++ deps/lua/src/lua_cjson.c 2016-12-04 20:49:59.728885000 -0500
+--- deps/lua/src/lua_cjson.c.orig 2019-09-25 10:40:18 UTC
++++ deps/lua/src/lua_cjson.c
@@ -46,7 +46,9 @@
#include "strbuf.h"
#include "fpconv.h"
diff --git a/databases/redis-devel/files/patch-redis.conf b/databases/redis-devel/files/patch-redis.conf
index 5e8d12a9e10b..187a9dfd5d20 100644
--- a/databases/redis-devel/files/patch-redis.conf
+++ b/databases/redis-devel/files/patch-redis.conf
@@ -1,6 +1,6 @@
---- redis.conf.orig 2016-06-17 09:15:21.000000000 -0400
-+++ redis.conf 2016-06-18 11:58:19.871082000 -0400
-@@ -125,7 +125,7 @@
+--- redis.conf.orig 2019-09-25 10:40:18 UTC
++++ redis.conf
+@@ -133,7 +133,7 @@ tcp-keepalive 300
# By default Redis does not run as a daemon. Use 'yes' if you need it.
# Note that Redis will write a pid file in /var/run/redis.pid when daemonized.
@@ -9,7 +9,7 @@
# If you run Redis from upstart or systemd, Redis can interact with your
# supervision tree. Options:
-@@ -147,7 +147,7 @@
+@@ -155,7 +155,7 @@ supervised no
#
# Creating a pid file is best effort: if Redis is not able to create it
# nothing bad happens, the server will start and run normally.
@@ -18,7 +18,7 @@
# Specify the server verbosity level.
# This can be one of:
-@@ -160,7 +160,7 @@
+@@ -168,7 +168,7 @@ loglevel notice
# Specify the log file name. Also the empty string can be used to force
# Redis to log on the standard output. Note that if you use standard
# output for logging but daemonize, logs will be sent to /dev/null
@@ -27,7 +27,7 @@
# To enable logging to the system logger, just set 'syslog-enabled' to yes,
# and optionally update the other syslog parameters to suit your needs.
-@@ -244,7 +244,7 @@
+@@ -260,7 +260,7 @@ dbfilename dump.rdb
# The Append Only File will also be created inside this directory.
#
# Note that you must specify a directory here, not a file name.
diff --git a/databases/redis-devel/files/patch-src-Makefile b/databases/redis-devel/files/patch-src-Makefile
index bfbe89b2d241..039f8f0dbe1e 100644
--- a/databases/redis-devel/files/patch-src-Makefile
+++ b/databases/redis-devel/files/patch-src-Makefile
@@ -1,7 +1,7 @@
---- src/Makefile.orig 2015-04-01 17:01:44.000000000 +0300
-+++ src/Makefile 2015-04-07 21:30:22.464962000 +0300
-@@ -22,7 +22,7 @@
- WARN=-Wall -W
+--- src/Makefile.orig 2019-09-25 10:40:18 UTC
++++ src/Makefile
+@@ -29,7 +29,7 @@ endif
+ WARN=-Wall -W -Wno-missing-field-initializers
OPT=$(OPTIMIZATION)
-PREFIX?=/usr/local
@@ -9,7 +9,7 @@
INSTALL_BIN=$(PREFIX)/bin
INSTALL=install
-@@ -52,7 +52,6 @@
+@@ -75,7 +75,6 @@ endif
FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) $(REDIS_CFLAGS)
FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
FINAL_LIBS=-lm
@@ -17,9 +17,9 @@
ifeq ($(uname_S),SunOS)
# SunOS
-@@ -63,6 +62,11 @@
- ifeq ($(uname_S),Darwin)
- # Darwin (nothing to do)
+@@ -94,6 +93,11 @@ ifeq ($(uname_S),Darwin)
+ # Darwin
+ FINAL_LIBS+= -ldl
else
+ifeq ($(uname_S),FreeBSD)
+ # FreeBSD
@@ -29,11 +29,11 @@
ifeq ($(uname_S),AIX)
# AIX
FINAL_LDFLAGS+= -Wl,-bexpall
-@@ -75,6 +79,7 @@
+@@ -120,6 +124,7 @@ else
+ # All the other OSes (notably Linux)
+ FINAL_LDFLAGS+= -rdynamic
+ FINAL_LIBS+=-ldl -pthread -lrt
++endif
endif
endif
endif
-+endif
- # Include paths to dependencies
- FINAL_CFLAGS+= -I../deps/hiredis -I../deps/linenoise -I../deps/lua/src
-
diff --git a/databases/redis-devel/files/patch-src-mkreleasehdr.sh b/databases/redis-devel/files/patch-src-mkreleasehdr.sh
index 15865ddb736b..05176402b0c0 100644
--- a/databases/redis-devel/files/patch-src-mkreleasehdr.sh
+++ b/databases/redis-devel/files/patch-src-mkreleasehdr.sh
@@ -1,5 +1,5 @@
---- src/mkreleasehdr.sh.orig 2018-09-06 07:04:23.000000000 -0400
-+++ src/mkreleasehdr.sh 2018-09-07 18:05:03.013274000 -0400
+--- src/mkreleasehdr.sh.orig 2019-09-25 10:40:18 UTC
++++ src/mkreleasehdr.sh
@@ -1,6 +1,6 @@
#!/bin/sh
-GIT_SHA1=`(git show-ref --head --hash=8 2> /dev/null || echo 00000000) | head -n1`