aboutsummaryrefslogtreecommitdiffstats
path: root/databases/redis
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2011-02-25 15:54:55 +0800
committerSergey A. Osokin <osa@FreeBSD.org>2011-02-25 15:54:55 +0800
commit14905080a5d18aa0c1d6a25f04752a06c317cacc (patch)
treea3850500ad1f51224f3a85e06d9dab9b57b54719 /databases/redis
parent5e9f42cbda7723e209ee352f41df8fd3d7d1ee28 (diff)
downloadfreebsd-ports-gnome-14905080a5d18aa0c1d6a25f04752a06c317cacc.tar.gz
freebsd-ports-gnome-14905080a5d18aa0c1d6a25f04752a06c317cacc.tar.zst
freebsd-ports-gnome-14905080a5d18aa0c1d6a25f04752a06c317cacc.zip
Remove necessary CONFLICTS.
Update package description, WWW. Bump PORTREVISION.
Diffstat (limited to 'databases/redis')
-rw-r--r--databases/redis/Makefile3
-rw-r--r--databases/redis/pkg-descr33
2 files changed, 20 insertions, 16 deletions
diff --git a/databases/redis/Makefile b/databases/redis/Makefile
index 142a736e5366..78ad2d4e1999 100644
--- a/databases/redis/Makefile
+++ b/databases/redis/Makefile
@@ -7,6 +7,7 @@
PORTNAME= redis
PORTVERSION= 2.2.1
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= GOOGLE_CODE
@@ -17,8 +18,6 @@ LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
CFLAGS+= -I${LOCALBASE}/include
-CONFLICTS?= redis-2.0.*
-
USE_GMAKE= yes
USE_RC_SUBR= redis.sh
BIN_FILES= redis-benchmark redis-check-aof redis-check-dump \
diff --git a/databases/redis/pkg-descr b/databases/redis/pkg-descr
index 81dd3e5bdd3b..e034aa3723ba 100644
--- a/databases/redis/pkg-descr
+++ b/databases/redis/pkg-descr
@@ -1,14 +1,19 @@
-Redis is a key-value database. It is similar to memcached but the
-dataset is not volatile, and values can be strings, exactly like in
-memcached, but also lists and sets with atomic operations to push/pop
-elements.
-
-In order to be very fast but at the same time persistent the whole
-dataset is taken in memory and from time to time and/or when a number of
-changes to the dataset are performed it is written asynchronously on
-disk. You may lost the last few queries that is acceptable in many
-applications but it is as fast as an in memory DB (Redis supports
-non-blocking master-slave replication in order to solve this problem by
-redundancy).
-
-WWW: http://code.google.com/p/redis/
+Redis is an open source, advanced key-value store. It is often referred
+to as a data structure server since keys can contain strings, hashes,
+lists, sets and sorted sets.
+
+You can run atomic operations on these types, like appending to a string;
+incrementing the value in a hash; pushing to a list; computing set
+intersection, union and difference; or getting the member with highest
+ranking in a sorted set.
+
+In order to achieve its outstanding performance, Redis works with an
+in-memory dataset. Depending on your use case, you can persist it either
+by dumping the dataset to disk every once in a while, or by appending each
+command to a log.
+
+Redis also supports trivial-to-setup master-slave replication, with very
+fast non-blocking first synchronization, auto-reconnection on net split
+and so forth.
+
+WWW: http://redis.io/