aboutsummaryrefslogtreecommitdiffstats
path: root/databases/redis
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2012-10-28 16:39:17 +0800
committerosa <osa@FreeBSD.org>2012-10-28 16:39:17 +0800
commit2942deb77e1fd9281a395640af0f4cc2a900d3f6 (patch)
tree1f62b039aae2253b8b81ecdb535d7c10290e218f /databases/redis
parent220f217ada3d428838ad9a9b641952481db7312f (diff)
downloadfreebsd-ports-gnome-2942deb77e1fd9281a395640af0f4cc2a900d3f6.tar.gz
freebsd-ports-gnome-2942deb77e1fd9281a395640af0f4cc2a900d3f6.tar.zst
freebsd-ports-gnome-2942deb77e1fd9281a395640af0f4cc2a900d3f6.zip
Update from 2.4.17 to latest stable version 2.6.2.
Feature safe: yes
Diffstat (limited to 'databases/redis')
-rw-r--r--databases/redis/Makefile22
-rw-r--r--databases/redis/distinfo4
-rw-r--r--databases/redis/files/patch-deps::Makefile17
-rw-r--r--databases/redis/files/patch-deps::hiredis::Makefile4
-rw-r--r--databases/redis/files/patch-deps::linenoise::Makefile15
-rw-r--r--databases/redis/files/patch-src::Makefile31
-rw-r--r--databases/redis/files/patch-src::redis.c15
-rw-r--r--databases/redis/files/redis.in2
8 files changed, 52 insertions, 58 deletions
diff --git a/databases/redis/Makefile b/databases/redis/Makefile
index 1c21945d58d8..ef993a6edf8e 100644
--- a/databases/redis/Makefile
+++ b/databases/redis/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: redis
-# Date created: 03 Jul 2009
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= redis
-PORTVERSION= 2.4.17
+DISTVERSION= 2.6.2
CATEGORIES= databases
MASTER_SITES= GOOGLE_CODE
@@ -17,6 +13,15 @@ LICENSE= BSD
LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo
+OPTIONS_DEFINE= TESTS
+TESTS_DESC= Install lang/tcl for redis unit tests
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MTESTS}
+USE_TCL_BUILD= yes
+.endif
+
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lm -lexecinfo
@@ -63,4 +68,9 @@ post-install:
[ -d ${d} ] || ${MKDIR} ${d} && ${CHOWN} ${USERS}:${GROUPS} ${d}
.endfor
+test: build
+ @cd ${WRKSRC} && ${TCLSH} tests/test_helper.tcl
+
+regression-test: test
+
.include <bsd.port.mk>
diff --git a/databases/redis/distinfo b/databases/redis/distinfo
index 2c26ad204bd1..908b8cb57e39 100644
--- a/databases/redis/distinfo
+++ b/databases/redis/distinfo
@@ -1,2 +1,2 @@
-SHA256 (redis-2.4.17.tar.gz) = 3fae7c47ef84886ff65073593c91586bb675babaf702eb6f3b37855ab3066ebd
-SIZE (redis-2.4.17.tar.gz) = 656155
+SHA256 (redis-2.6.2.tar.gz) = b3b2e74ec8a13337e5e17cc24b0fecf5d612d6a0835d99bd1e337b391f20a46d
+SIZE (redis-2.6.2.tar.gz) = 1000600
diff --git a/databases/redis/files/patch-deps::Makefile b/databases/redis/files/patch-deps::Makefile
new file mode 100644
index 000000000000..793a03c9bc61
--- /dev/null
+++ b/databases/redis/files/patch-deps::Makefile
@@ -0,0 +1,17 @@
+--- deps/Makefile.orig 2012-07-02 04:18:07.000000000 +0400
++++ deps/Makefile 2012-07-02 04:18:56.000000000 +0400
+@@ -58,12 +58,12 @@
+ LUA_CFLAGS= -D__C99FEATURES__=1
+ endif
+
+-LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI $(CFLAGS)
++LUA_CFLAGS+= -Wall -DLUA_ANSI $(CFLAGS)
+ LUA_LDFLAGS+= $(LDFLAGS)
+
+ lua: .make-prerequisites
+ @printf '%b %b\n' $(MAKECOLOR)MAKE$(ENDCOLOR) $(BINCOLOR)$@$(ENDCOLOR)
+- cd lua/src && $(MAKE) all CFLAGS="$(LUA_CFLAGS)" MYLDFLAGS="$(LUA_LDFLAGS)"
++ cd lua/src && $(MAKE) all CC="$(CC)" CFLAGS="$(LUA_CFLAGS)" MYLDFLAGS="$(LUA_LDFLAGS)"
+
+ .PHONY: lua
+
diff --git a/databases/redis/files/patch-deps::hiredis::Makefile b/databases/redis/files/patch-deps::hiredis::Makefile
index 92197663ac82..b0cfcd406885 100644
--- a/databases/redis/files/patch-deps::hiredis::Makefile
+++ b/databases/redis/files/patch-deps::hiredis::Makefile
@@ -20,8 +20,8 @@
endif
+ifeq ($(uname_S),FreeBSD)
+ CFLAGS?=$(CFLAGS)
-+ CCLINK?=$(PTHREAD_LIBS)
-+ LDFLAGS?=$(LDFLAGS)
++ CCLINK?=-pthread
++ LDFLAGS?=-L. -Wl,-rpath,.
+ DYLIBNAME?=libhiredis.so
+ DYLIB_MAKE_CMD?=$(CC) -o ${DYLIBNAME} ${OBJ}
+ STLIBNAME?=libhiredis.a
diff --git a/databases/redis/files/patch-deps::linenoise::Makefile b/databases/redis/files/patch-deps::linenoise::Makefile
deleted file mode 100644
index de4181edbd6c..000000000000
--- a/databases/redis/files/patch-deps::linenoise::Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
---- deps/linenoise/Makefile.orig 2012-02-22 17:23:43.000000000 +0400
-+++ deps/linenoise/Makefile 2012-02-24 16:48:55.000000000 +0400
-@@ -1,10 +1,10 @@
- linenoise_example: linenoise.h linenoise.c
-
- linenoise_example: linenoise.o example.o
-- $(CC) $(ARCH) -Wall -W -Os -g -o linenoise_example linenoise.o example.o
-+ $(CC) $(CFLAGS) -o linenoise_example linenoise.o example.o
-
- .c.o:
-- $(CC) $(ARCH) -c -Wall -W -Os -g $<
-+ $(CC) $(CFLAGS) -c $<
-
- clean:
- rm -f linenoise_example *.o
diff --git a/databases/redis/files/patch-src::Makefile b/databases/redis/files/patch-src::Makefile
index 1d51eecd7743..9641f2e4115f 100644
--- a/databases/redis/files/patch-src::Makefile
+++ b/databases/redis/files/patch-src::Makefile
@@ -1,24 +1,21 @@
---- src/Makefile.orig 2012-05-28 11:14:39.000000000 +0400
-+++ src/Makefile 2012-05-28 11:15:45.000000000 +0400
-@@ -28,6 +28,9 @@
- CFLAGS?=-std=c99 -pedantic $(OPTIMIZATION) -Wall -W -D__EXTENSIONS__ -D_XPG6
- CCLINK?=-ldl -lnsl -lsocket -lm -lpthread
- DEBUG?=-g -ggdb
+--- src/Makefile.orig 2012-08-01 14:06:03.000000000 +0400
++++ src/Makefile 2012-08-02 22:24:01.000000000 +0400
+@@ -50,6 +50,9 @@
+ FINAL_LDFLAGS= $(LDFLAGS) $(REDIS_LDFLAGS) -g -ggdb
+ FINAL_LIBS= -ldl -lnsl -lsocket -lm -lpthread
+ DEBUG= -g -ggdb
+else ifeq ($(uname_S),FreeBSD)
-+ CFLAGS?= $(CFLAGS)
-+ CCLINK?= $(LDFLAGS)
++ FINAL_CFLAGS?= $(CFLAGS) $(REDIS_CFLAGS) -I${PREFIX}/include
++ FINAL_LDFLAGS= $(LDFLAGS)
else
- CFLAGS?=-std=c99 -pedantic $(OPTIMIZATION) -Wall -W $(ARCH) $(PROF)
- CCLINK?=-lm -pthread
-@@ -52,9 +55,9 @@
- ALLOC_FLAGS=-DUSE_JEMALLOC -I../deps/jemalloc/include
- endif
-
--CCOPT= $(CFLAGS) $(ARCH) $(PROF)
-+CCOPT= $(CFLAGS) $(PROF)
+ FINAL_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) $(REDIS_CFLAGS)
+ FINAL_LDFLAGS= $(LDFLAGS) $(REDIS_LDFLAGS) -g -rdynamic -ggdb
+@@ -79,7 +82,7 @@
+ REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)
+ REDIS_LD=$(QUIET_LINK)$(CC) $(FINAL_LDFLAGS)
-PREFIX?=/usr/local
-+PREFIX:= ${PREFIX}
++PREFIX:=${PREFIX}
INSTALL_BIN= $(PREFIX)/bin
INSTALL= cp -pf
diff --git a/databases/redis/files/patch-src::redis.c b/databases/redis/files/patch-src::redis.c
deleted file mode 100644
index 87f2777936ff..000000000000
--- a/databases/redis/files/patch-src::redis.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/redis.c.orig 2011-11-28 14:22:08.000000000 +0400
-+++ src/redis.c 2011-12-02 06:23:15.000000000 +0400
-@@ -1685,7 +1685,11 @@
- #ifdef HAVE_BACKTRACE
- static void *getMcontextEip(ucontext_t *uc) {
- #if defined(__FreeBSD__)
-- return (void*) uc->uc_mcontext.mc_eip;
-+ #if __x86_64__
-+ return (void*) uc->uc_mcontext.mc_rip;
-+ #elif __i386__
-+ return (void*) uc->uc_mcontext.mc_eip;
-+ #endif
- #elif defined(__dietlibc__)
- return (void*) uc->uc_mcontext.eip;
- #elif defined(__APPLE__) && !defined(MAC_OS_X_VERSION_10_6)
diff --git a/databases/redis/files/redis.in b/databases/redis/files/redis.in
index 70bf3a691bc3..0e232f79f251 100644
--- a/databases/redis/files/redis.in
+++ b/databases/redis/files/redis.in
@@ -16,7 +16,7 @@
. /etc/rc.subr
name="redis"
-rcvar=redis_enable
+rcvar=`set_rcvar`
extra_commands="reload"