aboutsummaryrefslogtreecommitdiffstats
path: root/databases/redis
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2016-08-08 07:34:51 +0800
committerosa <osa@FreeBSD.org>2016-08-08 07:34:51 +0800
commitcacf5aea9b607758982237c6c30452d374b5b0db (patch)
tree81109d12968c5d6b3678d7c1cb8d579d150d760b /databases/redis
parente56cb1780852d012864849914b7674d5547ea7b7 (diff)
downloadfreebsd-ports-gnome-cacf5aea9b607758982237c6c30452d374b5b0db.tar.gz
freebsd-ports-gnome-cacf5aea9b607758982237c6c30452d374b5b0db.tar.zst
freebsd-ports-gnome-cacf5aea9b607758982237c6c30452d374b5b0db.zip
Upgrade from 3.0.7 to the latest stable version 3.2.3.
Diffstat (limited to 'databases/redis')
-rw-r--r--databases/redis/Makefile6
-rw-r--r--databases/redis/distinfo5
-rw-r--r--databases/redis/files/extra-patch-src-Makefile.lua32
-rw-r--r--databases/redis/files/extra-patch-src-Makefile.luajit36
-rw-r--r--databases/redis/files/patch-deps-Makefile12
-rw-r--r--databases/redis/files/patch-redis.conf28
6 files changed, 64 insertions, 55 deletions
diff --git a/databases/redis/Makefile b/databases/redis/Makefile
index 015cb889f1e6..c5cf1c52b41c 100644
--- a/databases/redis/Makefile
+++ b/databases/redis/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= redis
-DISTVERSION= 3.0.7
+DISTVERSION= 3.2.3
CATEGORIES= databases
MASTER_SITES= http://download.redis.io/releases/
@@ -22,6 +22,8 @@ LUAJIT_DESC= Use lang/luajit instead of builtin lua
TESTS_DESC= Install lang/tcl for redis unit tests
TRIB_DESC= Install redis-trib.rb (lang/ruby req.)
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTRIB}
@@ -57,7 +59,7 @@ CONFLICTS?= redis-devel-3.*
USES+= gmake
MAKE_ENV= "V=yo"
USE_RC_SUBR= redis sentinel
-BIN_FILES= redis-benchmark redis-check-aof redis-check-dump \
+BIN_FILES= redis-benchmark redis-check-aof redis-check-rdb \
redis-cli redis-sentinel redis-server
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/databases/redis/distinfo b/databases/redis/distinfo
index a8185fa0b0e3..5f8f8debc0d6 100644
--- a/databases/redis/distinfo
+++ b/databases/redis/distinfo
@@ -1,2 +1,3 @@
-SHA256 (redis-3.0.7.tar.gz) = b2a791c4ea3bb7268795c45c6321ea5abcc24457178373e6a6e3be6372737f23
-SIZE (redis-3.0.7.tar.gz) = 1375200
+TIMESTAMP = 1470611740
+SHA256 (redis-3.2.3.tar.gz) = 674e9c38472e96491b7d4f7b42c38b71b5acbca945856e209cb428fbc6135f15
+SIZE (redis-3.2.3.tar.gz) = 1541401
diff --git a/databases/redis/files/extra-patch-src-Makefile.lua b/databases/redis/files/extra-patch-src-Makefile.lua
index a35e056b405d..7a4611030d22 100644
--- a/databases/redis/files/extra-patch-src-Makefile.lua
+++ b/databases/redis/files/extra-patch-src-Makefile.lua
@@ -1,24 +1,24 @@
---- src/Makefile.orig 2014-05-26 20:06:48.000000000 +0400
-+++ src/Makefile 2014-06-02 00:19:36.000000000 +0400
+--- src/Makefile.orig 2016-02-02 19:44:07.760203000 -0500
++++ src/Makefile 2016-02-02 19:47:01.843358000 -0500
@@ -15,7 +15,7 @@
release_hdr := $(shell sh -c './mkreleasehdr.sh')
uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
OPTIMIZATION?=-O2
--DEPENDENCY_TARGETS=hiredis linenoise lua
-+DEPENDENCY_TARGETS=hiredis linenoise
+-DEPENDENCY_TARGETS=hiredis linenoise lua geohash-int
++DEPENDENCY_TARGETS=hiredis linenoise geohash-int
# Default settings
- STD=-std=c99 -pedantic
-@@ -49,7 +49,7 @@
+ STD=-std=c99 -pedantic -DREDIS_STATIC=''
+@@ -53,7 +53,7 @@
# Override default settings if possible
-include .make-settings
--FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) $(REDIS_CFLAGS)
-+FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS)
+-FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) $(REDIS_CFLAGS) -I../deps/geohash-int
++FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) -I../deps/geohash-int
FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
FINAL_LIBS=-lm
DEBUG=-g -ggdb
-@@ -88,6 +88,9 @@
+@@ -98,6 +98,9 @@
FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a -ldl
endif
@@ -28,20 +28,20 @@
REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)
REDIS_LD=$(QUIET_LINK)$(CC) $(FINAL_LDFLAGS)
REDIS_INSTALL=$(QUIET_INSTALL)$(INSTALL)
-@@ -108,6 +111,7 @@
+@@ -118,6 +121,7 @@
REDIS_SERVER_NAME=redis-server
REDIS_SENTINEL_NAME=redis-sentinel
- REDIS_SERVER_OBJ=adlist.o ae.o anet.o dict.o redis.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o cluster.o crc16.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o blocked.o hyperloglog.o latency.o sparkline.o
+ REDIS_SERVER_OBJ=adlist.o quicklist.o ae.o anet.o dict.o server.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o cluster.o crc16.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o blocked.o hyperloglog.o latency.o sparkline.o redis-check-rdb.o geo.o
+REDIS_SERVER_OBJ+=fpconv.o lua_bit.o lua_cjson.o lua_cmsgpack.o lua_struct.o strbuf.o
+ REDIS_GEOHASH_OBJ=../deps/geohash-int/geohash.o ../deps/geohash-int/geohash_helper.o
REDIS_CLI_NAME=redis-cli
- REDIS_CLI_OBJ=anet.o sds.o adlist.o redis-cli.o zmalloc.o release.o anet.o ae.o crc64.o
- REDIS_BENCHMARK_NAME=redis-benchmark
-@@ -162,7 +166,7 @@
+ REDIS_CLI_OBJ=anet.o adlist.o redis-cli.o zmalloc.o release.o anet.o ae.o crc64.o
+@@ -172,7 +176,7 @@
# redis-server
$(REDIS_SERVER_NAME): $(REDIS_SERVER_OBJ)
-- $(REDIS_LD) -o $@ $^ ../deps/hiredis/libhiredis.a ../deps/lua/src/liblua.a $(FINAL_LIBS)
-+ $(REDIS_LD) -o $@ $^ ../deps/hiredis/libhiredis.a $(FINAL_LIBS)
+- $(REDIS_LD) -o $@ $^ ../deps/hiredis/libhiredis.a ../deps/lua/src/liblua.a $(REDIS_GEOHASH_OBJ) $(FINAL_LIBS)
++ $(REDIS_LD) -o $@ $^ ../deps/hiredis/libhiredis.a $(REDIS_GEOHASH_OBJ) $(FINAL_LIBS)
# redis-sentinel
$(REDIS_SENTINEL_NAME): $(REDIS_SERVER_NAME)
diff --git a/databases/redis/files/extra-patch-src-Makefile.luajit b/databases/redis/files/extra-patch-src-Makefile.luajit
index 50e0ffd92146..9b9c5f598fe1 100644
--- a/databases/redis/files/extra-patch-src-Makefile.luajit
+++ b/databases/redis/files/extra-patch-src-Makefile.luajit
@@ -1,24 +1,26 @@
---- src/Makefile.orig 2014-07-29 12:17:48.000000000 +0400
-+++ src/Makefile 2014-09-10 02:30:38.000000000 +0400
+--- src/Makefile.orig 2016-02-02 19:28:26.001101000 -0500
++++ src/Makefile 2016-02-02 19:31:30.003197000 -0500
@@ -15,7 +15,7 @@
release_hdr := $(shell sh -c './mkreleasehdr.sh')
uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
OPTIMIZATION?=-O2
--DEPENDENCY_TARGETS=hiredis linenoise lua
-+DEPENDENCY_TARGETS=hiredis linenoise
+-DEPENDENCY_TARGETS=hiredis linenoise lua geohash-int
++DEPENDENCY_TARGETS=hiredis linenoise geohash-int
# Default settings
- STD=-std=c99 -pedantic
-@@ -49,7 +49,7 @@
+ STD=-std=c99 -pedantic -DREDIS_STATIC=''
+@@ -53,8 +53,8 @@
# Override default settings if possible
-include .make-settings
--FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) $(REDIS_CFLAGS)
-+FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS)
- FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
+-FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) $(REDIS_CFLAGS) -I../deps/geohash-int
+-FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
++FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) -I../deps/geohash-int
++FINAL_LDFLAGS=$(LDFLAGS) $(DEBUG)
FINAL_LIBS=-lm
DEBUG=-g -ggdb
-@@ -88,6 +88,9 @@
+
+@@ -98,6 +98,9 @@
FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a -ldl
endif
@@ -28,20 +30,20 @@
REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)
REDIS_LD=$(QUIET_LINK)$(CC) $(FINAL_LDFLAGS)
REDIS_INSTALL=$(QUIET_INSTALL)$(INSTALL)
-@@ -108,6 +111,7 @@
+@@ -118,6 +121,7 @@
REDIS_SERVER_NAME=redis-server
REDIS_SENTINEL_NAME=redis-sentinel
- REDIS_SERVER_OBJ=adlist.o ae.o anet.o dict.o redis.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o cluster.o crc16.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o blocked.o hyperloglog.o latency.o sparkline.o
+ REDIS_SERVER_OBJ=adlist.o quicklist.o ae.o anet.o dict.o server.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o cluster.o crc16.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o blocked.o hyperloglog.o latency.o sparkline.o redis-check-rdb.o geo.o
+REDIS_SERVER_OBJ+=fpconv.o lua_bit.o lua_cjson.o lua_cmsgpack.o lua_struct.o strbuf.o
+ REDIS_GEOHASH_OBJ=../deps/geohash-int/geohash.o ../deps/geohash-int/geohash_helper.o
REDIS_CLI_NAME=redis-cli
- REDIS_CLI_OBJ=anet.o sds.o adlist.o redis-cli.o zmalloc.o release.o anet.o ae.o crc64.o
- REDIS_BENCHMARK_NAME=redis-benchmark
-@@ -162,7 +166,7 @@
+ REDIS_CLI_OBJ=anet.o adlist.o redis-cli.o zmalloc.o release.o anet.o ae.o crc64.o
+@@ -172,7 +176,7 @@
# redis-server
$(REDIS_SERVER_NAME): $(REDIS_SERVER_OBJ)
-- $(REDIS_LD) -o $@ $^ ../deps/hiredis/libhiredis.a ../deps/lua/src/liblua.a $(FINAL_LIBS)
-+ $(REDIS_LD) -o $@ $^ ../deps/hiredis/libhiredis.a $(FINAL_LIBS)
+- $(REDIS_LD) -o $@ $^ ../deps/hiredis/libhiredis.a ../deps/lua/src/liblua.a $(REDIS_GEOHASH_OBJ) $(FINAL_LIBS)
++ $(REDIS_LD) -o $@ $^ ../deps/hiredis/libhiredis.a $(REDIS_GEOHASH_OBJ) $(FINAL_LIBS)
# redis-sentinel
$(REDIS_SENTINEL_NAME): $(REDIS_SERVER_NAME)
diff --git a/databases/redis/files/patch-deps-Makefile b/databases/redis/files/patch-deps-Makefile
index 7a055f479e7d..e252c929c246 100644
--- a/databases/redis/files/patch-deps-Makefile
+++ b/databases/redis/files/patch-deps-Makefile
@@ -1,15 +1,15 @@
---- deps/Makefile.orig 2014-09-01 19:00:38.000000000 +0400
-+++ deps/Makefile 2014-09-09 05:33:10.000000000 +0400
-@@ -58,7 +58,7 @@
+--- deps/Makefile.orig 2016-02-02 19:38:43.438304000 -0500
++++ deps/Makefile 2016-02-02 19:40:05.911356000 -0500
+@@ -59,7 +59,7 @@
LUA_CFLAGS= -D__C99FEATURES__=1
endif
--LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI -DENABLE_CJSON_GLOBAL $(CFLAGS)
-+LUA_CFLAGS+= -Wall -DLUA_ANSI -DENABLE_CJSON_GLOBAL $(CFLAGS)
+-LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI -DENABLE_CJSON_GLOBAL -DREDIS_STATIC='' $(CFLAGS)
++LUA_CFLAGS+= -Wall -DLUA_ANSI -DENABLE_CJSON_GLOBAL -DREDIS_STATIC='' $(CFLAGS)
LUA_LDFLAGS+= $(LDFLAGS)
# lua's Makefile defines AR="ar rcu", which is unusual, and makes it more
# challenging to cross-compile lua (and redis). These defines make it easier
-@@ -68,7 +68,7 @@
+@@ -69,7 +69,7 @@
lua: .make-prerequisites
@printf '%b %b\n' $(MAKECOLOR)MAKE$(ENDCOLOR) $(BINCOLOR)$@$(ENDCOLOR)
diff --git a/databases/redis/files/patch-redis.conf b/databases/redis/files/patch-redis.conf
index 0ade1ddf1195..5e8d12a9e10b 100644
--- a/databases/redis/files/patch-redis.conf
+++ b/databases/redis/files/patch-redis.conf
@@ -1,21 +1,25 @@
---- redis.conf.orig 2013-08-13 15:40:42.000000000 +0400
-+++ redis.conf 2013-08-13 15:42:50.000000000 +0400
-@@ -14,11 +14,11 @@
+--- redis.conf.orig 2016-06-17 09:15:21.000000000 -0400
++++ redis.conf 2016-06-18 11:58:19.871082000 -0400
+@@ -125,7 +125,7 @@
# By default Redis does not run as a daemon. Use 'yes' if you need it.
# Note that Redis will write a pid file in /var/run/redis.pid when daemonized.
-daemonize no
+daemonize yes
- # When running daemonized, Redis writes a pid file in /var/run/redis.pid by
- # default. You can specify a custom pid file location here.
--pidfile /var/run/redis.pid
+ # If you run Redis from upstart or systemd, Redis can interact with your
+ # supervision tree. Options:
+@@ -147,7 +147,7 @@
+ #
+ # Creating a pid file is best effort: if Redis is not able to create it
+ # nothing bad happens, the server will start and run normally.
+-pidfile /var/run/redis_6379.pid
+pidfile %%REDIS_RUNDIR%%/redis.pid
- # Accept connections on the specified port, default is 6379.
- # If port 0 is specified Redis will not listen on a TCP socket.
-@@ -71,7 +71,7 @@
- # Specify the log file name. Also the emptry string can be used to force
+ # Specify the server verbosity level.
+ # This can be one of:
+@@ -160,7 +160,7 @@
+ # Specify the log file name. Also the empty string can be used to force
# Redis to log on the standard output. Note that if you use standard
# output for logging but daemonize, logs will be sent to /dev/null
-logfile ""
@@ -23,9 +27,9 @@
# To enable logging to the system logger, just set 'syslog-enabled' to yes,
# and optionally update the other syslog parameters to suit your needs.
-@@ -155,7 +155,7 @@
+@@ -244,7 +244,7 @@
# The Append Only File will also be created inside this directory.
- #
+ #
# Note that you must specify a directory here, not a file name.
-dir ./
+dir %%REDIS_DBDIR%%/