aboutsummaryrefslogtreecommitdiffstats
path: root/databases/rrdtool12
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
committermat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
commit9debac461b7729b783ca5a0f5e46461ddac07173 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /databases/rrdtool12
parenteedda7c96f5b61bbadc957164c030b26a221e965 (diff)
downloadfreebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.gz
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.zst
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Diffstat (limited to 'databases/rrdtool12')
-rw-r--r--databases/rrdtool12/Makefile4
-rw-r--r--databases/rrdtool12/pkg-plist8
2 files changed, 5 insertions, 7 deletions
diff --git a/databases/rrdtool12/Makefile b/databases/rrdtool12/Makefile
index 0a355e56b235..51224575fb04 100644
--- a/databases/rrdtool12/Makefile
+++ b/databases/rrdtool12/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rrdtool
PORTVERSION= 1.2.30
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= databases graphics
MASTER_SITES= http://oss.oetiker.ch/rrdtool/pub/
PKGNAMESUFFIX= 12
@@ -48,7 +48,7 @@ PLIST_SUB+= WITH_RUBY="@comment "
.if ${PORT_OPTIONS:MPERL}
USES+= perl5
-USE_PERL5= run build fixpacklist
+USE_PERL5= run build
CONFIGURE_ARGS+= --enable-perl --enable-perl-site-install
PLIST_SUB+= WITH_PERL=""
.else
diff --git a/databases/rrdtool12/pkg-plist b/databases/rrdtool12/pkg-plist
index 498aa34ab69c..6e0c2c651b99 100644
--- a/databases/rrdtool12/pkg-plist
+++ b/databases/rrdtool12/pkg-plist
@@ -129,11 +129,9 @@ man/man1/rrdlastupdate.1.gz
%%WITH_PERL%%%%PERL5_MAN3%%/RRDp.3.gz
%%WITH_PERL%%%%PERL5_MAN3%%/RRDs.3.gz
%%WITH_PERL%%%%SITE_PERL%%/RRDp.pm
-%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/RRDp/.packlist
-%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/RRDs.pm
-%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/ntmake.pl
-%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/RRDs/RRDs.so
-%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/RRDs/.packlist
+%%WITH_PERL%%%%SITE_ARCH%%/RRDs.pm
+%%WITH_PERL%%%%SITE_ARCH%%/ntmake.pl
+%%WITH_PERL%%%%SITE_ARCH%%/auto/RRDs/RRDs.so
%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/rrdtoolmodule.so
%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/py_rrdtool-0.2.1-py%%PYTHON_VER%%.egg-info
%%WITH_RUBY%%%%RUBY_SITEARCHLIBDIR%%/RRD.so