aboutsummaryrefslogtreecommitdiffstats
path: root/databases/ruby-mysql
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-08-07 19:23:12 +0800
committerknu <knu@FreeBSD.org>2000-08-07 19:23:12 +0800
commit5743fb696cbc38801a443066fd51533d2ab13c9b (patch)
tree6b5bd23ccc02cd232738220ceeb4281f977bd6af /databases/ruby-mysql
parentf892435599ab77eb261a019f85c2c05f2d0aac2f (diff)
downloadfreebsd-ports-gnome-5743fb696cbc38801a443066fd51533d2ab13c9b.tar.gz
freebsd-ports-gnome-5743fb696cbc38801a443066fd51533d2ab13c9b.tar.zst
freebsd-ports-gnome-5743fb696cbc38801a443066fd51533d2ab13c9b.zip
Add another couple of Ruby modules.
databases/ruby-mysql: Ruby module for accessing MySQL databases, which has the same functions as C API ports/devel/ruby-optparse: Yet another command line option parser for Ruby
Diffstat (limited to 'databases/ruby-mysql')
-rw-r--r--databases/ruby-mysql/Makefile40
-rw-r--r--databases/ruby-mysql/distinfo1
-rw-r--r--databases/ruby-mysql/pkg-comment1
-rw-r--r--databases/ruby-mysql/pkg-descr4
-rw-r--r--databases/ruby-mysql/pkg-plist5
5 files changed, 51 insertions, 0 deletions
diff --git a/databases/ruby-mysql/Makefile b/databases/ruby-mysql/Makefile
new file mode 100644
index 000000000000..e76f91d87831
--- /dev/null
+++ b/databases/ruby-mysql/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: Ruby-MySQL
+# Date created: 7 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mysql
+PORTVERSION= 2.3.0
+CATEGORIES= databases # ruby
+MASTER_SITES= http://www.tmtm.org/mysql/ruby/
+PKGNAMEPREFIX= ruby-
+DISTNAME= ${PORTNAME}-ruby-${PORTVERSION}
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+LIB_DEPENDS= mysqlclient.6:${PORTSDIR}/databases/mysql322-client
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+
+PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY= ${LOCALBASE}/bin/ruby
+RUBY_VER= 1.4
+RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+
+do-configure:
+ @cd ${WRKSRC}; \
+ ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb
+
+do-install:
+ @cd ${WRKSRC}; \
+ ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ruby/mysql/ja
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/ruby/mysql/
+ ${INSTALL_DATA} ${WRKSRC}/README.jp ${PREFIX}/share/doc/ruby/mysql/ja
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/ruby-mysql/distinfo b/databases/ruby-mysql/distinfo
new file mode 100644
index 000000000000..02dbfdc12734
--- /dev/null
+++ b/databases/ruby-mysql/distinfo
@@ -0,0 +1 @@
+MD5 (mysql-ruby-2.3.0.tar.gz) = e518e06eab4f7a6f2bac186989d04595
diff --git a/databases/ruby-mysql/pkg-comment b/databases/ruby-mysql/pkg-comment
new file mode 100644
index 000000000000..79a6cb2e4f19
--- /dev/null
+++ b/databases/ruby-mysql/pkg-comment
@@ -0,0 +1 @@
+Ruby module for accessing MySQL databases, which has the same functions as C API
diff --git a/databases/ruby-mysql/pkg-descr b/databases/ruby-mysql/pkg-descr
new file mode 100644
index 000000000000..189a24aa6b3a
--- /dev/null
+++ b/databases/ruby-mysql/pkg-descr
@@ -0,0 +1,4 @@
+This is a Ruby module for accessing MySQL databases, which has the
+same functions as C API.
+
+WWW: http://www.tmtm.org/mysql/ruby/README
diff --git a/databases/ruby-mysql/pkg-plist b/databases/ruby-mysql/pkg-plist
new file mode 100644
index 000000000000..63cb1ac4de43
--- /dev/null
+++ b/databases/ruby-mysql/pkg-plist
@@ -0,0 +1,5 @@
+lib/ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/mysql.so
+share/doc/ruby/mysql/ja/README.jp
+share/doc/ruby/mysql/README
+@dirrm share/doc/ruby/mysql/ja
+@dirrm share/doc/ruby/mysql