aboutsummaryrefslogtreecommitdiffstats
path: root/databases/rubygem-couchrest
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2011-06-25 02:19:33 +0800
committerpgollucci <pgollucci@FreeBSD.org>2011-06-25 02:19:33 +0800
commit0a1ee4e06f141b4a43a3d5971e624b99f4fd2595 (patch)
tree10dd0f3da289fc7882da4164f84e6e81ee6bc1f5 /databases/rubygem-couchrest
parent56552e83163553c782e4149009fec17501825c27 (diff)
downloadfreebsd-ports-gnome-0a1ee4e06f141b4a43a3d5971e624b99f4fd2595.tar.gz
freebsd-ports-gnome-0a1ee4e06f141b4a43a3d5971e624b99f4fd2595.tar.zst
freebsd-ports-gnome-0a1ee4e06f141b4a43a3d5971e624b99f4fd2595.zip
CouchRest provides a simple interface on top of CouchDB's RESTful HTTP API,
as well as including some utility scripts for managing views and attachments. WWW: http://rubygems.org/gems/couchrest PR: ports/158129 Submitted by: Mike Carlson (carlson39 at llnl.gov)
Diffstat (limited to 'databases/rubygem-couchrest')
-rw-r--r--databases/rubygem-couchrest/Makefile23
-rw-r--r--databases/rubygem-couchrest/distinfo2
-rw-r--r--databases/rubygem-couchrest/pkg-descr4
3 files changed, 29 insertions, 0 deletions
diff --git a/databases/rubygem-couchrest/Makefile b/databases/rubygem-couchrest/Makefile
new file mode 100644
index 000000000000..4b265dbcd630
--- /dev/null
+++ b/databases/rubygem-couchrest/Makefile
@@ -0,0 +1,23 @@
+# Ports collection makefile for: rubygem-couchrest
+# Date created: 20 June 2011
+# Whom: Mike Carlson (carlson39@llnl.gov)
+#
+# $FreeBSD$
+
+PORTNAME= couchrest
+PORTVERSION= 1.0.2
+CATEGORIES= databases rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Provides a simple interface on top of CouchDBs RESTful HTTP API
+
+RUN_DEPENDS= rubygem-json>=${PORTVERSION}:${PORTSDIR}/devel/rubygem-json \
+ rubygem-mime-types>=${PORTVERSION}:${PORTSDIR}/misc/rubygem-mime-types \
+ rubygem-rest-client>=${PORTVERSION}:${PORTSDIR}/www/rubygem-rest-client
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/databases/rubygem-couchrest/distinfo b/databases/rubygem-couchrest/distinfo
new file mode 100644
index 000000000000..55a25b6482a1
--- /dev/null
+++ b/databases/rubygem-couchrest/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/couchrest-1.0.2.gem) = 55b62424feedba1cb936d7187c94875fbea8daf17962813deba0cf0c41c93c72
+SIZE (rubygem/couchrest-1.0.2.gem) = 45056
diff --git a/databases/rubygem-couchrest/pkg-descr b/databases/rubygem-couchrest/pkg-descr
new file mode 100644
index 000000000000..cfe4afdcf2eb
--- /dev/null
+++ b/databases/rubygem-couchrest/pkg-descr
@@ -0,0 +1,4 @@
+CouchRest provides a simple interface on top of CouchDB's RESTful HTTP API,
+as well as including some utility scripts for managing views and attachments.
+
+WWW: http://rubygems.org/gems/couchrest