aboutsummaryrefslogtreecommitdiffstats
path: root/databases/slony1v2/Makefile
diff options
context:
space:
mode:
authorgirgen <girgen@FreeBSD.org>2006-12-08 18:59:53 +0800
committergirgen <girgen@FreeBSD.org>2006-12-08 18:59:53 +0800
commitaa682facccb8cedc04e957ddba97c7e713532bdb (patch)
tree0aa3817a0ea19d204abec4102fddd6ac370d83fc /databases/slony1v2/Makefile
parentbc688bda99a737f1ba30eaad3d4f39bf911ab984 (diff)
downloadfreebsd-ports-gnome-aa682facccb8cedc04e957ddba97c7e713532bdb.tar.gz
freebsd-ports-gnome-aa682facccb8cedc04e957ddba97c7e713532bdb.tar.zst
freebsd-ports-gnome-aa682facccb8cedc04e957ddba97c7e713532bdb.zip
More rubust regex to determine which version of postgresql that is
already installed. Reported by: Kostik Belousov
Diffstat (limited to 'databases/slony1v2/Makefile')
-rw-r--r--databases/slony1v2/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/databases/slony1v2/Makefile b/databases/slony1v2/Makefile
index 12aa6c55971f..ceede4ac2e61 100644
--- a/databases/slony1v2/Makefile
+++ b/databases/slony1v2/Makefile
@@ -59,7 +59,7 @@ DEFAULT_PGSQL_VER?=80
# Setting/finding PostgreSQL version we want.
.if exists(${LOCALBASE}/bin/postmaster)
PGSQL_VER!= ${LOCALBASE}/bin/postmaster -V | \
- ${SED} -En 's/postmaster.*PostgreSQL[^0-9]*([0-9]+)\.([0-9]+)\..*/\1\2/p'
+ ${SED} -En 's/.*PostgreSQL[^0-9]*([0-9]+)\.([0-9]+)\..*/\1\2/p'
.elif exists(${LOCALBASE}/bin/pg_config)
PGSQL_VER!= ${LOCALBASE}/bin/pg_config --version | \
${SED} -En 's/PostgreSQL[^0-9]*([0-9]*)\.([0-9]+)\..*/\1\2/p'