aboutsummaryrefslogtreecommitdiffstats
path: root/databases/slony1v2
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-11-27 21:15:46 +0800
committermiwi <miwi@FreeBSD.org>2006-11-27 21:15:46 +0800
commit9a9191a18e00e2c753d941b480193948c1c44ce6 (patch)
treea47d1e5a23b207a66ef8ec974daf3fa1aef4f68e /databases/slony1v2
parent0b630babc9b888bc3ab80bdd6e9a41018fd6053a (diff)
downloadfreebsd-ports-gnome-9a9191a18e00e2c753d941b480193948c1c44ce6.tar.gz
freebsd-ports-gnome-9a9191a18e00e2c753d941b480193948c1c44ce6.tar.zst
freebsd-ports-gnome-9a9191a18e00e2c753d941b480193948c1c44ce6.zip
- Update to 4.2.2
PR: ports/105882 Submitted by: David Thiel <lx@redundancy.redundancy.org> (Maintainer)
Diffstat (limited to 'databases/slony1v2')
-rw-r--r--databases/slony1v2/Makefile1
-rw-r--r--databases/slony1v2/files/bds-slony.patch73
2 files changed, 74 insertions, 0 deletions
diff --git a/databases/slony1v2/Makefile b/databases/slony1v2/Makefile
index 675fcbe301d7..12aa6c55971f 100644
--- a/databases/slony1v2/Makefile
+++ b/databases/slony1v2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= slony1
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://developer.postgresql.org/~wieck/slony1/download/ \
http://freebsd.unixfreunde.de/sources/
diff --git a/databases/slony1v2/files/bds-slony.patch b/databases/slony1v2/files/bds-slony.patch
new file mode 100644
index 000000000000..9fbd7470e25d
--- /dev/null
+++ b/databases/slony1v2/files/bds-slony.patch
@@ -0,0 +1,73 @@
+--- slony1-1.2.0-orig/src/slon/remote_worker.c 2006-10-05 08:40:37.000000000 -0600
++++ slony1-1.2.0/src/slon/remote_worker.c 2006-10-20 15:42:35.000000000 -0600
+@@ -5236,7 +5236,8 @@
+ " octet_length(log_cmddata), "
+ " case when octet_length(log_cmddata) <= %d "
+ " then log_cmddata "
+- " else null end "
++ " else null end, "
++ " 1 as which_log_table "
+ "from %s.sl_log_1 %s order by log_actionseq; ",
+ sync_max_rowsize,
+ rtcfg_namespace,
+@@ -5251,7 +5252,8 @@
+ " octet_length(log_cmddata), "
+ " case when octet_length(log_cmddata) <= %d "
+ " then log_cmddata "
+- " else null end "
++ " else null end, "
++ " 2 as which_log_table "
+ "from %s.sl_log_2 %s order by log_actionseq; ",
+ sync_max_rowsize,
+ rtcfg_namespace,
+@@ -5267,7 +5269,8 @@
+ " octet_length(log_cmddata), "
+ " case when octet_length(log_cmddata) <= %d "
+ " then log_cmddata "
+- " else null end "
++ " else null end, "
++ " 1 as which_log_table "
+ " from %s.sl_log_1 %s "
+ " union all "
+ " select log_origin, log_xid, log_tableid, "
+@@ -5275,7 +5278,8 @@
+ " octet_length(log_cmddata), "
+ " case when octet_length(log_cmddata) <= %d "
+ " then log_cmddata "
+- " else null end "
++ " else null end, "
++ " 2 as which_log_table "
+ " from %s.sl_log_2 %s) as log_union "
+ "order by log_actionseq; ",
+ sync_max_rowsize,
+@@ -5497,6 +5501,8 @@
+ int log_cmdsize = strtol(PQgetvalue(res, tupno, 5),
+ NULL, 10);
+ char *log_cmddata = PQgetvalue(res, tupno, 6);
++ int which_log_table = strtol(PQgetvalue(res, tupno, 7),
++ NULL, 10);
+ int largemem = 0;
+
+ tupno++;
+@@ -5505,11 +5511,12 @@
+ {
+ slon_mkquery(&query2,
+ "select log_cmddata "
+- "from %s.sl_log_1 "
++ "from %s.sl_log_%d "
+ "where log_origin = '%s' "
+ " and log_xid = '%s' "
+ " and log_actionseq = '%s'",
+ rtcfg_namespace,
++ which_log_table,
+ log_origin, log_xid, log_actionseq);
+ res2 = PQexec(dbconn, dstring_data(&query2));
+ if (PQresultStatus(res2) != PGRES_TUPLES_OK)
+@@ -5526,7 +5533,6 @@
+ {
+ slon_log(SLON_ERROR, "remoteHelperThread_%d_%d: large log_cmddata for actionseq %s not found\n",
+ node->no_id, provider->no_id,
+- dstring_data(&query),
+ log_actionseq);
+ PQclear(res2);
+ errors++;