aboutsummaryrefslogtreecommitdiffstats
path: root/databases/sqlite2
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2003-06-27 06:58:32 +0800
committerade <ade@FreeBSD.org>2003-06-27 06:58:32 +0800
commit9487d820b3247d8654d99544f8144188dcec810a (patch)
tree740462af7ed8e371913ea7f6b12533a99dd524ac /databases/sqlite2
parentdfe03c1be7cf9f1612091e1e697a7e74f7002416 (diff)
downloadfreebsd-ports-gnome-9487d820b3247d8654d99544f8144188dcec810a.tar.gz
freebsd-ports-gnome-9487d820b3247d8654d99544f8144188dcec810a.tar.zst
freebsd-ports-gnome-9487d820b3247d8654d99544f8144188dcec810a.zip
libtool uber-patch
* kill devel/libtool and move to devel/libtool13, upgrading to 1.3.5 * upgrade repo-copied devel/libtool14 to 1.4.3 * break out libltdl into its own separate port * move to version-numbered binaries/scripts (ie: there is *no* 'libtool' any more -- USE_LIBTOOL and USE_LIBTOOL_VER are your friends) Approved by: portmgr (kris) - for the bsd.port.mk hooks Tested by: bento 4-exp builds (repeatedly)
Diffstat (limited to 'databases/sqlite2')
-rw-r--r--databases/sqlite2/Makefile10
-rw-r--r--databases/sqlite2/files/patch-makefile2
2 files changed, 7 insertions, 5 deletions
diff --git a/databases/sqlite2/Makefile b/databases/sqlite2/Makefile
index 0b6b90021081..56a4b1e39c68 100644
--- a/databases/sqlite2/Makefile
+++ b/databases/sqlite2/Makefile
@@ -57,9 +57,9 @@ GNU_CONFIGURE= YES
USE_REINPLACE= YES
CONFIGURE_ARGS= --prefix=${PREFIX} --with-hints=freebsd.hints
ALL_TARGET= all
-.if defined(WITH_TCL)
-ALL_TARGET+= libtclsqlite.la
-.endif
+#.if defined(WITH_TCL)
+#ALL_TARGET+= libtclsqlite.la
+#.endif
INSTALLS_SHLIB= YES
@@ -76,7 +76,9 @@ DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}
post-patch:
- ${REINPLACE_CMD} -e "s/tclsh \$$(TOP)/\$$(TCLSH) \$$(TOP)/g" ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -e "s/tclsh \$$(TOP)/\$$(TCLSH) \$$(TOP)/g" \
+ -e "s|%%LIBTOOL%%|${LIBTOOL}|g" \
+ ${WRKSRC}/Makefile.in
${ECHO} "config_TARGET_TCL_INC=\"-I${PREFIX}/include/tcl${TCL_V}\"" >${WRKSRC}/freebsd.hints
${ECHO} "config_TARGET_TCL_LIBS=\"-L${PREFIX}/lib -ltcl${TCL_SHORT_V}\"" >>${WRKSRC}/freebsd.hints
#${ECHO} "config_TARGET_CFLAGS=\"-DTHREADSAFE=1 -pthread\"" >>${WRKSRC}/freebsd.hints
diff --git a/databases/sqlite2/files/patch-makefile b/databases/sqlite2/files/patch-makefile
index 1097d4d24b13..a3739872b3c1 100644
--- a/databases/sqlite2/files/patch-makefile
+++ b/databases/sqlite2/files/patch-makefile
@@ -13,7 +13,7 @@
prefix = @prefix@
exec_prefix = @exec_prefix@
INSTALL = @INSTALL@
-! LIBTOOL = @prefix@/bin/libtool
+! LIBTOOL = %%LIBTOOL%%
# Compiler options needed for programs that use the TCL library.
#