aboutsummaryrefslogtreecommitdiffstats
path: root/databases/tora/Makefile
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2006-04-09 03:39:47 +0800
committerthierry <thierry@FreeBSD.org>2006-04-09 03:39:47 +0800
commita8dbbc6d0d7ff489aa84ca4996f27e23c87a8418 (patch)
tree4ffa11b00fbb77253fcf362a37ab5dc3abd98284 /databases/tora/Makefile
parent368c75a7f2d83743b8b9032ac773f8bfb99d48a5 (diff)
downloadfreebsd-ports-gnome-a8dbbc6d0d7ff489aa84ca4996f27e23c87a8418.tar.gz
freebsd-ports-gnome-a8dbbc6d0d7ff489aa84ca4996f27e23c87a8418.tar.zst
freebsd-ports-gnome-a8dbbc6d0d7ff489aa84ca4996f27e23c87a8418.zip
Mark broken on FreeBSD-4.
Reported by: Ports-i386 via Kris
Diffstat (limited to 'databases/tora/Makefile')
-rw-r--r--databases/tora/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/databases/tora/Makefile b/databases/tora/Makefile
index e5c21049bc65..5edb2fc48d69 100644
--- a/databases/tora/Makefile
+++ b/databases/tora/Makefile
@@ -49,6 +49,13 @@ PORTDOCS= AUTHORS BUGS ChangeLog INSTALL NEWS README README.CODESTYLE README.LIC
PREFIX2FIX= help/preferences.html totool.cpp
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+# Just defining time_t as long in topiechart.h could be sufficient?
+BROKEN= does not compile with gcc 2.95
+.endif
+
pre-configure:
${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|/etc/torarc|${PREFIX}/etc/torarc|' ${PREFIX2FIX:S|^|${WRKSRC}/|}
@@ -60,4 +67,4 @@ post-install:
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>