aboutsummaryrefslogtreecommitdiffstats
path: root/databases/typhoon
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-10-22 10:30:24 +0800
committerasami <asami@FreeBSD.org>1998-10-22 10:30:24 +0800
commit9cc78c6a1fcda267ffcadb01c4e0e1c2dab06549 (patch)
treee370ce651e0917f17a6a06fc31c7934f420eebfe /databases/typhoon
parent5c497742ce3830de9cbdd4d7bf88824e7696090f (diff)
downloadfreebsd-ports-gnome-9cc78c6a1fcda267ffcadb01c4e0e1c2dab06549.tar.gz
freebsd-ports-gnome-9cc78c6a1fcda267ffcadb01c4e0e1c2dab06549.tar.zst
freebsd-ports-gnome-9cc78c6a1fcda267ffcadb01c4e0e1c2dab06549.zip
Fix various bogons. (I *assume* the libtyphoon.so link was meant for
the a.out case, because otherwise the name of the shared library is wrong.)
Diffstat (limited to 'databases/typhoon')
-rw-r--r--databases/typhoon/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/databases/typhoon/Makefile b/databases/typhoon/Makefile
index ae8a6b998eab..e05d77c7def9 100644
--- a/databases/typhoon/Makefile
+++ b/databases/typhoon/Makefile
@@ -3,7 +3,7 @@
# Date created: Wed Dec 11 15:16:19 CST 1996
# Whom: erich@FreeBSD.org
#
-# $Id: Makefile,v 1.3 1998/01/31 16:59:53 jseger Exp $
+# $Id: Makefile,v 1.4 1998/10/20 01:30:01 steve Exp $
#
DISTNAME= typhoon-1.10.3
@@ -26,8 +26,8 @@ post-install:
@${MKDIR} ${PREFIX}/share/typhoon
@${INSTALL_DATA} ${WRKSRC}/man/manual.asc ${PREFIX}/share/typhoon
@${INSTALL_DATA} ${WRKSRC}/include/environ.h ${WRKSRC}/include/typhoon.h ${PREFIX}/include
- @if [ $PORTOBJFORMAT = "elf" ]; then \
- @{LN} -sf libtyphoon.so.1.10 ${PREFIX}/lib/libtyphoon.so; \
+ @if [ ${PORTOBJFORMAT} = "aout" ]; then \
+ ${LN} -sf libtyphoon.so.1.10 ${PREFIX}/lib/libtyphoon.so; \
fi
@${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib