aboutsummaryrefslogtreecommitdiffstats
path: root/databases/xapian-bindings
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-04-04 17:37:49 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-04-04 17:37:49 +0800
commita6aead19c1469dbc40c645290f120f1e7f1e228c (patch)
tree289717ad87fe87cb52b133f0f5c72e660302f85b /databases/xapian-bindings
parent457748d331d4fc15dba3973346f6aaee593c22c0 (diff)
downloadfreebsd-ports-gnome-a6aead19c1469dbc40c645290f120f1e7f1e228c.tar.gz
freebsd-ports-gnome-a6aead19c1469dbc40c645290f120f1e7f1e228c.tar.zst
freebsd-ports-gnome-a6aead19c1469dbc40c645290f120f1e7f1e228c.zip
Update to 1.4.3 and convert to a meta port
- Use USES=metaport - Add PERL option - Update pkg-descr - Update WWW Changes: https://trac.xapian.org/wiki/ReleaseOverview/1.4.3 https://trac.xapian.org/wiki/ReleaseOverview/1.4.2 https://trac.xapian.org/wiki/ReleaseOverview/1.4.1 https://trac.xapian.org/wiki/ReleaseOverview/1.4.0
Diffstat (limited to 'databases/xapian-bindings')
-rw-r--r--databases/xapian-bindings/Makefile45
-rw-r--r--databases/xapian-bindings/distinfo3
-rw-r--r--databases/xapian-bindings/pkg-descr10
-rw-r--r--databases/xapian-bindings/pkg-plist9
4 files changed, 20 insertions, 47 deletions
diff --git a/databases/xapian-bindings/Makefile b/databases/xapian-bindings/Makefile
index f0034d0b45f4..42ebabf7bf35 100644
--- a/databases/xapian-bindings/Makefile
+++ b/databases/xapian-bindings/Makefile
@@ -2,48 +2,29 @@
# $FreeBSD$
PORTNAME= xapian-bindings
-PORTVERSION= 1.2.24
+PORTVERSION= 1.4.3
CATEGORIES= databases
-MASTER_SITES= http://oligarchy.co.uk/xapian/${PORTVERSION}/ \
- LOCAL/sunpoet
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Bindings allowing Xapian to be used from various programming languages
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libxapian.so:databases/xapian-core
-
-OPTIONS_DEFINE= DOCS LUA PHP PYTHON RUBY
-OPTIONS_DEFAULT=PHP PYTHON RUBY
-OPTIONS_SUB= yes
+OPTIONS_DEFINE= LUA PERL PHP PYTHON RUBY
+OPTIONS_DEFAULT=LUA PERL PHP PYTHON RUBY
PORTSCOUT= limitw:1,even
-CONFIGURE_ARGS= --datarootdir=${DATADIR} --docdir=${DOCSDIR} \
- --without-csharp --without-java --without-perl --without-tcl
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
-USES= libtool tar:xz
-
-PORTDOCS= *
-
-LUA_CONFIGURE_ENV= LUA="${LUA_CMD}" LUA_INC="${LUA_INCDIR}" LUA_LIB="${LUA_MODLIBDIR}" LUA_SO=.so
-LUA_CONFIGURE_WITH= lua
-LUA_USES= lua
-PHP_CONFIGURE_ENV= PHP_CONFIG=${LOCALBASE}/bin/php-config
-PHP_CONFIGURE_WITH= php
-PHP_USES= php:build
-PYTHON_CONFIGURE_ENV= PYTHON_LIB=${PYTHON_SITELIBDIR}
-PYTHON_CONFIGURE_WITH= python
-PYTHON_USES= python:2
-RUBY_CONFIGURE_WITH= ruby
-RUBY_USE= RUBY=yes
+USES= metaport
-post-patch:
- @${REINPLACE_CMD} -e 's|-lstdc++||g' ${WRKSRC}/configure
-# do not install rdoc
- @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-data-local||' ${WRKSRC}/ruby/Makefile.in
+LUA_RUN_DEPENDS= ${LUA_PKGNAMEPREFIX}xapian>=${PORTVERSION}:databases/lua-xapian
+LUA_USES= lua:run
+PERL_RUN_DEPENDS= p5-Xapian>=${PORTVERSION}:databases/p5-Xapian
+PHP_RUN_DEPENDS= php-xapian>=${PORTVERSION}:databases/php-xapian
+PYTHON_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xapian>=${PORTVERSION}:databases/py-xapian
+PYTHON_USES= python:run
+RUBY_RUN_DEPENDS= ${RUBY_PKGNAMEPREFIX}xapian>=${PORTVERSION}:databases/ruby-xapian
+RUBY_USE= RUBY=yes
+RUBY_VARS= RUBY_NO_BUILD_DEPENDS=yes
.include <bsd.port.mk>
diff --git a/databases/xapian-bindings/distinfo b/databases/xapian-bindings/distinfo
deleted file mode 100644
index d1fd0fefd2e8..000000000000
--- a/databases/xapian-bindings/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1475134758
-SHA256 (xapian-bindings-1.2.24.tar.xz) = 0c2a0df0a4616e2bd8e578d372c9bb4684780573abebbd1ac515502177229965
-SIZE (xapian-bindings-1.2.24.tar.xz) = 886148
diff --git a/databases/xapian-bindings/pkg-descr b/databases/xapian-bindings/pkg-descr
index 70b02adf07fb..591ccce41160 100644
--- a/databases/xapian-bindings/pkg-descr
+++ b/databases/xapian-bindings/pkg-descr
@@ -1,4 +1,8 @@
-SWIG and JNI bindings allowing Xapian to be used from various other programming
-languages.
+This is the meta port of the following bindings:
+- databases/lua-xapian: Lua binding
+- databases/p5-Xapian: Perl binding
+- databases/php-xapian: PHP binding
+- databases/py-xapian: Python binding
+- databases/ruby-xapian: Ruby binding
-WWW: http://www.xapian.org/
+WWW: https://xapian.org/
diff --git a/databases/xapian-bindings/pkg-plist b/databases/xapian-bindings/pkg-plist
deleted file mode 100644
index 90167eee7db6..000000000000
--- a/databases/xapian-bindings/pkg-plist
+++ /dev/null
@@ -1,9 +0,0 @@
-%%LUA%%%%LUA_MODLIBDIR%%/xapian.so
-%%PHP%%lib/php/%%PHP_EXT_DIR%%/xapian.so
-%%PHP%%%%DATADIR%%/php5/xapian.php
-%%PYTHON%%%%PYTHON_SITELIBDIR%%/xapian/__init__.py
-%%PYTHON%%%%PYTHON_SITELIBDIR%%/xapian/__init__.pyc
-%%PYTHON%%%%PYTHON_SITELIBDIR%%/xapian/__init__.pyo
-%%PYTHON%%%%PYTHON_SITELIBDIR%%/xapian/_xapian.so
-%%RUBY%%%%RUBY_SITELIBDIR%%/xapian.rb
-%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/_xapian.so