aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2015-06-18 13:51:21 +0800
committervanilla <vanilla@FreeBSD.org>2015-06-18 13:51:21 +0800
commit0430a59020a05cf1940367ac8105669b2f8545d2 (patch)
treedd5081e1ed7637b4358d5363b45b71194c092381 /databases
parent48f592b8804933a46413e2c41c85b92418512ca2 (diff)
downloadfreebsd-ports-gnome-0430a59020a05cf1940367ac8105669b2f8545d2.tar.gz
freebsd-ports-gnome-0430a59020a05cf1940367ac8105669b2f8545d2.tar.zst
freebsd-ports-gnome-0430a59020a05cf1940367ac8105669b2f8545d2.zip
Upgrade to 0.7, and fix build on non-root user.
Diffstat (limited to 'databases')
-rw-r--r--databases/p5-LMDB_File/Makefile8
-rw-r--r--databases/p5-LMDB_File/distinfo4
-rw-r--r--databases/p5-LMDB_File/files/patch-liblmdb_Makefile16
3 files changed, 8 insertions, 20 deletions
diff --git a/databases/p5-LMDB_File/Makefile b/databases/p5-LMDB_File/Makefile
index b5f08c1aad34..3033a045f63b 100644
--- a/databases/p5-LMDB_File/Makefile
+++ b/databases/p5-LMDB_File/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= LMDB_File
-PORTVERSION= 0.05
+PORTVERSION= 0.07
CATEGORIES= databases perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -12,11 +12,15 @@ COMMENT= Perl wrapper around the OpenLDAP's LMDB
LICENSE= ART20
-CFLAGS+= -DMDB_DSYNC=O_SYNC -Dfdatasync=fsync
+LIB_DEPENDS= liblmdb.so:${PORTSDIR}/databases/lmdb
+
+CFLAGS+= -I${LOCALBASE}/include
USES= perl5
USE_PERL5= configure
post-install:
+ ${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/LMDB_File/LMDB_File.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/LMDB_File/LMDB_File.so
+ ${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/LMDB_File/LMDB_File.so
.include <bsd.port.mk>
diff --git a/databases/p5-LMDB_File/distinfo b/databases/p5-LMDB_File/distinfo
index ad232d0c2e3e..7ec9e8bbaa6b 100644
--- a/databases/p5-LMDB_File/distinfo
+++ b/databases/p5-LMDB_File/distinfo
@@ -1,2 +1,2 @@
-SHA256 (LMDB_File-0.05.tar.gz) = ea78115bd78a3ff740b91d74e2d18773a98f72274a6761f7e2ea94d765161331
-SIZE (LMDB_File-0.05.tar.gz) = 190963
+SHA256 (LMDB_File-0.07.tar.gz) = ebb04d9ff68880a45ea45a6ee5cbf35cef823c1870520bc15ba372c3adc4b820
+SIZE (LMDB_File-0.07.tar.gz) = 216033
diff --git a/databases/p5-LMDB_File/files/patch-liblmdb_Makefile b/databases/p5-LMDB_File/files/patch-liblmdb_Makefile
deleted file mode 100644
index 4511ae16f48e..000000000000
--- a/databases/p5-LMDB_File/files/patch-liblmdb_Makefile
+++ /dev/null
@@ -1,16 +0,0 @@
---- liblmdb/Makefile.orig 2013-09-11 05:23:43 UTC
-+++ liblmdb/Makefile
-@@ -16,11 +16,11 @@
- # There may be other macros in mdb.c of interest. You should
- # read mdb.c before changing any of them.
- #
--CC = gcc
-+CC ?= gcc
- W = -W -Wall -Wno-unused-parameter -Wbad-function-cast
- THREADS = -pthread
- OPT = -O2 -g
--CFLAGS = $(THREADS) $(OPT) $(W) $(XCFLAGS)
-+CFLAGS += $(THREADS) $(OPT) $(W) $(XCFLAGS)
- LDLIBS =
- SOLIBS =
- prefix = /usr/local