aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-06-04 16:49:57 +0800
committermiwi <miwi@FreeBSD.org>2014-06-04 16:49:57 +0800
commit043c45010e6d6098604c9fdacb07fd0b4991c33b (patch)
tree052e04ddaeab9c98fe00a98f0022e24806b3ab29 /databases
parent91fe5014f8cfec67dc26d4184966bb0a1a7ec25a (diff)
downloadfreebsd-ports-gnome-043c45010e6d6098604c9fdacb07fd0b4991c33b.tar.gz
freebsd-ports-gnome-043c45010e6d6098604c9fdacb07fd0b4991c33b.tar.zst
freebsd-ports-gnome-043c45010e6d6098604c9fdacb07fd0b4991c33b.zip
SFCGAL is a C++ wrapper library around CGAL with the aim of supporting ISO
19107:2013 and OGC Simple Features Access 1.2 for 3D operations. SFCGAL provides standard compliant geometry types and operations, that can be accessed from its C or C++ APIs. PostGIS uses the C API, to expose some SFCGAL's functions in spatial databases WWW: http://www.sfcgal.org/ PR: ports/188927 Submitted by: Loïc BARTOLETTI <coder@tuxfamily.org>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/sfcgal/Makefile25
-rw-r--r--databases/sfcgal/distinfo2
-rw-r--r--databases/sfcgal/pkg-descr8
-rw-r--r--databases/sfcgal/pkg-plist122
5 files changed, 158 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 47196b2f0d0b..39539f165f28 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -873,6 +873,7 @@
SUBDIR += rubygem-sqlite3
SUBDIR += rubygem-sqlite3-ruby
SUBDIR += rubygem-tarantool
+ SUBDIR += sfcgal
SUBDIR += sharedance
SUBDIR += skytools
SUBDIR += slony1
diff --git a/databases/sfcgal/Makefile b/databases/sfcgal/Makefile
new file mode 100644
index 000000000000..3f36393820dd
--- /dev/null
+++ b/databases/sfcgal/Makefile
@@ -0,0 +1,25 @@
+# Created by: Loïc BARTOLETTI <coder@tuxfamily.org>
+# $FreeBSD$
+
+PORTNAME= sfcgal
+PORTVERSION= 1.0.4
+CATEGORIES= databases math graphics
+MASTER_SITES= http://github.com/Oslandia/${PORTNAME}/archive/v${PORTVERSION}.tar.gz?dummy=/
+
+MAINTAINER= coder@tuxfamily.org
+COMMENT= Wrapper library around CGAL for PostGIS
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libCGAL.so:${PORTSDIR}/math/cgal \
+ libboost_system.so:${PORTSDIR}/devel/boost-libs \
+ libgmp.so:${PORTSDIR}/math/gmp \
+ libmpfr.so:${PORTSDIR}/math/mpfr
+
+WRKSRC= ${WRKDIR}/SFCGAL-${PORTVERSION}
+
+USES= cmake compiler
+compiler_ARGS= c++0x
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/databases/sfcgal/distinfo b/databases/sfcgal/distinfo
new file mode 100644
index 000000000000..ce4d0b69ca1c
--- /dev/null
+++ b/databases/sfcgal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sfcgal-1.0.4.tar.gz) = f4660631bf42e2ed3f8b06bcd7a083f3f25e8a860a902bbb4687c60fcde1e131
+SIZE (sfcgal-1.0.4.tar.gz) = 2373804
diff --git a/databases/sfcgal/pkg-descr b/databases/sfcgal/pkg-descr
new file mode 100644
index 000000000000..3a6d87beb491
--- /dev/null
+++ b/databases/sfcgal/pkg-descr
@@ -0,0 +1,8 @@
+SFCGAL is a C++ wrapper library around CGAL with the aim of supporting ISO
+19107:2013 and OGC Simple Features Access 1.2 for 3D operations.
+
+SFCGAL provides standard compliant geometry types and operations, that can be
+accessed from its C or C++ APIs. PostGIS uses the C API, to expose some
+SFCGAL's functions in spatial databases
+
+WWW: http://www.sfcgal.org/
diff --git a/databases/sfcgal/pkg-plist b/databases/sfcgal/pkg-plist
new file mode 100644
index 000000000000..b30046abd53c
--- /dev/null
+++ b/databases/sfcgal/pkg-plist
@@ -0,0 +1,122 @@
+bin/sfcgal-config
+include/SFCGAL/Coordinate.h
+include/SFCGAL/Envelope.h
+include/SFCGAL/Exception.h
+include/SFCGAL/Geometry.h
+include/SFCGAL/GeometryCollection.h
+include/SFCGAL/GeometryVisitor.h
+include/SFCGAL/Grid.h
+include/SFCGAL/Kernel.h
+include/SFCGAL/LineString.h
+include/SFCGAL/MultiLineString.h
+include/SFCGAL/MultiPoint.h
+include/SFCGAL/MultiPolygon.h
+include/SFCGAL/MultiSolid.h
+include/SFCGAL/Point.h
+include/SFCGAL/Polygon.h
+include/SFCGAL/PolyhedralSurface.h
+include/SFCGAL/PreparedGeometry.h
+include/SFCGAL/Solid.h
+include/SFCGAL/Surface.h
+include/SFCGAL/Transform.h
+include/SFCGAL/Triangle.h
+include/SFCGAL/TriangulatedSurface.h
+include/SFCGAL/Validity.h
+include/SFCGAL/algorithm/BoundaryVisitor.h
+include/SFCGAL/algorithm/ConsistentOrientationBuilder.h
+include/SFCGAL/algorithm/area.h
+include/SFCGAL/algorithm/collect.h
+include/SFCGAL/algorithm/collectionExtract.h
+include/SFCGAL/algorithm/collectionHomogenize.h
+include/SFCGAL/algorithm/collectionToMulti.h
+include/SFCGAL/algorithm/connection.h
+include/SFCGAL/algorithm/convexHull.h
+include/SFCGAL/algorithm/covers.h
+include/SFCGAL/algorithm/difference.h
+include/SFCGAL/algorithm/distance.h
+include/SFCGAL/algorithm/distance3d.h
+include/SFCGAL/algorithm/extrude.h
+include/SFCGAL/algorithm/force2D.h
+include/SFCGAL/algorithm/force3D.h
+include/SFCGAL/algorithm/intersection.h
+include/SFCGAL/algorithm/intersects.h
+include/SFCGAL/algorithm/isValid.h
+include/SFCGAL/algorithm/length.h
+include/SFCGAL/algorithm/minkowskiSum.h
+include/SFCGAL/algorithm/normal.h
+include/SFCGAL/algorithm/offset.h
+include/SFCGAL/algorithm/orientation.h
+include/SFCGAL/algorithm/plane.h
+include/SFCGAL/algorithm/straightSkeleton.h
+include/SFCGAL/algorithm/tesselate.h
+include/SFCGAL/algorithm/translate.h
+include/SFCGAL/algorithm/volume.h
+include/SFCGAL/capi/sfcgal_c.h
+include/SFCGAL/config.h
+include/SFCGAL/config.h.cmake
+include/SFCGAL/detail/ComplexComparator.h
+include/SFCGAL/detail/EnvelopeVisitor.h
+include/SFCGAL/detail/GeometrySet.h
+include/SFCGAL/detail/GetPointsVisitor.h
+include/SFCGAL/detail/Interval.h
+include/SFCGAL/detail/TestGeometry.h
+include/SFCGAL/detail/TypeForDimension.h
+include/SFCGAL/detail/algorithm/coversPoints.h
+include/SFCGAL/detail/generator/building.h
+include/SFCGAL/detail/generator/disc.h
+include/SFCGAL/detail/generator/hoch.h
+include/SFCGAL/detail/generator/sierpinski.h
+include/SFCGAL/detail/graph/Edge.h
+include/SFCGAL/detail/graph/GeometryGraph.h
+include/SFCGAL/detail/graph/GeometryGraphBuilder.h
+include/SFCGAL/detail/graph/Vertex.h
+include/SFCGAL/detail/graph/algorithm/isHalfEdge.h
+include/SFCGAL/detail/graph/algorithm/orientation.h
+include/SFCGAL/detail/io/OsgFactory.h
+include/SFCGAL/detail/io/Serialization.h
+include/SFCGAL/detail/io/WktReader.h
+include/SFCGAL/detail/io/WktWriter.h
+include/SFCGAL/detail/polygonSetToMultiPolygon.h
+include/SFCGAL/detail/tools/CharArrayBuffer.h
+include/SFCGAL/detail/tools/InputStreamReader.h
+include/SFCGAL/detail/tools/Log.h
+include/SFCGAL/detail/tools/Registry.h
+include/SFCGAL/detail/transform/AffineTransform2.h
+include/SFCGAL/detail/transform/AffineTransform3.h
+include/SFCGAL/detail/transform/Force2D.h
+include/SFCGAL/detail/transform/ForceOrderPoints.h
+include/SFCGAL/detail/transform/ForceZ.h
+include/SFCGAL/detail/transform/ForceZOrderPoints.h
+include/SFCGAL/detail/transform/RoundTransform.h
+include/SFCGAL/detail/triangulate/ConstraintDelaunayTriangulation.h
+include/SFCGAL/detail/triangulate/markDomains.h
+include/SFCGAL/detail/triangulate/triangulateInGeometrySet.h
+include/SFCGAL/detail/ublas.h
+include/SFCGAL/export.h
+include/SFCGAL/io/GeometryStreams.h
+include/SFCGAL/io/asc.h
+include/SFCGAL/io/ewkt.h
+include/SFCGAL/io/osg.h
+include/SFCGAL/io/vtk.h
+include/SFCGAL/io/wkt.h
+include/SFCGAL/numeric.h
+include/SFCGAL/triangulate/triangulate2DZ.h
+include/SFCGAL/triangulate/triangulatePolygon.h
+include/SFCGAL/version.h
+include/SFCGAL/version.h.cmake
+lib/libSFCGAL.la
+lib/libSFCGAL.so
+@dirrmtry include/SFCGAL/triangulate
+@dirrmtry include/SFCGAL/io
+@dirrmtry include/SFCGAL/detail/triangulate
+@dirrmtry include/SFCGAL/detail/transform
+@dirrmtry include/SFCGAL/detail/tools
+@dirrmtry include/SFCGAL/detail/io
+@dirrmtry include/SFCGAL/detail/graph/algorithm
+@dirrmtry include/SFCGAL/detail/graph
+@dirrmtry include/SFCGAL/detail/generator
+@dirrmtry include/SFCGAL/detail/algorithm
+@dirrmtry include/SFCGAL/detail
+@dirrmtry include/SFCGAL/capi
+@dirrmtry include/SFCGAL/algorithm
+@dirrmtry include/SFCGAL