aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2018-05-06 17:02:02 +0800
committerdanfe <danfe@FreeBSD.org>2018-05-06 17:02:02 +0800
commit04572c0615056e42f4c659e014bb1cbf4e73073d (patch)
treec293999dfd4e039bc7b7992de2795f6e2bd7bbb5 /databases
parent6eb55b243289ad84938d59d24e171560aea9bd98 (diff)
downloadfreebsd-ports-gnome-04572c0615056e42f4c659e014bb1cbf4e73073d.tar.gz
freebsd-ports-gnome-04572c0615056e42f4c659e014bb1cbf4e73073d.tar.zst
freebsd-ports-gnome-04572c0615056e42f4c659e014bb1cbf4e73073d.zip
- Update `databases/iowow' to version 1.1.0 [*]
- Remove ONLY_FOR_ARCHS (x64-specific bits are guarded now) - Cleanup up patch hunks that were included upstream - Fix a typo and generally include port description Requested by: upstream [*]
Diffstat (limited to 'databases')
-rw-r--r--databases/iowow/Makefile8
-rw-r--r--databases/iowow/distinfo6
-rw-r--r--databases/iowow/files/patch-src_CMakeLists.txt24
-rw-r--r--databases/iowow/files/patch-src_fs_iwfile.c8
-rw-r--r--databases/iowow/files/patch-src_log_iwlog.c19
-rw-r--r--databases/iowow/pkg-descr8
-rw-r--r--databases/iowow/pkg-plist4
7 files changed, 29 insertions, 48 deletions
diff --git a/databases/iowow/Makefile b/databases/iowow/Makefile
index 4bc22c7a2678..ca46fc488128 100644
--- a/databases/iowow/Makefile
+++ b/databases/iowow/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= iowow
-PORTVERSION= 1.0.5
+PORTVERSION= 1.1.0
DISTVERSIONPREFIX= v
CATEGORIES= databases
@@ -11,9 +11,6 @@ COMMENT= Persistent key-value database engine
LICENSE= MIT
-ONLY_FOR_ARCHS= amd64 i386
-ONLY_FOR_ARCHS_REASON= invokes x86 assembler
-
USES= cmake:outsource compiler:c11
USE_GITHUB= yes
GH_ACCOUNT= Softmotions
@@ -21,7 +18,4 @@ USE_LDCONFIG= yes
PORTDOCS= Changelog README
-post-patch:
- @${REINPLACE_CMD} -e '/sizeof(size_t)/d' ${WRKSRC}/src/kv/iwkv.c
-
.include <bsd.port.mk>
diff --git a/databases/iowow/distinfo b/databases/iowow/distinfo
index bf32ff0b0bb0..afb124cd7270 100644
--- a/databases/iowow/distinfo
+++ b/databases/iowow/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1523540906
-SHA256 (Softmotions-iowow-v1.0.5_GH0.tar.gz) = e30556b3c16952f68c0ecbee3f49a1c72412ca78d2a634babe71ba4cd8f703f0
-SIZE (Softmotions-iowow-v1.0.5_GH0.tar.gz) = 170856
+TIMESTAMP = 1525256894
+SHA256 (Softmotions-iowow-v1.1.0_GH0.tar.gz) = 512725b470a2842688db62a0639104e7b08e92d952cff8ee995c23be5c1ad242
+SIZE (Softmotions-iowow-v1.1.0_GH0.tar.gz) = 186008
diff --git a/databases/iowow/files/patch-src_CMakeLists.txt b/databases/iowow/files/patch-src_CMakeLists.txt
index e1853311d3a9..bdc904326639 100644
--- a/databases/iowow/files/patch-src_CMakeLists.txt
+++ b/databases/iowow/files/patch-src_CMakeLists.txt
@@ -1,13 +1,18 @@
---- src/CMakeLists.txt.orig 2018-04-12 13:48:26 UTC
+--- src/CMakeLists.txt.orig 2018-05-02 10:28:14 UTC
+++ src/CMakeLists.txt
-@@ -121,14 +121,12 @@ if (NOT WIN32) ## todo review
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC")
+@@ -72,6 +72,11 @@ if (HAVE_CLOCK_MONOTONIC)
+ add_definitions(-DIW_HAVE_CLOCK_MONOTONIC)
endif()
--set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -D__FILENAME__='\"$(subst ${CMAKE_SOURCE_DIR}/,,$(abspath $<))\"'")
--
- if (ASAN)
- set(CMAKE_C_ASAN "-fsanitize=address -fno-omit-frame-pointer")
++check_symbol_exists(basename_r libgen.h HAVE_BASENAME_R)
++if (HAVE_BASENAME_R)
++ set_source_files_properties(log/iwlog.c PROPERTIES COMPILE_FLAGS -DIW_HAVE_BASENAME_R)
++endif()
++
+ foreach(HF IN ITEMS stdlib stddef stdint stdbool stdatomic unistd dirent)
+ string(TOUPPER "${HF}" UHF)
+ check_include_file(${HF}.h "IW_HAVE_${UHF}")
+@@ -141,7 +146,7 @@ if (ASAN)
endif()
set(CMAKE_C_FLAGS_DEBUG "-O0 -g -ggdb -Werror -DDEBUG -D_DEBUG -UNDEBUG -Wno-unused-variable ${CMAKE_C_ASAN}")
@@ -16,7 +21,7 @@
set(CMAKE_C_FLAGS_RELWITHDEBINFO "${CMAKE_C_FLAGS_RELEASE} -g")
-@@ -151,7 +149,7 @@ file(GLOB PROJECT_GENERATED_HDRS ${PROJECT_GENERATED_D
+@@ -164,7 +169,7 @@ file(GLOB PROJECT_GENERATED_HDRS ${PROJECT_GENERATED_D
list(APPEND ALL_HDRS ${PROJECT_GENERATED_HDRS})
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/tmpl/libiowow.pc.in ${PROJECT_GENERATED_DIR}/libiowow.pc @ONLY)
@@ -25,12 +30,11 @@
foreach(MODULE IN LISTS MODULES)
if (EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/${MODULE}/CMakeLists.txt)
-@@ -216,8 +214,6 @@ endif()
+@@ -229,7 +234,6 @@ endif()
install(FILES
- ${CMAKE_SOURCE_DIR}/LICENSE
-- ${CMAKE_SOURCE_DIR}/INSTALL
${CMAKE_SOURCE_DIR}/Changelog
DESTINATION ${CMAKE_INSTALL_DOCDIR})
install(FILES
diff --git a/databases/iowow/files/patch-src_fs_iwfile.c b/databases/iowow/files/patch-src_fs_iwfile.c
index d507ba2c49e7..88fc8a95dadf 100644
--- a/databases/iowow/files/patch-src_fs_iwfile.c
+++ b/databases/iowow/files/patch-src_fs_iwfile.c
@@ -1,11 +1,11 @@
---- src/fs/iwfile.c.orig 2018-04-12 13:48:26 UTC
+--- src/fs/iwfile.c.orig 2018-05-02 10:28:14 UTC
+++ src/fs/iwfile.c
-@@ -92,7 +92,7 @@ static iwrc _iwfs_sync(struct IWFS_FILE *f, iwfs_sync_
- if (fcntl(wf->fh, F_FULLFSYNC) == -1) {
+@@ -97,7 +97,7 @@ static iwrc _iwfs_sync(struct IWFS_FILE *f, iwfs_sync_
+ if (fcntl(impl->fh, F_FULLFSYNC) == -1) {
return iwrc_set_errno(IW_ERROR_IO_ERRNO, errno);
}
-#else
+#elif defined(__FreeBSD_version) && __FreeBSD_version > 1100501
- if (fdatasync(wf->fh) == -1) {
+ if (fdatasync(impl->fh) == -1) {
return iwrc_set_errno(IW_ERROR_IO_ERRNO, errno);
}
diff --git a/databases/iowow/files/patch-src_log_iwlog.c b/databases/iowow/files/patch-src_log_iwlog.c
deleted file mode 100644
index 2725380a10ea..000000000000
--- a/databases/iowow/files/patch-src_log_iwlog.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/log/iwlog.c.orig 2018-04-12 13:48:26 UTC
-+++ src/log/iwlog.c
-@@ -383,16 +383,9 @@ static iwrc _default_logfn(locale_t locale,
- ecode_msg = _ecode_explained(locale, ecode);
- }
-
--#if defined(__APPLE__) || defined(__FreeBSD__)
-- char bfile[MAXPATHLEN];
- if (file && line > 0) {
-- file = basename_r(file, bfile);
-- }
--#else
-- if (file && line > 0) {
- file = basename(file);
- }
--#endif
-
- if (ecode || errno_code || werror_code) {
- if (file && line > 0) {
diff --git a/databases/iowow/pkg-descr b/databases/iowow/pkg-descr
index a82dceb33e75..75ed88c683d2 100644
--- a/databases/iowow/pkg-descr
+++ b/databases/iowow/pkg-descr
@@ -1,14 +1,14 @@
IOWOW is persistent key-value database engine based on skip list data
-structure. Its features and imitations are:
+structure. Its features and limitations are:
- Support of multiple key-value databases within a single file
- Native support of integer keys
- Support of record values represented as sorted array of integers
- Ultra-fast traversal of database records
- - Good performance comparing its main competitors (LMDB, LevelDB,
+ - Good performance comparing to main competitors (LMDB, LevelDB,
Kyoto Cabinet)
- Tiny C11 library (150 KB), easily embeddable into any software
- - Maximum storage file size: 255 GB, maximum size of a single
- key+value record 255 MB
+ - Maximum storage file size is 255 GB, maximum size of a single
+ key+value record is 255 MB
WWW: http://iowow.io/
diff --git a/databases/iowow/pkg-plist b/databases/iowow/pkg-plist
index 74aed584909e..49c3cde8de5a 100644
--- a/databases/iowow/pkg-plist
+++ b/databases/iowow/pkg-plist
@@ -3,6 +3,7 @@ include/iowow/iowow.h
include/iowow/iwarr.h
include/iowow/iwbits.h
include/iowow/iwconv.h
+include/iowow/iwdlsnr.h
include/iowow/iwexfile.h
include/iowow/iwfile.h
include/iowow/iwfsmfile.h
@@ -10,12 +11,13 @@ include/iowow/iwkv.h
include/iowow/iwlog.h
include/iowow/iwp.h
include/iowow/iwpool.h
+include/iowow/iwrdb.h
include/iowow/iwutils.h
include/iowow/iwxstr.h
lib/libiowow-1.a
lib/libiowow.so
lib/libiowow.so.1
-lib/libiowow.so.1.0.5
+lib/libiowow.so.1.1.0
libdata/pkgconfig/libiowow.pc
man/man3/iowow.3.gz
%%DATADIR%%/iowow-exports-%%CMAKE_BUILD_TYPE%%.cmake