aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-04-03 02:26:51 +0800
committermiwi <miwi@FreeBSD.org>2009-04-03 02:26:51 +0800
commit0495167a4473f3464212207985068f0108ab1d51 (patch)
tree58b1a4b3c482bb3e88c7d25061d3c4170f34aaa1 /databases
parent599cb80201d5e62cf2ec17135fd7a5140b4f9222 (diff)
downloadfreebsd-ports-gnome-0495167a4473f3464212207985068f0108ab1d51.tar.gz
freebsd-ports-gnome-0495167a4473f3464212207985068f0108ab1d51.tar.zst
freebsd-ports-gnome-0495167a4473f3464212207985068f0108ab1d51.zip
There's plenty of modules which need a database, and they all have
to be configured differently and they're always a PITA when you first install and each and every time they upgrade. Test::Database provides a simple way for test authors to request a test database, without worrying about environment variables or the test host configuration. WWW: http://search.cpan.org/dist/Test-Database/ PR: ports/133273 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-Test-Database/Makefile33
-rw-r--r--databases/p5-Test-Database/distinfo3
-rw-r--r--databases/p5-Test-Database/pkg-descr9
-rw-r--r--databases/p5-Test-Database/pkg-plist14
5 files changed, 60 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 6cbd75a30efe..d3e39aee3361 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -374,6 +374,7 @@
SUBDIR += p5-T2
SUBDIR += p5-Tangram
SUBDIR += p5-Template-DBI
+ SUBDIR += p5-Test-Database
SUBDIR += p5-Test-DatabaseRow
SUBDIR += p5-Text-Query-SQL
SUBDIR += p5-Tie-DBI
diff --git a/databases/p5-Test-Database/Makefile b/databases/p5-Test-Database/Makefile
new file mode 100644
index 000000000000..53eca73f211e
--- /dev/null
+++ b/databases/p5-Test-Database/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Test-Database
+# Date created: 2 April, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Database
+PORTVERSION= 0.99
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Database handles ready for testing
+
+BUILD_DEPENDS= ${SITE_PERL}/mach/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/Test/Builder/Module.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-File-HomeDir>=0.84:${PORTSDIR}/devel/p5-File-HomeDir \
+ p5-version>=0.76:${PORTSDIR}/devel/p5-version
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Database.3 Test::Database::Driver.3 \
+ Test::Database::Driver::CSV.3 \
+ Test::Database::Driver::DBM.3 \
+ Test::Database::Driver::SQLite2.3 \
+ Test::Database::Driver::mysql.3 \
+ Test::Database::Handle.3 \
+ Test::Database::Driver::SQLite.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-Test-Database/distinfo b/databases/p5-Test-Database/distinfo
new file mode 100644
index 000000000000..17b5255c91ff
--- /dev/null
+++ b/databases/p5-Test-Database/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-Database-0.99.tar.gz) = fcbc42ad0e918db56a00a94aeeb637ca
+SHA256 (Test-Database-0.99.tar.gz) = 5327ea775dc6acf647d5643fc5a09957ed38219aa4cf1baa21322e0f64777179
+SIZE (Test-Database-0.99.tar.gz) = 12912
diff --git a/databases/p5-Test-Database/pkg-descr b/databases/p5-Test-Database/pkg-descr
new file mode 100644
index 000000000000..cb5a50fa970b
--- /dev/null
+++ b/databases/p5-Test-Database/pkg-descr
@@ -0,0 +1,9 @@
+There's plenty of modules which need a database, and they all have
+to be configured differently and they're always a PITA when you first
+install and each and every time they upgrade.
+
+Test::Database provides a simple way for test authors to request
+a test database, without worrying about environment variables or the
+test host configuration.
+
+WWW: http://search.cpan.org/dist/Test-Database/
diff --git a/databases/p5-Test-Database/pkg-plist b/databases/p5-Test-Database/pkg-plist
new file mode 100644
index 000000000000..30c29baa201f
--- /dev/null
+++ b/databases/p5-Test-Database/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Database/.packlist
+%%SITE_PERL%%/Test/Database.pm
+%%SITE_PERL%%/Test/Database/Driver.pm
+%%SITE_PERL%%/Test/Database/Handle.pm
+%%SITE_PERL%%/Test/Database/Driver/CSV.pm
+%%SITE_PERL%%/Test/Database/Driver/DBM.pm
+%%SITE_PERL%%/Test/Database/Driver/SQLite2.pm
+%%SITE_PERL%%/Test/Database/Driver/mysql.pm
+%%SITE_PERL%%/Test/Database/Driver/SQLite.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Database
+@dirrm %%SITE_PERL%%/Test/Database/Driver
+@dirrm %%SITE_PERL%%/Test/Database
+@dirrmtry %%SITE_PERL%%/Test
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test