aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-15 16:20:27 +0800
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-15 16:20:27 +0800
commit074ea5282a00d556c73d86231bec5444990597dc (patch)
treeeec3d608e84e79f0187985e5a1e29cd4f04f13eb /databases
parent522c152d1c7b0c92982e310110fa6d59f915ffeb (diff)
downloadfreebsd-ports-gnome-074ea5282a00d556c73d86231bec5444990597dc.tar.gz
freebsd-ports-gnome-074ea5282a00d556c73d86231bec5444990597dc.tar.zst
freebsd-ports-gnome-074ea5282a00d556c73d86231bec5444990597dc.zip
converters/libiconv:
- Remove const qualifier from iconv(3) to match POSIX: http://pubs.opengroup.org/onlinepubs/9699919799/functions/iconv.html - Patch iconv.h to expose more GNU extensions when LIBICONV_PLUG is defined because the base system iconv supports these extensions too. Add/remove patches to/from ports to call iconv with non-const arguments. This breaks some ports on FreeBSD 10 because base system iconv.h still has the const qualifier. Fix this by letting USES=iconv add a build dependency on converters/libiconv so ports can use its iconv.h (with LIBICONV_PLUG defined) instead of the base system iconv.h. This exposed some ports that link with libiconv when it is available instead of using libc iconv. In these cases one of the following changes has been made: - patch configure scripts to test for libc iconv first - add ac_cv_lib_iconv_libiconv=no or similar to CONFIGURE_ARGS to disable some configure tests - converters/wkhtmltopdf: this includes Qt4 so add a patch from devel/qt4 - lang/gcc5-aux: respect CFLAGS and friends during configure such that LIBICONV_PLUG is defined in the iconv test, also switch to external gettext - mail/gnarwl: replace patches with CPPFLAGS/LIBS - multimedia/ffmpeg2theora: remove iconv test from SConstruct and use ICONV_LIB in port Makefile instead, also fix a bug in subtitles.c - net-im/licq: finish conversion to cmake - net-mgmt/bandwidthd, net-mgmt/icinga, net-mgmt/nagios, net-mgmt/nagios4: don't need iconv - textproc/p5-XML-TinyXML: finish conversion to USES=perl5 Other changes: - databases/qdbm and slaves: respect CFLAGS and friends, also enable bzip2 and lzo support - games/ldmud: respect CFLAGS and friends - graphics/inventor: replace some patches with MAKE_ARGS/MAKE_ENV to respect CFLAGS and friends, also remove FreeBSD/alpha patch and add missing xorg dependencies PR: 199099 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'databases')
-rw-r--r--databases/kbibtex/Makefile4
-rw-r--r--databases/kbibtex/files/patch-src__libkbibtexio__iconvlatex.cpp11
-rw-r--r--databases/mysql-workbench52/files/patch-plugins__migration__copytable__copytable.cpp20
-rw-r--r--databases/p5-qdbm/Makefile1
-rw-r--r--databases/p5-qdbm/files/patch-Makefile.in4
-rw-r--r--databases/qdbm-plus/Makefile2
-rw-r--r--databases/qdbm-plus/files/patch-Makefile.in (renamed from databases/qdbm/files/patch-plus__Makefile.in)7
-rw-r--r--databases/qdbm/Makefile41
-rw-r--r--databases/qdbm/files/patch-Makefile.in27
-rw-r--r--databases/qdbm/files/patch-java__Makefile.in10
-rw-r--r--databases/ruby-qdbm/Makefile4
11 files changed, 38 insertions, 93 deletions
diff --git a/databases/kbibtex/Makefile b/databases/kbibtex/Makefile
index c5821a7c6f00..8ed1593644dc 100644
--- a/databases/kbibtex/Makefile
+++ b/databases/kbibtex/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kbibtex
DISTVERSION= 0.4.1
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= databases kde
MASTER_SITES= http://download.gna.org/${PORTNAME}/${PORTVERSION:C,(^[[:digit:]]\.[[:digit:]]).*,\1,}/
@@ -12,7 +12,7 @@ COMMENT= Bibliography editor for KDE
LIB_DEPENDS= libpoppler-qt4.so:${PORTSDIR}/graphics/poppler-qt4
-USES= cmake shared-mime-info tar:bzip2
+USES= cmake iconv shared-mime-info tar:bzip2
USE_GNOME= libxml2 libxslt
USE_KDE4= kdelibs kdeprefix automoc4
USE_QT4= qmake_build moc_build uic_build rcc_build \
diff --git a/databases/kbibtex/files/patch-src__libkbibtexio__iconvlatex.cpp b/databases/kbibtex/files/patch-src__libkbibtexio__iconvlatex.cpp
deleted file mode 100644
index 1769cd6b4c3d..000000000000
--- a/databases/kbibtex/files/patch-src__libkbibtexio__iconvlatex.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/libkbibtexio/iconvlatex.cpp.orig 2012-05-05 10:50:42.000000000 +0000
-+++ ./src/libkbibtexio/iconvlatex.cpp 2012-05-06 00:53:04.285249457 +0000
-@@ -58,7 +58,7 @@
- QByteArray IConvLaTeX::encode(const QString &input)
- {
- QByteArray inputByteArray = input.toUtf8();
--#ifdef Q_WS_WIN
-+#ifndef Q_OS_LINUX
- /// iconv on Windows likes to have it as const char *
- const char *inputBuffer = inputByteArray.data();
- #else
diff --git a/databases/mysql-workbench52/files/patch-plugins__migration__copytable__copytable.cpp b/databases/mysql-workbench52/files/patch-plugins__migration__copytable__copytable.cpp
deleted file mode 100644
index f8e0d2fa40c0..000000000000
--- a/databases/mysql-workbench52/files/patch-plugins__migration__copytable__copytable.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- plugins/migration/copytable/copytable.cpp.orig
-+++ plugins/migration/copytable/copytable.cpp
-@@ -555,7 +555,7 @@
- //log_debug3("Convert string with %i chars to buffer size %i\n", inbuf_len, outbuf_len);
-
- // convert data from UCS-2 to utf-8
--#ifdef _WIN32
-+#if defined(_WIN32) || defined(__FreeBSD__)
- converted = iconv(_iconv,
- (const char**)&inbuf, &inbuf_len,
- (char**)&outbuf, &outbuf_len);
-@@ -617,7 +617,7 @@
- //log_debug3("Convert string with %i chars to buffer size %i\n", inbuf_len, outbuf_len);
-
- // convert data from UCS-2 to utf-8
--#ifdef _WIN32
-+#if defined(_WIN32) || defined(__FreeBSD__)
- converted = iconv(_iconv,
- (const char**)&inbuf, &inbuf_len,
- (char**)&outbuf, &outbuf_len);
diff --git a/databases/p5-qdbm/Makefile b/databases/p5-qdbm/Makefile
index 6fb2cd6fcb5b..43237ab52db3 100644
--- a/databases/p5-qdbm/Makefile
+++ b/databases/p5-qdbm/Makefile
@@ -1,6 +1,7 @@
# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
+PORTREVISION= 2
PKGNAMEPREFIX= p5-
COMMENT= Perl API for QDBM
diff --git a/databases/p5-qdbm/files/patch-Makefile.in b/databases/p5-qdbm/files/patch-Makefile.in
index c41668245581..7e2154a32318 100644
--- a/databases/p5-qdbm/files/patch-Makefile.in
+++ b/databases/p5-qdbm/files/patch-Makefile.in
@@ -5,11 +5,11 @@
# Building binaries
-CC = gcc
-+CC ?= gcc
++CC = @CC@
INC = -I. -I../.. -I$(HOME)/include -I/usr/local/include
OPTIMIZE = -O2
-LD = gcc
-+LD ?= gcc
++LD = @CC@
LIBS = -L../.. -I$(HOME)/lib -L/usr/local/lib -lqdbm @LIBS@
RUNENV = LD_LIBRARY_PATH=.:..:../..:/usr/local/lib:$(HOME)/lib
diff --git a/databases/qdbm-plus/Makefile b/databases/qdbm-plus/Makefile
index 057d5d821ecc..b9bd81b14bee 100644
--- a/databases/qdbm-plus/Makefile
+++ b/databases/qdbm-plus/Makefile
@@ -1,7 +1,7 @@
# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 0
+PORTREVISION= 2
PKGNAMESUFFIX= -plus
COMMENT= C++ API for QDBM
diff --git a/databases/qdbm/files/patch-plus__Makefile.in b/databases/qdbm-plus/files/patch-Makefile.in
index 35e31fe36e35..17d294b238ff 100644
--- a/databases/qdbm/files/patch-plus__Makefile.in
+++ b/databases/qdbm-plus/files/patch-Makefile.in
@@ -1,10 +1,11 @@
---- plus/Makefile.in.orig 2014-05-03 18:41:29.000000000 +0300
-+++ plus/Makefile.in 2014-05-03 18:41:32.000000000 +0300
-@@ -44,7 +44,6 @@
+--- Makefile.in.orig 2007-03-07 02:44:50 UTC
++++ Makefile.in
+@@ -44,7 +44,7 @@ CPPFLAGS = @CPPFLAGS@ -I$(srcdir) -I$(sr
-D_XOPEN_SOURCE_EXTENDED=1 -D_GNU_SOURCE=1 -D__EXTENSIONS__=1 -D_HPUX_SOURCE=1 \
-D_POSIX_MAPPED_FILES=1 -D_POSIX_SYNCHRONIZED_IO=1 \
-DPIC=1 -D_THREAD_SAFE=1 -D_REENTRANT=1 -DNDEBUG
-CXXFLAGS = -Wall -ansi -pedantic -fsigned-char -fPIC -O2 -fno-strict-aliasing @MYOPTS@
++CXXFLAGS = @CXXFLAGS@ -Wall -ansi -pedantic -fsigned-char -fPIC -fno-strict-aliasing
LD = @LD@
LIBS = -lqdbm @LIBS@
LIBLDFLAGS = @LDFLAGS@ -L. -L$(srcdir)/.. -L$(MYLIBDIR) \
diff --git a/databases/qdbm/Makefile b/databases/qdbm/Makefile
index d13a66ede1e5..e7b94b2a71dd 100644
--- a/databases/qdbm/Makefile
+++ b/databases/qdbm/Makefile
@@ -3,36 +3,39 @@
PORTNAME= qdbm
PORTVERSION= 1.8.78
-PORTREVISION= 1
+PORTREVISION?= 2
CATEGORIES= databases
MASTER_SITES= http://fallabs.com/qdbm/
MAINTAINER= ports@FreeBSD.org
COMMENT?= Quick Database Manager
+LIB_DEPENDS= liblzo2.so:${PORTSDIR}/archivers/lzo2
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CFLAGS+= -fPIC
.if !defined(SLAVEPORT)
USES+= iconv
-CONFIGURE_ARGS= --enable-zlib \
+CONFIGURE_ARGS= --enable-bzip --enable-lzo --enable-zlib \
--enable-iconv \
--enable-pthread
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -lpthread -L${LOCALBASE}/lib
-MAKE_ARGS= RELCFLAGS="${CFLAGS}" \
- MYDATADIR="${DOCSDIR}" MYDOCS="${PORTDOCS}"
+LIBS+= -L${LOCALBASE}/lib
+MAKE_ARGS= MYDATADIR="${DOCSDIR}" MYDOCS="${PORTDOCS}" \
+ MYPCDIR="${PREFIX}/libdata/pkgconfig"
PORTDOCS= ChangeLog NEWS
post-patch:
- @${REINPLACE_CMD} -e 's|@libdir@/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
- ${WRKSRC}/Makefile.in
+.if defined(WITH_DEBUG) && !defined(WITHOUT_DEBUG)
+ @${REINPLACE_CMD} 's/-DNDEBUG//' ${WRKSRC}/Makefile.in
+.endif
+ @${REINPLACE_CMD} 's/-liconv/${ICONV_LIB}/' ${WRKSRC}/configure
post-build:
(cd ${WRKSRC}/lab && ${MAKE} CC="${CC}" CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${ICONV_LIB}" \
+ CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
fmtcnv031127)
post-install:
@@ -43,19 +46,15 @@ post-install:
LIB_DEPENDS+= libqdbm.so:${PORTSDIR}/databases/qdbm
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/java|${JAVA_HOME}|' ${WRKSRC}/configure
-.if ${SLAVEPORT}=="ruby"
- @${FIND} ${WRKSRC} -type f | \
- ${XARGS} -n 10 ${REINPLACE_CMD} -e \
- 's|/usr/bin/ruby -w|${SETENV} ruby|'
- @${FIND} ${WRKSRC} -name '*.bak' | ${XARGS} ${RM} -f
+.if defined(WITH_DEBUG) && !defined(WITHOUT_DEBUG)
+ @${REINPLACE_CMD} 's/-DNDEBUG//' ${WRKSRC}/Makefile.in
.endif
+ @${REINPLACE_CMD} -e 's/-liconv//' -e 's/-lstdc++//' ${WRKSRC}/configure
+.if ${SLAVEPORT} == "ruby"
+ @${REINPLACE_CMD} '/iconv/d' ${WRKSRC}/curia/extconf.rb \
+ ${WRKSRC}/depot/extconf.rb ${WRKSRC}/villa/extconf.rb
.endif
-.include <bsd.port.pre.mk>
-
-.if !defined(SLAVEPORT) && defined(WITH_DEBUG)
-CONFIGURE_ARGS+= --enable-debug
-.endif
+.endif # !defined(SLAVEPORT)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/qdbm/files/patch-Makefile.in b/databases/qdbm/files/patch-Makefile.in
index e6322eb12af3..1eeb64fc78e7 100644
--- a/databases/qdbm/files/patch-Makefile.in
+++ b/databases/qdbm/files/patch-Makefile.in
@@ -1,30 +1,11 @@
---- Makefile.in.orig 2010-08-04 20:14:34.000000000 +0300
-+++ Makefile.in 2014-05-03 18:41:01.000000000 +0300
-@@ -46,7 +46,7 @@
- MYMAN1DIR = @mandir@/man1
- MYMAN3DIR = @mandir@/man3
- MYDATADIR = @datadir@/$(PACKAGE)
--MYPCDIR = @libdir@/pkgconfig
-+MYPCDIR = /usr/local/libdata/pkgconfig
- DESTDIR =
-
- # Building binaries
-@@ -56,7 +56,6 @@
+--- Makefile.in.orig 2010-08-04 17:14:34 UTC
++++ Makefile.in
+@@ -56,7 +56,7 @@ CPPFLAGS = @CPPFLAGS@ -I$(srcdir) -I$(MY
-D_XOPEN_SOURCE_EXTENDED=1 -D_GNU_SOURCE=1 -D__EXTENSIONS__=1 -D_HPUX_SOURCE=1 \
-D_POSIX_MAPPED_FILES=1 -D_POSIX_SYNCHRONIZED_IO=1 \
-DPIC=1 -D_THREAD_SAFE=1 -D_REENTRANT=1 -DNDEBUG
-CFLAGS = -Wall -pedantic -fPIC -fsigned-char -O3 -fomit-frame-pointer -fforce-addr @MYOPTS@
++CFLAGS = @CFLAGS@ -Wall -pedantic -fPIC -fsigned-char
LD = @LD@
LIBS = -lqdbm @LIBS@
LIBLDFLAGS = @LDFLAGS@ -L. -L$(MYLIBDIR) -L$(HOME)/lib -L/usr/local/lib @LIBS@
-@@ -170,8 +169,10 @@
- cd $(srcdir)/man && cp -Rf $(MYMAN1S) $(DESTDIR)$(MYMAN1DIR)
- mkdir -p $(DESTDIR)$(MYMAN3DIR)
- cd $(srcdir)/man && cp -Rf $(MYMAN3S) $(DESTDIR)$(MYMAN3DIR)
-+.if $(MYDOCS) != ""
- mkdir -p $(DESTDIR)$(MYDATADIR)
- cd $(srcdir) && cp -Rf $(MYDOCS) $(DESTDIR)$(MYDATADIR)
-+.endif
- mkdir -p $(DESTDIR)$(MYPCDIR)
- cd $(srcdir) && cp -Rf $(MYPCS) $(DESTDIR)$(MYPCDIR)
- @printf '\n'
diff --git a/databases/qdbm/files/patch-java__Makefile.in b/databases/qdbm/files/patch-java__Makefile.in
deleted file mode 100644
index 82ec1027b52a..000000000000
--- a/databases/qdbm/files/patch-java__Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- java/Makefile.in.orig 2014-05-03 18:41:15.000000000 +0300
-+++ java/Makefile.in 2014-05-03 18:41:21.000000000 +0300
-@@ -56,7 +56,6 @@
- @MYDEFS@ -D_XOPEN_SOURCE_EXTENDED=1 -D_GNU_SOURCE=1 -D__EXTENSIONS__=1 -D_HPUX_SOURCE=1 \
- -D_POSIX_MAPPED_FILES=1 -D_POSIX_SYNCHRONIZED_IO=1 \
- -DPIC=1 -D_THREAD_SAFE=1 -D_REENTRANT=1 -DNDEBUG
--CFLAGS = -Wall -fPIC -fsigned-char -O2 @MYOPTS@
- LD = @LD@
- LIBS = -lqdbm @LIBS@
- LIBLDFLAGS = @LDFLAGS@ -L. -L$(srcdir)/.. -L$(MYLIBDIR) -L$(HOME)/lib -L/usr/local/lib $(LIBS)
diff --git a/databases/ruby-qdbm/Makefile b/databases/ruby-qdbm/Makefile
index 9e7685ac15e9..9e8a6e819330 100644
--- a/databases/ruby-qdbm/Makefile
+++ b/databases/ruby-qdbm/Makefile
@@ -1,13 +1,17 @@
# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
+PORTREVISION= 2
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
COMMENT= Ruby API for QDBM
SLAVEPORT= ruby
+USES= shebangfix
+SHEBANG_FILES= curia/rbcrtest depot/rbdptest myrbdoc villa/rbvltest
USE_RUBY= yes
+
MASTERDIR= ${.CURDIR}/../../databases/qdbm
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/ruby
PLIST= ${.CURDIR}/pkg-plist