aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2011-10-29 19:45:20 +0800
committerbeat <beat@FreeBSD.org>2011-10-29 19:45:20 +0800
commit12426cc2a8ee1f3640ea96e5f04b39c1dca7f749 (patch)
tree5805fd4e6a792ac0c9e7b03300949c5d1b58e6a4 /databases
parent0392e15d4d9799e91a21fa91050eeaf639d098a5 (diff)
downloadfreebsd-ports-gnome-12426cc2a8ee1f3640ea96e5f04b39c1dca7f749.tar.gz
freebsd-ports-gnome-12426cc2a8ee1f3640ea96e5f04b39c1dca7f749.tar.zst
freebsd-ports-gnome-12426cc2a8ee1f3640ea96e5f04b39c1dca7f749.zip
- Fix build on FreeBSD 10. Apply manual fix as the configure script is
outside of WRKSRC and the WITH_FBSD10_FIX knob doesn't work in this case. Approved by: portmgr (miwi)
Diffstat (limited to 'databases')
-rw-r--r--databases/db4/Makefile4
-rw-r--r--databases/db41/Makefile4
-rw-r--r--databases/db43/Makefile2
-rw-r--r--databases/db44/Makefile3
-rw-r--r--databases/db46/Makefile5
-rw-r--r--databases/db47/Makefile5
-rw-r--r--databases/db48/Makefile5
-rw-r--r--databases/db5/Makefile5
8 files changed, 33 insertions, 0 deletions
diff --git a/databases/db4/Makefile b/databases/db4/Makefile
index 87f2ef2c6056..1a6cb7211464 100644
--- a/databases/db4/Makefile
+++ b/databases/db4/Makefile
@@ -42,4 +42,8 @@ post-patch:
@${REINPLACE_CMD} -Ee \
's|-l?pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+pre-configure:
+ @${REINPLACE_CMD} -e 's|freebsd1\*)|freebsd1\.\*)|' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
.include <bsd.port.mk>
diff --git a/databases/db41/Makefile b/databases/db41/Makefile
index 2f6454584732..3f19a8bc8ee9 100644
--- a/databases/db41/Makefile
+++ b/databases/db41/Makefile
@@ -45,4 +45,8 @@ post-patch:
@${REINPLACE_CMD} -Ee \
's|-l?pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+pre-configure:
+ @${REINPLACE_CMD} -e 's|freebsd1\*)|freebsd1\.\*)|' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
.include <bsd.port.post.mk>
diff --git a/databases/db43/Makefile b/databases/db43/Makefile
index 185ba99a9066..48c5d167c295 100644
--- a/databases/db43/Makefile
+++ b/databases/db43/Makefile
@@ -41,6 +41,8 @@ pre-patch:
${REINPLACE_CMD} -Ee 's|-l?pthread|${PTHREAD_LIBS}|g; s,/usr/bin/objformat \|\| echo aout,/usr/bin/objformat || echo elf,' ${WRKSRC}/${CONFIGURE_SCRIPT}
pre-configure:
+ @${REINPLACE_CMD} -e 's|freebsd1\*)|freebsd1\.\*)|' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
${CHMOD} u+w ${WRKSRC}/../dist/configure
post-configure:
diff --git a/databases/db44/Makefile b/databases/db44/Makefile
index ef8c10798e24..a127955d88b0 100644
--- a/databases/db44/Makefile
+++ b/databases/db44/Makefile
@@ -40,6 +40,9 @@ pre-patch:
@${REINPLACE_CMD} -Ee 's|-l?pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/${CONFIGURE_SCRIPT}
pre-configure:
+ @${REINPLACE_CMD} -e 's|freebsd1\*)|freebsd1\.\*)|' \
+ -e 's|freebsd\[123\]\*)|freebsd\[123\]\.\*)|' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
@${CHMOD} u+w ${WRKSRC}/../dist/configure
post-configure:
diff --git a/databases/db46/Makefile b/databases/db46/Makefile
index 39c7f13b745a..1e4b2bfd652a 100644
--- a/databases/db46/Makefile
+++ b/databases/db46/Makefile
@@ -55,6 +55,11 @@ INSTALL_TARGET+= install_docs docdir=${DOCSDIR}
PORTDOCS= *
.endif
+pre-configure:
+ @${REINPLACE_CMD} -e 's|freebsd1\*)|freebsd1\.\*)|' \
+ -e 's|freebsd\[123\]\*)|freebsd\[123\]\.\*)|' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
post-install:
.for i in libdb libdb_cxx
${LN} -s -f ${PORTNAME}/${i}-${BDBVER}.so.0 ${PREFIX}/lib
diff --git a/databases/db47/Makefile b/databases/db47/Makefile
index 635aa8520c30..891c687fa65b 100644
--- a/databases/db47/Makefile
+++ b/databases/db47/Makefile
@@ -53,6 +53,11 @@ INSTALL_TARGET+= install_docs docdir=${DOCSDIR}
PORTDOCS= *
.endif
+pre-configure:
+ @${REINPLACE_CMD} -e 's|freebsd1\*)|freebsd1\.\*)|' \
+ -e 's|freebsd\[123\]\*)|freebsd\[123\]\.\*)|' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
post-install:
.for i in libdb libdb_cxx
${LN} -s -f ${PORTNAME}/${i}-${BDBVER}.so.0 ${PREFIX}/lib
diff --git a/databases/db48/Makefile b/databases/db48/Makefile
index 95d14f965882..9ace74f87093 100644
--- a/databases/db48/Makefile
+++ b/databases/db48/Makefile
@@ -32,6 +32,11 @@ LIBTOOLFILES= ${CONFIGURE_SCRIPT}
WRKSRC= ${WRKDIR}/${DISTNAME}/build_unix
USE_LDCONFIG= yes
+pre-configure:
+ @${REINPLACE_CMD} -e 's|freebsd1\*)|freebsd1\.\*)|' \
+ -e 's|freebsd\[123\]\*)|freebsd\[123\]\.\*)|' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
post-install:
.for i in libdb libdb_cxx
${LN} -s -f ${PORTNAME}/${i}-${BDBVER}.so.0 ${PREFIX}/lib
diff --git a/databases/db5/Makefile b/databases/db5/Makefile
index 02e850cf228d..4c2afce6ba9c 100644
--- a/databases/db5/Makefile
+++ b/databases/db5/Makefile
@@ -84,6 +84,11 @@ CONFIGURE_ARGS+= --enable-debug --enable-umrw
post-patch:
${REINPLACE_CMD} -e '/^DOCLIST/{s/csharp//;}' ${WRKSRC}/../dist/Makefile.in
+pre-configure:
+ @${REINPLACE_CMD} -e 's|freebsd1\*)|freebsd1\.\*)|' \
+ -e 's|freebsd\[123\]\*)|freebsd\[123\]\.\*)|' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
post-install:
.for i in libdb libdb_cxx libdb_stl ${libdb_sql} ${libdb_java}
${LN} -s -f ${PORTNAME}/${i}-${BDBVER}.so.0 ${PREFIX}/lib