aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2016-02-15 02:57:53 +0800
committerkwm <kwm@FreeBSD.org>2016-02-15 02:57:53 +0800
commit189722383bc516c4795233d42fc85471adbfb78c (patch)
treecb5a8a1108829deee66dbb334ff2a733162448c6 /databases
parent140d30a2a631f34b0530c4177867d6b09a692ed2 (diff)
downloadfreebsd-ports-gnome-189722383bc516c4795233d42fc85471adbfb78c.tar.gz
freebsd-ports-gnome-189722383bc516c4795233d42fc85471adbfb78c.tar.zst
freebsd-ports-gnome-189722383bc516c4795233d42fc85471adbfb78c.zip
The FreeBSD GNOME team proudly presents GNOME 3.18 for FreeBSD.
The offical GNOME 3.18 release notes can be found at https://help.gnome.org/misc/release-notes/3.18/ This update doesn't contain the glib/gtk c++ bindings which will be done in a another update due to the requirement on c++11 and the amount of fallout this probably will give. GDM is still at version 3.16 due to some issues. Bump mate-themes to use the gtk 3.18 version of the themes. Thanks to Antoine Brodin for running the exp-runs. This release was made possible by the following people: Gustau Perez Ting-Wei_Lan PR: 207006
Diffstat (limited to 'databases')
-rw-r--r--databases/evolution-data-server/Makefile21
-rw-r--r--databases/evolution-data-server/distinfo4
-rw-r--r--databases/evolution-data-server/pkg-plist51
3 files changed, 40 insertions, 36 deletions
diff --git a/databases/evolution-data-server/Makefile b/databases/evolution-data-server/Makefile
index 4c1a6080f8ba..3b75eebbeaec 100644
--- a/databases/evolution-data-server/Makefile
+++ b/databases/evolution-data-server/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= evolution-data-server
-PORTVERSION= 3.16.5
+PORTVERSION= 3.18.4
CATEGORIES= databases gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -26,7 +26,8 @@ LIB_DEPENDS= libsoup-gnome-2.4.so:${PORTSDIR}/devel/libsoup-gnome \
PORTSCOUT= limitw:1,even
-USES= bison gettext gmake gperf libtool pathfix pkgconfig tar:xz
+USES= bison gettext gmake gnome gperf libtool pathfix pkgconfig \
+ sqlite tar:xz
# Unbreak mail/evolution with webkit-gtk3 on FreeBSD 8 and 9. Normally
# this change would be done there, but it is not a C++ application, so it
# does not link directly to libstdc++ and adding the libstdc++ rpath to
@@ -34,7 +35,6 @@ USES= bison gettext gmake gperf libtool pathfix pkgconfig tar:xz
USES+= compiler:c++11-lib
USE_GNOME= gtk30 intltool introspection:build libxml2
USE_OPENLDAP= yes
-USE_SQLITE= yes
GNU_CONFIGURE= yes
USE_BDB= 5
USE_LDCONFIG= yes
@@ -55,12 +55,16 @@ GLIB_SCHEMAS= org.gnome.Evolution.DefaultSources.gschema.xml \
org.gnome.evolution-data-server.gschema.xml \
org.gnome.evolution.shell.network-config.gschema.xml
-PLIST_SUB= VERSION="3.16" EVO_VERSION="1.2"
+PLIST_SUB= VERSION="3.18" EVO_VERSION="1.2"
+OPTIONS_SUB= yes
OPTIONS_DEFINE= WEATHER KERBEROS
OPTIONS_DEFAULT=WEATHER KERBEROS
WEATHER_DESC= Weather calendar backend
+WEATHER_LIB_DEPENDS= libgweather-3.so:${PORTSDIR}/net/libgweather
+WEATHER_CONFIGURE_ENABLE= weather
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MKERBEROS} && exists(/usr/bin/krb5-config)
@@ -70,15 +74,6 @@ KRB5_LIB= `/usr/bin/krb5-config gssapi --libs`
CONFIGURE_ARGS+= --without-krb5
.endif
-.if ${PORT_OPTIONS:MWEATHER}
-LIB_DEPENDS+= libgweather-3.so:${PORTSDIR}/net/libgweather
-CONFIGURE_ARGS+= --enable-weather
-PLIST_SUB+= WEATHER=""
-.else
-CONFIGURE_ARGS+= --disable-weather
-PLIST_SUB+= WEATHER="@comment "
-.endif
-
EDS_BDB_MSG= "!!!WARNING!!!: Berkeley Database version is ${BDB_VER}. If this is an upgrade, you may experience problems if you or any other Evolution-data-server users were previously using BDB_VER 5."
pre-everything::
diff --git a/databases/evolution-data-server/distinfo b/databases/evolution-data-server/distinfo
index 974b1f24a21a..4842b629ddd4 100644
--- a/databases/evolution-data-server/distinfo
+++ b/databases/evolution-data-server/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome3/evolution-data-server-3.16.5.tar.xz) = e44ad4143402957cab8cab1a6b3d7057d8b111d268c6b9ad4e4008850f5b244c
-SIZE (gnome3/evolution-data-server-3.16.5.tar.xz) = 5364120
+SHA256 (gnome3/evolution-data-server-3.18.4.tar.xz) = 0b756f05feae538676832acc122407046a89d4dd32da725789229dc3c416433f
+SIZE (gnome3/evolution-data-server-3.18.4.tar.xz) = 5413312
diff --git a/databases/evolution-data-server/pkg-plist b/databases/evolution-data-server/pkg-plist
index 1ed94a07631f..c30bd73ee985 100644
--- a/databases/evolution-data-server/pkg-plist
+++ b/databases/evolution-data-server/pkg-plist
@@ -117,6 +117,7 @@ include/evolution-data-server/libebackend/e-backend-enums.h
include/evolution-data-server/libebackend/e-backend-enumtypes.h
include/evolution-data-server/libebackend/e-backend-factory.h
include/evolution-data-server/libebackend/e-backend.h
+include/evolution-data-server/libebackend/e-cache-reaper.h
include/evolution-data-server/libebackend/e-collection-backend-factory.h
include/evolution-data-server/libebackend/e-collection-backend.h
include/evolution-data-server/libebackend/e-data-factory.h
@@ -128,8 +129,6 @@ include/evolution-data-server/libebackend/e-oauth2-support.h
include/evolution-data-server/libebackend/e-offline-listener.h
include/evolution-data-server/libebackend/e-server-side-source-credentials-provider.h
include/evolution-data-server/libebackend/e-server-side-source.h
-include/evolution-data-server/libebackend/e-soup-auth-bearer.h
-include/evolution-data-server/libebackend/e-soup-ssl-trust.h
include/evolution-data-server/libebackend/e-source-registry-server.h
include/evolution-data-server/libebackend/e-sqlite3-vfs.h
include/evolution-data-server/libebackend/e-subprocess-factory.h
@@ -137,15 +136,6 @@ include/evolution-data-server/libebackend/e-user-prompter-server-extension.h
include/evolution-data-server/libebackend/e-user-prompter-server.h
include/evolution-data-server/libebackend/e-user-prompter.h
include/evolution-data-server/libebackend/libebackend.h
-include/evolution-data-server/libebook/e-book-client-cursor.h
-include/evolution-data-server/libebook/e-book-client-view.h
-include/evolution-data-server/libebook/e-book-client.h
-include/evolution-data-server/libebook/e-book-enumtypes.h
-include/evolution-data-server/libebook/e-book-types.h
-include/evolution-data-server/libebook/e-book-view.h
-include/evolution-data-server/libebook/e-book.h
-include/evolution-data-server/libebook/e-destination.h
-include/evolution-data-server/libebook/libebook.h
include/evolution-data-server/libebook-contacts/e-address-western.h
include/evolution-data-server/libebook-contacts/e-book-contacts-enumtypes.h
include/evolution-data-server/libebook-contacts/e-book-contacts-types.h
@@ -156,6 +146,15 @@ include/evolution-data-server/libebook-contacts/e-phone-number.h
include/evolution-data-server/libebook-contacts/e-source-backend-summary-setup.h
include/evolution-data-server/libebook-contacts/e-vcard.h
include/evolution-data-server/libebook-contacts/libebook-contacts.h
+include/evolution-data-server/libebook/e-book-client-cursor.h
+include/evolution-data-server/libebook/e-book-client-view.h
+include/evolution-data-server/libebook/e-book-client.h
+include/evolution-data-server/libebook/e-book-enumtypes.h
+include/evolution-data-server/libebook/e-book-types.h
+include/evolution-data-server/libebook/e-book-view.h
+include/evolution-data-server/libebook/e-book.h
+include/evolution-data-server/libebook/e-destination.h
+include/evolution-data-server/libebook/libebook.h
include/evolution-data-server/libecal/e-cal-check-timezones.h
include/evolution-data-server/libecal/e-cal-client-view.h
include/evolution-data-server/libecal/e-cal-client.h
@@ -218,7 +217,10 @@ include/evolution-data-server/libedataserver/e-memory.h
include/evolution-data-server/libedataserver/e-module.h
include/evolution-data-server/libedataserver/e-operation-pool.h
include/evolution-data-server/libedataserver/e-proxy.h
+include/evolution-data-server/libedataserver/e-secret-store.h
include/evolution-data-server/libedataserver/e-sexp.h
+include/evolution-data-server/libedataserver/e-soup-auth-bearer.h
+include/evolution-data-server/libedataserver/e-soup-ssl-trust.h
include/evolution-data-server/libedataserver/e-source-address-book.h
include/evolution-data-server/libedataserver/e-source-alarms.h
include/evolution-data-server/libedataserver/e-source-authentication.h
@@ -227,6 +229,7 @@ include/evolution-data-server/libedataserver/e-source-backend.h
include/evolution-data-server/libedataserver/e-source-calendar.h
include/evolution-data-server/libedataserver/e-source-camel.h
include/evolution-data-server/libedataserver/e-source-collection.h
+include/evolution-data-server/libedataserver/e-source-contacts.h
include/evolution-data-server/libedataserver/e-source-credentials-provider-impl-password.h
include/evolution-data-server/libedataserver/e-source-credentials-provider-impl.h
include/evolution-data-server/libedataserver/e-source-credentials-provider.h
@@ -234,6 +237,8 @@ include/evolution-data-server/libedataserver/e-source-enums.h
include/evolution-data-server/libedataserver/e-source-enumtypes.h
include/evolution-data-server/libedataserver/e-source-extension.h
include/evolution-data-server/libedataserver/e-source-goa.h
+include/evolution-data-server/libedataserver/e-source-ldap.h
+include/evolution-data-server/libedataserver/e-source-local.h
include/evolution-data-server/libedataserver/e-source-mail-account.h
include/evolution-data-server/libedataserver/e-source-mail-composition.h
include/evolution-data-server/libedataserver/e-source-mail-identity.h
@@ -252,19 +257,23 @@ include/evolution-data-server/libedataserver/e-source-security.h
include/evolution-data-server/libedataserver/e-source-selectable.h
include/evolution-data-server/libedataserver/e-source-smime.h
include/evolution-data-server/libedataserver/e-source-uoa.h
+include/evolution-data-server/libedataserver/e-source-weather.h
include/evolution-data-server/libedataserver/e-source-webdav.h
include/evolution-data-server/libedataserver/e-source.h
include/evolution-data-server/libedataserver/e-time-utils.h
include/evolution-data-server/libedataserver/e-uid.h
include/evolution-data-server/libedataserver/e-url.h
+include/evolution-data-server/libedataserver/e-webdav-discover.h
include/evolution-data-server/libedataserver/e-xml-hash-utils.h
include/evolution-data-server/libedataserver/e-xml-utils.h
include/evolution-data-server/libedataserver/eds-version.h
include/evolution-data-server/libedataserver/libedataserver.h
+include/evolution-data-server/libedataserverui/e-cell-renderer-color.h
include/evolution-data-server/libedataserverui/e-credentials-prompter-impl-password.h
include/evolution-data-server/libedataserverui/e-credentials-prompter-impl.h
include/evolution-data-server/libedataserverui/e-credentials-prompter.h
include/evolution-data-server/libedataserverui/e-trust-prompt.h
+include/evolution-data-server/libedataserverui/e-webdav-discover-widget.h
include/evolution-data-server/libedataserverui/libedataserverui.h
lib/evolution-data-server/addressbook-backends/libebookbackendfile.a
lib/evolution-data-server/addressbook-backends/libebookbackendfile.so
@@ -326,8 +335,8 @@ lib/evolution-data-server/registry-modules/module-yahoo-backend.a
lib/evolution-data-server/registry-modules/module-yahoo-backend.so
lib/libcamel-%%EVO_VERSION%%.a
lib/libcamel-%%EVO_VERSION%%.so
-lib/libcamel-%%EVO_VERSION%%.so.52
-lib/libcamel-%%EVO_VERSION%%.so.52.0.0
+lib/libcamel-%%EVO_VERSION%%.so.54
+lib/libcamel-%%EVO_VERSION%%.so.54.0.0
lib/libebackend-%%EVO_VERSION%%.a
lib/libebackend-%%EVO_VERSION%%.so
lib/libebackend-%%EVO_VERSION%%.so.10
@@ -338,24 +347,24 @@ lib/libebook-%%EVO_VERSION%%.so.16
lib/libebook-%%EVO_VERSION%%.so.16.3.1
lib/libebook-contacts-%%EVO_VERSION%%.a
lib/libebook-contacts-%%EVO_VERSION%%.so
-lib/libebook-contacts-%%EVO_VERSION%%.so.1
-lib/libebook-contacts-%%EVO_VERSION%%.so.1.0.0
+lib/libebook-contacts-%%EVO_VERSION%%.so.2
+lib/libebook-contacts-%%EVO_VERSION%%.so.2.0.0
lib/libecal-%%EVO_VERSION%%.a
lib/libecal-%%EVO_VERSION%%.so
-lib/libecal-%%EVO_VERSION%%.so.18
-lib/libecal-%%EVO_VERSION%%.so.18.0.0
+lib/libecal-%%EVO_VERSION%%.so.19
+lib/libecal-%%EVO_VERSION%%.so.19.0.0
lib/libedata-book-%%EVO_VERSION%%.a
lib/libedata-book-%%EVO_VERSION%%.so
lib/libedata-book-%%EVO_VERSION%%.so.25
lib/libedata-book-%%EVO_VERSION%%.so.25.0.0
lib/libedata-cal-%%EVO_VERSION%%.a
lib/libedata-cal-%%EVO_VERSION%%.so
-lib/libedata-cal-%%EVO_VERSION%%.so.27
-lib/libedata-cal-%%EVO_VERSION%%.so.27.0.0
+lib/libedata-cal-%%EVO_VERSION%%.so.28
+lib/libedata-cal-%%EVO_VERSION%%.so.28.0.0
lib/libedataserver-%%EVO_VERSION%%.a
lib/libedataserver-%%EVO_VERSION%%.so
-lib/libedataserver-%%EVO_VERSION%%.so.20
-lib/libedataserver-%%EVO_VERSION%%.so.20.0.0
+lib/libedataserver-%%EVO_VERSION%%.so.21
+lib/libedataserver-%%EVO_VERSION%%.so.21.0.0
lib/libedataserverui-%%EVO_VERSION%%.a
lib/libedataserverui-%%EVO_VERSION%%.so
lib/libedataserverui-%%EVO_VERSION%%.so.1