aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authoradridg <adridg@FreeBSD.org>2018-01-05 19:06:15 +0800
committeradridg <adridg@FreeBSD.org>2018-01-05 19:06:15 +0800
commit20934207b4078cbd98a0eda5fa94c41440b22e11 (patch)
tree8bf1b0e23e20b984c16a8ece009688443f394233 /databases
parentfd34ff9477ec52698d9dc6b5a3c07d2aa9abb57f (diff)
downloadfreebsd-ports-gnome-20934207b4078cbd98a0eda5fa94c41440b22e11.tar.gz
freebsd-ports-gnome-20934207b4078cbd98a0eda5fa94c41440b22e11.tar.zst
freebsd-ports-gnome-20934207b4078cbd98a0eda5fa94c41440b22e11.zip
Fix build of databases/soci w/ clang 4.0 and later and on arm6, arm7.
Adds upstream patch to fix backends/mysql/session.cpp:202:22: error: ordered comparison between pointer and zero ('int *' and 'int') if (port < 0) PR: 222651 216074 Reported by: jbeich, Neel Chauhan Reviewed by: jlaffaye Approved by: tcberner (mentor) Obtained from: upstream Differential Revision: https://reviews.freebsd.org/D13769
Diffstat (limited to 'databases')
-rw-r--r--databases/soci/Makefile5
-rw-r--r--databases/soci/files/patch-backends_mysql_session.cpp14
2 files changed, 15 insertions, 4 deletions
diff --git a/databases/soci/Makefile b/databases/soci/Makefile
index cc4cd3212607..230513b99780 100644
--- a/databases/soci/Makefile
+++ b/databases/soci/Makefile
@@ -3,7 +3,7 @@
PORTNAME= soci
PORTVERSION= 3.2.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= databases
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -13,9 +13,6 @@ COMMENT= C++ Database Access Library
LICENSE= BSL
LICENSE_FILE= ${WRKSRC}/LICENSE_1_0.txt
-BROKEN_armv6= fails to compile: backends/mysql/session.cpp:202:22: error: ordered comparison between pointer and zero ('int *' and 'int')
-BROKEN_armv7= fails to compile: backends/mysql/session.cpp:202:22: error: ordered comparison between pointer and zero ('int *' and 'int')
-
USES= cmake zip
CMAKE_ARGS+= -DWITH_ORACLE:BOOL=OFF
USE_LDCONFIG= yes
diff --git a/databases/soci/files/patch-backends_mysql_session.cpp b/databases/soci/files/patch-backends_mysql_session.cpp
new file mode 100644
index 000000000000..487df23c217e
--- /dev/null
+++ b/databases/soci/files/patch-backends_mysql_session.cpp
@@ -0,0 +1,14 @@
+Patch obtained from upstream
+https://github.com/SOCI/soci/commit/165737c4be7d6c9acde92610b92e8f42a4cfe933
+
+--- backends/mysql/session.cpp.orig 2018-01-04 20:29:49 UTC
++++ backends/mysql/session.cpp
+@@ -199,7 +199,7 @@ void parse_connect_string(const string &
+ throw soci_error(err);
+ }
+ *port = std::atoi(val.c_str());
+- if (port < 0)
++ if (*port < 0)
+ {
+ throw soci_error(err);
+ }