aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2010-03-04 22:20:19 +0800
committerkuriyama <kuriyama@FreeBSD.org>2010-03-04 22:20:19 +0800
commit22572ce42899506692e0159d1c149ee3951e183a (patch)
tree8c525bc67ca82d4d518be7e22965cfc299ea34a0 /databases
parent5b1b665ed632266da7acd0be5ab81d447e2ad742 (diff)
downloadfreebsd-ports-gnome-22572ce42899506692e0159d1c149ee3951e183a.tar.gz
freebsd-ports-gnome-22572ce42899506692e0159d1c149ee3951e183a.tar.zst
freebsd-ports-gnome-22572ce42899506692e0159d1c149ee3951e183a.zip
pg_rman is an online backup and restore tool for PostgreSQL.
The goal of the pg_rman project is providing a method for online backup and PITR as easy as pg_dump. Also, it maintains a backup catalog per database cluster. Users can maintain old backups including archive logs with one command. WWW: http://code.google.com/p/pg-rman/ Feature safe: yes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pg_rman/Makefile27
-rw-r--r--databases/pg_rman/distinfo3
-rw-r--r--databases/pg_rman/pkg-descr8
4 files changed, 39 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 0c8397587848..507d83b219cf 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -460,6 +460,7 @@
SUBDIR += pecl-mongo
SUBDIR += pecl-sqlite
SUBDIR += pg_filedump
+ SUBDIR += pg_rman
SUBDIR += pgaccess
SUBDIR += pgadmin3
SUBDIR += pgbouncer
diff --git a/databases/pg_rman/Makefile b/databases/pg_rman/Makefile
new file mode 100644
index 000000000000..227c0fb4a407
--- /dev/null
+++ b/databases/pg_rman/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: pg_rman
+# Date created: 4 March 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pg_rman
+PORTVERSION= 1.1.2
+CATEGORIES= databases
+MASTER_SITES= http://pg-rman.googlecode.com/files/
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Online backup and restore tool for PostgreSQL
+
+USE_GMAKE= yes
+USE_PGSQL= YES
+WANT_PGSQL_VER?=83
+WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKE_ARGS= USE_PGXS=1
+PLIST_FILES= bin/pg_rman
+
+.include <bsd.port.pre.mk>
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libpgport.a:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
+
+.include <bsd.port.post.mk>
diff --git a/databases/pg_rman/distinfo b/databases/pg_rman/distinfo
new file mode 100644
index 000000000000..9e616f1a9ac8
--- /dev/null
+++ b/databases/pg_rman/distinfo
@@ -0,0 +1,3 @@
+MD5 (pg_rman-1.1.2.tar.gz) = 5a82c357b849fc7804ef0fcc0bb2f7f1
+SHA256 (pg_rman-1.1.2.tar.gz) = fac8038759f219d141a88766a9d1fa891d31e6f7408013d899400accd7340838
+SIZE (pg_rman-1.1.2.tar.gz) = 67103
diff --git a/databases/pg_rman/pkg-descr b/databases/pg_rman/pkg-descr
new file mode 100644
index 000000000000..f540e7f2367b
--- /dev/null
+++ b/databases/pg_rman/pkg-descr
@@ -0,0 +1,8 @@
+pg_rman is an online backup and restore tool for PostgreSQL.
+
+The goal of the pg_rman project is providing a method for online
+backup and PITR as easy as pg_dump. Also, it maintains a backup
+catalog per database cluster. Users can maintain old backups including
+archive logs with one command.
+
+WWW: http://code.google.com/p/pg-rman/