aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2013-12-03 03:40:20 +0800
committerlwhsu <lwhsu@FreeBSD.org>2013-12-03 03:40:20 +0800
commit23da16e8e2fc36c210c92f4dbd272f79b2bf6e26 (patch)
tree3d56a410b4212c9daa22491d497d360a9dbc10a8 /databases
parent6291a4a5efb49e043c93bf07b893ddd13f80d267 (diff)
downloadfreebsd-ports-gnome-23da16e8e2fc36c210c92f4dbd272f79b2bf6e26.tar.gz
freebsd-ports-gnome-23da16e8e2fc36c210c92f4dbd272f79b2bf6e26.tar.zst
freebsd-ports-gnome-23da16e8e2fc36c210c92f4dbd272f79b2bf6e26.zip
Add py-alembic 0.6.1, database migration tool for SQLAlchemy.
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-alembic/Makefile21
-rw-r--r--databases/py-alembic/distinfo2
-rw-r--r--databases/py-alembic/pkg-descr12
4 files changed, 36 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 0f381ea944d1..b49d7fa7033c 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -726,6 +726,7 @@
SUBDIR += py-MySQLdb55
SUBDIR += py-PyGreSQL
SUBDIR += py-Pyrseas
+ SUBDIR += py-alembic
SUBDIR += py-apsw
SUBDIR += py-bsddb
SUBDIR += py-bsddb3
diff --git a/databases/py-alembic/Makefile b/databases/py-alembic/Makefile
new file mode 100644
index 000000000000..9d8097e772d6
--- /dev/null
+++ b/databases/py-alembic/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= alembic
+PORTVERSION= 0.6.1
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lwhsu@FreeBSD.org
+COMMENT= Database migration tool for SQLAlchemy
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy>=0.7.3:${PORTSDIR}/databases/py-sqlalchemy \
+ ${PYTHON_PKGNAMEPREFIX}mako>=0:${PORTSDIR}/textproc/py-mako
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/databases/py-alembic/distinfo b/databases/py-alembic/distinfo
new file mode 100644
index 000000000000..a842c1766581
--- /dev/null
+++ b/databases/py-alembic/distinfo
@@ -0,0 +1,2 @@
+SHA256 (alembic-0.6.1.tar.gz) = 1a35c98febe00b4efdd05c4e38c34b7239b23b42ce43c39320ae50a2b39705a5
+SIZE (alembic-0.6.1.tar.gz) = 414655
diff --git a/databases/py-alembic/pkg-descr b/databases/py-alembic/pkg-descr
new file mode 100644
index 000000000000..7ec7e717b5f4
--- /dev/null
+++ b/databases/py-alembic/pkg-descr
@@ -0,0 +1,12 @@
+Alembic is a new database migrations tool, written by the author of
+SQLAlchemy. A migrations tool offers the following functionality:
+
+- Can emit ALTER statements to a database in order to change the structure of
+ tables and other constructs
+- Provides a system whereby "migration scripts" may be constructed; each
+ script indicates a particular series of steps that can "upgrade" a target
+ database to a new version, and optionally a series of steps that can
+ "downgrade" similarly, doing the same steps in reverse.
+- Allows the scripts to execute in some sequential manner.
+
+WWW: http://bitbucket.org/zzzeek/alembic