aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorseanc <seanc@FreeBSD.org>2003-01-05 08:03:13 +0800
committerseanc <seanc@FreeBSD.org>2003-01-05 08:03:13 +0800
commit2499b931bea7048ff4a891c9fd8d3fe54bd5b9e1 (patch)
tree63bd717e87953cfaab7029014809a3057362aa19 /databases
parenta6b2ba12bee7671352a867fecacf682a14ebf6bd (diff)
downloadfreebsd-ports-gnome-2499b931bea7048ff4a891c9fd8d3fe54bd5b9e1.tar.gz
freebsd-ports-gnome-2499b931bea7048ff4a891c9fd8d3fe54bd5b9e1.tar.zst
freebsd-ports-gnome-2499b931bea7048ff4a891c9fd8d3fe54bd5b9e1.zip
Add libpq++. libpq++ is no longer hosted under the main PostgreSQL tree and
is now a project on gborg. libpq++ is still a supported interface. PR: ports/45943 Submitted by: Palle Girgensohn <girgen@pingpong.net>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/postgresql-libpq++/Makefile29
-rw-r--r--databases/postgresql-libpq++/distinfo1
-rw-r--r--databases/postgresql-libpq++/pkg-comment1
-rw-r--r--databases/postgresql-libpq++/pkg-descr5
-rw-r--r--databases/postgresql-libpq++/pkg-plist9
6 files changed, 46 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index bbf0c5133b44..6f39317c93fc 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -118,6 +118,7 @@
SUBDIR += postgresql-devel
SUBDIR += postgresql-docs
SUBDIR += postgresql-jdbc
+ SUBDIR += postgresql-libpq++
SUBDIR += postgresql-odbc
SUBDIR += postgresql-plruby
SUBDIR += postgresql-pltcl
diff --git a/databases/postgresql-libpq++/Makefile b/databases/postgresql-libpq++/Makefile
new file mode 100644
index 000000000000..24aa1f23df3f
--- /dev/null
+++ b/databases/postgresql-libpq++/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: PostgreSQL Pgaccess
+# Date created: December 1st, 2002
+# Whom: Palle Girgensohn <girgen@pingpong.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libpq++
+PORTVERSION= 4.0
+CATEGORIES= databases
+MASTER_SITES= ftp://gborg.postgresql.org/pub/libpqpp/stable/
+DIST_SUBDIR= postgresql
+
+MAINTAINER= girgen@pingpong.net
+
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+
+USE_GMAKE= YES
+USE_REINPLACE= YES
+INSTALLS_SHLIB= YES
+
+post-patch:
+ ${REINPLACE_CMD} "s,/usr/local/pgsql,${PREFIX},; \
+ s,^CFLAGS.*,CFLAGS=${CFLAGS},; \
+ s,\...SO_MINOR_VERSION.,,; \
+ s,\(\-[IL]\)[^/]*,\\1${LOCALBASE}," ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/databases/postgresql-libpq++/distinfo b/databases/postgresql-libpq++/distinfo
new file mode 100644
index 000000000000..32f33d64325e
--- /dev/null
+++ b/databases/postgresql-libpq++/distinfo
@@ -0,0 +1 @@
+MD5 (postgresql/libpq++-4.0.tar.gz) = da71cb79ef45cef55f4bc97a33a0857d
diff --git a/databases/postgresql-libpq++/pkg-comment b/databases/postgresql-libpq++/pkg-comment
new file mode 100644
index 000000000000..777a51cf1bd1
--- /dev/null
+++ b/databases/postgresql-libpq++/pkg-comment
@@ -0,0 +1 @@
+C++ interface for PostgreSQL
diff --git a/databases/postgresql-libpq++/pkg-descr b/databases/postgresql-libpq++/pkg-descr
new file mode 100644
index 000000000000..8e2cca40fe33
--- /dev/null
+++ b/databases/postgresql-libpq++/pkg-descr
@@ -0,0 +1,5 @@
+This is the C++ interface that has been shipped as part of PostgreSQL for
+many releases. There is a newer C++ interface called libpqxx, which is
+in a separate port, postgresq-pgcxx.
+
+WWW: http://gborg.postgresql.org/project/libpqpp/
diff --git a/databases/postgresql-libpq++/pkg-plist b/databases/postgresql-libpq++/pkg-plist
new file mode 100644
index 000000000000..bbd73d84b359
--- /dev/null
+++ b/databases/postgresql-libpq++/pkg-plist
@@ -0,0 +1,9 @@
+include/libpq++.h
+include/libpq++/pgconnection.h
+include/libpq++/pgdatabase.h
+include/libpq++/pgtransdb.h
+include/libpq++/pgcursordb.h
+include/libpq++/pglobject.h
+lib/libpq++.so.4
+lib/libpq++.so
+@dirrm include/libpq++