aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-19 18:40:22 +0800
committerKoop Mast <kwm@FreeBSD.org>2013-03-19 18:40:22 +0800
commit2a3357182d8cb640f374f8c60b71b6c99ec43843 (patch)
tree7a5f4c1c91d14d9fcab2b30589db732cde4a3725 /databases
parent92fdeef4740a0893f904a81b5150a5e3f5604b10 (diff)
downloadfreebsd-ports-gnome-2a3357182d8cb640f374f8c60b71b6c99ec43843.tar.gz
freebsd-ports-gnome-2a3357182d8cb640f374f8c60b71b6c99ec43843.tar.zst
freebsd-ports-gnome-2a3357182d8cb640f374f8c60b71b6c99ec43843.zip
Convert almost all gnome@ ports to OptionsNG, trim header, use USES=pathfix
instead of gnomehack and pet portlint. Add conflicts with future gnome3 versions. Reviewed by: miwi, bapt
Diffstat (limited to 'databases')
-rw-r--r--databases/evolution-data-server/Makefile27
1 files changed, 10 insertions, 17 deletions
diff --git a/databases/evolution-data-server/Makefile b/databases/evolution-data-server/Makefile
index 43dde05a793c..a9df23fba152 100644
--- a/databases/evolution-data-server/Makefile
+++ b/databases/evolution-data-server/Makefile
@@ -1,6 +1,6 @@
# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/databases/evolution-data-server/Makefile,v 1.203 2010/11/15 17:19:55 kwm Exp $
+# $MCom: ports/databases/evolution-data-server/Makefile,v 1.218 2013/03/09 09:12:37 kwm Exp $
PORTNAME= evolution-data-server
PORTVERSION= 2.32.1
@@ -18,7 +18,6 @@ LIB_DEPENDS= soup-2.4:${PORTSDIR}/devel/libsoup \
ical:${PORTSDIR}/devel/libical \
nss3:${PORTSDIR}/security/nss \
tasn1:${PORTSDIR}/security/libtasn1 \
- sqlite3:${PORTSDIR}/databases/sqlite3 \
gnome-keyring:${PORTSDIR}/security/libgnome-keyring
USE_BZIP2= yes
@@ -28,6 +27,7 @@ USE_GETTEXT= yes
USE_GNOME= gnomeprefix intlhack ltverhack ltasneededhack gconf2 \
libxml2
USE_OPENLDAP= yes
+USE_SQLITE= 3
USE_AUTOTOOLS= libtool
USE_BDB= 41+
USE_LDCONFIG= yes
@@ -40,26 +40,19 @@ LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
PLIST_SUB= VERSION="2.32" EVO_VERSION="1.2"
-#OPTIONS= IMAP4 "Enable experimental IMAP4 backend" off
-OPTIONS= WEATHER "Enable weather calendar backend" on \
- KERBEROS "Adds Kerberos support" on
+OPTIONS_DEFINE= WEATHER KERBEROS
+OPTIONS_DEFAULT=WEATHER KERBEROS
+WEATHER_DESC= Weather calendar backend
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_KERBEROS)
+.if ${PORT_OPTIONS:MKERBEROS}
CONFIGURE_ARGS+= --with-krb5=/usr
KRB5_LIB= `/usr/bin/krb5-config gssapi --libs`
.endif
-#.if defined(WITH_IMAP4) || defined(PACKAGE_BUILDING)
-#CONFIGURE_ARGS+= --enable-imap4=yes
-#PLIST_SUB+= IMAP4=""
-#.else
-PLIST_SUB+= IMAP4="@comment "
-#.endif
-
-.if defined(WITH_WEATHER)
-LIB_DEPENDS+= gweather.1:${PORTSDIR}/net/libgweather
+.if ${PORT_OPTIONS:MWEATHER}
+LIB_DEPENDS+= gweather:${PORTSDIR}/net/libgweather
CONFIGURE_ARGS+= --with-weather
PLIST_SUB+= WEATHER=""
.else
@@ -83,4 +76,4 @@ post-patch:
s|-Wmissing-include-dirs||g' \
${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>