aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2004-06-01 15:15:09 +0800
committerale <ale@FreeBSD.org>2004-06-01 15:15:09 +0800
commit2ef090102bc62d608aff2f2d0281016facf8f27e (patch)
treed9d001eb5d544fce652c8bfd1a7d55f05508b305 /databases
parent76f8415623ac05124fca6f0936a0b02b1a754789 (diff)
downloadfreebsd-ports-gnome-2ef090102bc62d608aff2f2d0281016facf8f27e.tar.gz
freebsd-ports-gnome-2ef090102bc62d608aff2f2d0281016facf8f27e.tar.zst
freebsd-ports-gnome-2ef090102bc62d608aff2f2d0281016facf8f27e.zip
- Update to 4.1.2 release
- Add experimental WITH_PROC_SCOPE_PTH knob to use process scope threads instead of system scope threads with libpthread
Diffstat (limited to 'databases')
-rw-r--r--databases/mysql41-client/Makefile1
-rw-r--r--databases/mysql41-scripts/Makefile1
-rw-r--r--databases/mysql41-server/Makefile20
-rw-r--r--databases/mysql41-server/distinfo4
-rw-r--r--databases/mysql41-server/files/patch-Makefile.in8
-rw-r--r--databases/mysql41-server/files/patch-client::mysql.cc11
-rw-r--r--databases/mysql41-server/files/patch-configure74
-rw-r--r--databases/mysql41-server/files/patch-scripts::Makefile.in11
-rw-r--r--databases/mysql41-server/files/patch-scripts::mysql_install_db.sh22
-rw-r--r--databases/mysql41-server/files/patch-scripts::mysqlbug.sh14
-rw-r--r--databases/mysql41-server/pkg-plist2
11 files changed, 51 insertions, 117 deletions
diff --git a/databases/mysql41-client/Makefile b/databases/mysql41-client/Makefile
index e34a3b8160da..7362acc9af88 100644
--- a/databases/mysql41-client/Makefile
+++ b/databases/mysql41-client/Makefile
@@ -6,7 +6,6 @@
#
PORTNAME= mysql
-PORTREVISION= 2
PKGNAMESUFFIX= -client
COMMENT= Multithreaded SQL database (client)
diff --git a/databases/mysql41-scripts/Makefile b/databases/mysql41-scripts/Makefile
index ce92746030e7..c17cb4d517e2 100644
--- a/databases/mysql41-scripts/Makefile
+++ b/databases/mysql41-scripts/Makefile
@@ -6,7 +6,6 @@
#
PORTNAME= mysql
-PORTREVISION= 1
PKGNAMESUFFIX= -scripts
COMMENT= Multithreaded SQL database (scripts)
diff --git a/databases/mysql41-server/Makefile b/databases/mysql41-server/Makefile
index a6fef3195356..902c051d3d8d 100644
--- a/databases/mysql41-server/Makefile
+++ b/databases/mysql41-server/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME?= mysql
-PORTVERSION= 4.1.1
-PORTREVISION?= 2
+PORTVERSION= 4.1.2
+PORTREVISION?= 0
CATEGORIES= databases
MASTER_SITES= ftp://planetmirror.com/pub/mysql/Downloads/MySQL-4.1/ \
http://www.softagency.co.jp/MySQL/Downloads/MySQL-4.1/ \
@@ -32,6 +32,7 @@ DB_DIR?= /var/db/mysql
USE_GNOME= lthack
USE_LIBTOOL_VER= 13
USE_REINPLACE= yes
+USE_GMAKE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=${DB_DIR} \
@@ -67,7 +68,7 @@ CONFIGURE_ARGS+=--with-mysqld-ldflags=-all-static
.include <bsd.port.pre.mk>
-.if ${MACHINE_ARCH} == "i386"
+.if ${ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler --with-berkeley-db
.endif
.if defined(WITH_LINUXTHREADS)
@@ -110,7 +111,8 @@ LATEST_LINK= mysql41-server
CONFLICTS= mysql-server-3.* mysql-server-4.[02-9].* mysql-server-5.*
-PLIST_SUB= DB_DIR=${DB_DIR}
+PLIST_SUB= DB_DIR=${DB_DIR} \
+ VER=${PORTVERSION}-alpha
MAN1= isamchk.1 isamlog.1 mysqld.1 \
mysqld_safe.1 perror.1 replace.1
@@ -129,6 +131,8 @@ pre-fetch:
@${ECHO} " DB_DIR=directory Set alternate directory for database files"
@${ECHO} " (default is /var/db/mysql)."
@${ECHO} " WITH_LINUXTHREADS=yes Use the linuxthreads pthread library."
+ @${ECHO} " WITH_PROC_SCOPE_PTH=yes Use process scope threads"
+ @${ECHO} " (try it if you use libpthread)."
@${ECHO} " OVERWRITE_DB=yes Re-initialize default databases."
@${ECHO} " BUILD_OPTIMIZED=yes Enable compiler optimizations"
@${ECHO} " (use it if you need speed)."
@@ -141,7 +145,10 @@ post-patch:
@${REINPLACE_CMD} -e "s|bin_SCRIPTS =|bin_SCRIPTS = @server_scripts@ mysql_create_system_tables|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|dist_pkgdata_DATA =|dist_pkgdata_DATA = fill_help_tables.sql|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|man_MANS =|man_MANS = ${MAN1}|g" ${WRKSRC}/man/Makefile.in
- @${REINPLACE_CMD} -e "s|install: install-am|install:|g" ${WRKSRC}/include/Makefile.in
+ @${REINPLACE_CMD} -e "s|install-data-am: install-pkgincludeHEADERS|install-data-am:|g" ${WRKSRC}/include/Makefile.in
+.if defined(WITH_PROC_SCOPE_PTH)
+ @${REINPLACE_CMD} -e "s|PTHREAD_SCOPE_SYSTEM|PTHREAD_SCOPE_PROCESS|g" ${WRKSRC}/sql/mysqld.cc
+.endif
post-build:
@${SED} "s|%%DB_DIR%%|${DB_DIR}|g" ${PKGDIR}/pkg-install > ${WRKDIR}/pkg-install
@@ -191,6 +198,9 @@ post-patch:
@${REINPLACE_CMD} -e "s|bin_SCRIPTS =|bin_SCRIPTS = mysql_config mysql_fix_privilege_tables mysqlbug|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|dist_pkgdata_DATA =|dist_pkgdata_DATA = mysql_fix_privilege_tables.sql|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|man_MANS =|man_MANS = ${MAN1}|g" ${WRKSRC}/man/Makefile.in
+.if defined(WITH_PROC_SCOPE_PTH)
+ @${REINPLACE_CMD} -e "s|PTHREAD_SCOPE_SYSTEM|PTHREAD_SCOPE_PROCESS|g" ${WRKSRC}/tools/mysqlmanager.c
+.endif
post-install:
@${SED} "s|%%PREFIX%%|${PREFIX}|g" < ${FILESDIR}/mysql-client.sh > ${PREFIX}/etc/rc.d/000.mysql-client.sh
diff --git a/databases/mysql41-server/distinfo b/databases/mysql41-server/distinfo
index 5a4c431d74cd..49dac52bbeca 100644
--- a/databases/mysql41-server/distinfo
+++ b/databases/mysql41-server/distinfo
@@ -1,2 +1,2 @@
-MD5 (mysql-4.1.1-alpha.tar.gz) = dc337413c0a9ce4d5dcb91b02383371b
-SIZE (mysql-4.1.1-alpha.tar.gz) = 15603049
+MD5 (mysql-4.1.2-alpha.tar.gz) = 9877e8d208bedd7065c4f0d86258f64a
+SIZE (mysql-4.1.2-alpha.tar.gz) = 16924395
diff --git a/databases/mysql41-server/files/patch-Makefile.in b/databases/mysql41-server/files/patch-Makefile.in
index 94f38623fcf4..1ec46e3b31bb 100644
--- a/databases/mysql41-server/files/patch-Makefile.in
+++ b/databases/mysql41-server/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig Mon Dec 1 13:55:28 2003
-+++ Makefile.in Wed Dec 10 00:18:16 2003
-@@ -209,12 +209,7 @@
+--- Makefile.in.orig Fri May 28 21:38:32 2004
++++ Makefile.in Mon May 31 15:10:44 2004
+@@ -282,12 +282,7 @@
# These are built from source in the Docs directory
EXTRA_DIST = INSTALL-SOURCE README COPYING zlib
@@ -8,7 +8,7 @@
- @readline_topdir@ sql-common \
- @thread_dirs@ pstack @sql_client_dirs@ \
- @sql_server_dirs@ scripts man tests SSL\
-- BUILD @netware_dir@ os2 @libmysqld_dirs@ \
+- BUILD netware os2 @libmysqld_dirs@ \
- @bench_dirs@ support-files @fs_dirs@ @tools_dirs@
+SUBDIRS =
diff --git a/databases/mysql41-server/files/patch-client::mysql.cc b/databases/mysql41-server/files/patch-client::mysql.cc
new file mode 100644
index 000000000000..2e9b7440ca83
--- /dev/null
+++ b/databases/mysql41-server/files/patch-client::mysql.cc
@@ -0,0 +1,11 @@
+--- client/mysql.cc.orig Mon May 31 18:16:27 2004
++++ client/mysql.cc Mon May 31 18:24:35 2004
+@@ -294,7 +294,7 @@
+ HIST_ENTRY is defined for libedit, but not for the real readline
+ Need to redefine it for real readline to find it
+ */
+-#if !defined(USE_LIBEDIT_INTERFACE)
++#if defined(USE_LIBEDIT_INTERFACE)
+ typedef struct _hist_entry {
+ const char *line;
+ const char *data;
diff --git a/databases/mysql41-server/files/patch-configure b/databases/mysql41-server/files/patch-configure
index c7b052905fa8..10080e85bfee 100644
--- a/databases/mysql41-server/files/patch-configure
+++ b/databases/mysql41-server/files/patch-configure
@@ -1,59 +1,16 @@
---- configure.orig Mon Dec 1 13:55:34 2003
-+++ configure Wed Dec 10 00:22:08 2003
-@@ -9069,7 +9070,7 @@
- ;;
- esac
- fi
--HOSTNAME=$ac_cv_path_HOSTNAME
-+HOSTNAME="$ac_cv_path_HOSTNAME -s"
+--- configure.orig Tue Jun 1 09:08:41 2004
++++ configure Tue Jun 1 09:08:41 2004
+@@ -18835,9 +18835,6 @@
- if test -n "$HOSTNAME"; then
- echo "$as_me:$LINENO: result: $HOSTNAME" >&5
-@@ -9261,43 +9262,8 @@
- echo "$as_me:$LINENO: checking \"how to check if pid exists\"" >&5
- echo $ECHO_N "checking \"how to check if pid exists\"... $ECHO_C" >&6
- PS=$ac_cv_path_PS
--# Linux style
--if $PS p $$ 2> /dev/null | grep $0 > /dev/null
--then
-- FIND_PROC="$PS p \$\$PID | grep mysqld > /dev/null"
--# Solaris
--elif $PS -p $$ 2> /dev/null | grep $0 > /dev/null
--then
-- FIND_PROC="$PS -p \$\$PID | grep mysqld > /dev/null"
- # BSD style
--elif $PS -uaxww 2> /dev/null | grep $0 > /dev/null
--then
- FIND_PROC="$PS -uaxww | grep mysqld | grep \" \$\$PID \" > /dev/null"
--# SysV style
--elif $PS -ef 2> /dev/null | grep $0 > /dev/null
--then
-- FIND_PROC="$PS -ef | grep mysqld | grep \" \$\$PID \" > /dev/null"
--# Do anybody use this?
--elif $PS $$ 2> /dev/null | grep $0 > /dev/null
--then
-- FIND_PROC="$PS \$\$PID | grep mysqld > /dev/null"
--else
-- case $SYSTEM_TYPE in
-- *darwin*)
-- FIND_PROC="$PS -uaxww | grep mysqld | grep \" \$\$PID \" > /dev/null"
-- ;;
-- *cygwin*)
-- FIND_PROC="$PS -e | grep mysqld | grep \" \$\$PID \" > /dev/null"
-- ;;
-- *netware* | *modesto*)
-- FIND_PROC=
-- ;;
-- *)
-- { { echo "$as_me:$LINENO: error: Could not find the right ps switches. Which OS is this ?. See the Installation chapter in the Reference Manual." >&5
--echo "$as_me: error: Could not find the right ps switches. Which OS is this ?. See the Installation chapter in the Reference Manual." >&2;}
-- { (exit 1); exit 1; }; }
-- esac
--fi
- echo "$as_me:$LINENO: result: \"$FIND_PROC\"" >&5
- echo "${ECHO_T}\"$FIND_PROC\"" >&6
-@@ -12678,8 +12644,8 @@
+
+-# Ensure that we have --preserve-dup-deps defines, otherwise we get link
+-# problems of 'mysql' with CXX=g++
+-LIBTOOL="$LIBTOOL --preserve-dup-deps"
+
+ #AC_LIBTOOL_DLOPEN AC_LIBTOOL_WIN32_DLL AC_DISABLE_FAST_INSTALL AC_DISABLE_SHARED AC_DISABLE_STATIC
+
+@@ -23625,8 +23622,8 @@
# Some system specific hacks
#
@@ -64,12 +21,3 @@
case $SYSTEM_TYPE in
*solaris2.7*)
-@@ -23893,7 +23859,7 @@
- /* ) rel_srcdir="$srcdir" ;;
- * ) rel_srcdir="../$srcdir" ;;
- esac
-- if test "x$enable_dependency_tracking" == xno
-+ if test "x$enable_dependency_tracking" = xno
- then
- innodb_conf_flags=--disable-dependency-tracking
- fi
diff --git a/databases/mysql41-server/files/patch-scripts::Makefile.in b/databases/mysql41-server/files/patch-scripts::Makefile.in
index a7e83fd3d258..961fbb5898e2 100644
--- a/databases/mysql41-server/files/patch-scripts::Makefile.in
+++ b/databases/mysql41-server/files/patch-scripts::Makefile.in
@@ -1,6 +1,6 @@
---- scripts/Makefile.in.orig Tue Mar 2 12:24:51 2004
-+++ scripts/Makefile.in Tue Mar 2 12:25:28 2004
-@@ -203,25 +203,7 @@
+--- scripts/Makefile.in.orig Fri May 28 21:38:37 2004
++++ scripts/Makefile.in Mon May 31 15:14:31 2004
+@@ -276,26 +276,7 @@
vio_dir = @vio_dir@
vio_libs = @vio_libs@
@@ -22,12 +22,13 @@
- mysql_tableinfo \
- mysqld_multi \
- make_win_src_distribution \
+- make_win_binary_distribution \
- mysql_create_system_tables
+bin_SCRIPTS =
EXTRA_SCRIPTS = make_binary_distribution.sh \
-@@ -254,7 +236,7 @@
+@@ -329,7 +310,7 @@
mysqlbug
@@ -36,7 +37,7 @@
# mysqlbug should be distributed built so that people can report build
# failures with it.
-@@ -510,8 +492,6 @@
+@@ -605,8 +586,6 @@
all: fill_help_tables.sql make_win_src_distribution make_binary_distribution make_sharedlib_distribution
diff --git a/databases/mysql41-server/files/patch-scripts::mysql_install_db.sh b/databases/mysql41-server/files/patch-scripts::mysql_install_db.sh
deleted file mode 100644
index 1ccb78b2925a..000000000000
--- a/databases/mysql41-server/files/patch-scripts::mysql_install_db.sh
+++ /dev/null
@@ -1,22 +0,0 @@
---- scripts/mysql_install_db.sh.orig Thu Mar 11 10:20:57 2004
-+++ scripts/mysql_install_db.sh Thu Mar 11 10:27:09 2004
-@@ -118,7 +118,7 @@
- if [ $? -ne 0 ]
- then
- resolved=`$bindir/resolveip localhost 2>&1`
-- if [ $? -eq 0 ]
-+ if [ $? -ne 0 ]
- then
- echo "Neither host '$hostname' and 'localhost' could not be looked up with"
- echo "$bindir/resolveip"
-@@ -128,8 +128,8 @@
- exit 1
- fi
- echo "WARNING: The host '$hostname' could not be looked up with resolveip."
-- echo "This probably means that your libc libraries are not 100 % compatible"
-- echo "with this binary MySQL version. The MySQL daemon, mysqld, should work"
-+ echo "This probably means that your host name is not listed in your"
-+ echo "/etc/hosts file (as it should). The MySQL daemon, mysqld, should work"
- echo "normally with the exception that host name resolving will not work."
- echo "This means that you should use IP addresses instead of hostnames"
- echo "when specifying MySQL privileges !"
diff --git a/databases/mysql41-server/files/patch-scripts::mysqlbug.sh b/databases/mysql41-server/files/patch-scripts::mysqlbug.sh
deleted file mode 100644
index fa26d2206310..000000000000
--- a/databases/mysql41-server/files/patch-scripts::mysqlbug.sh
+++ /dev/null
@@ -1,14 +0,0 @@
---- scripts/mysqlbug.sh.orig Tue May 18 10:20:19 2004
-+++ scripts/mysqlbug.sh Fri May 14 02:53:22 2004
-@@ -254,9 +254,9 @@
- if cmp -s $TEMP $TEMP.x
- then
- echo "File not changed, no bug report submitted."
-- cp $TEMP /tmp/failed-mysql-bugreport
-+ mv -f $TEMP /tmp/failed-mysql-bugreport
- echo "The raw bug report exists in /tmp/failed-mysql-bugreport"
-- echo "If you use this remember that the first lines of the report now is a lie.."
-+ echo "If you use this remember that the first lines of the report are now a lie.."
- exit 1
- fi
-
diff --git a/databases/mysql41-server/pkg-plist b/databases/mysql41-server/pkg-plist
index b50c526d693f..fe2ec3230b7f 100644
--- a/databases/mysql41-server/pkg-plist
+++ b/databases/mysql41-server/pkg-plist
@@ -2,6 +2,7 @@ bin/comp_err
bin/isamchk
bin/isamlog
bin/my_print_defaults
+bin/myisam_ftdump
bin/myisamchk
bin/myisamlog
bin/myisampack
@@ -140,6 +141,7 @@ share/mysql/my-huge.cnf
share/mysql/my-large.cnf
share/mysql/my-medium.cnf
share/mysql/my-small.cnf
+share/mysql/mysql-%%VER%%.spec
share/mysql/mysql-log-rotate
share/mysql/mysql.server
share/mysql/norwegian-ny/errmsg.sys