aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-02-13 21:50:45 +0800
committermiwi <miwi@FreeBSD.org>2014-02-13 21:50:45 +0800
commit32426c1f8e5bc8b35dee47ae1caa1ead9490aec6 (patch)
tree9442febbff362b3aa8c72306a7d5cf10b456f8a7 /databases
parent9b54845e62e4dab8a7323c6b6f65de4d52522422 (diff)
downloadfreebsd-ports-gnome-32426c1f8e5bc8b35dee47ae1caa1ead9490aec6.tar.gz
freebsd-ports-gnome-32426c1f8e5bc8b35dee47ae1caa1ead9490aec6.tar.zst
freebsd-ports-gnome-32426c1f8e5bc8b35dee47ae1caa1ead9490aec6.zip
- Convert USE_SCONS to USES
Diffstat (limited to 'databases')
-rw-r--r--databases/mongodb/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/databases/mongodb/Makefile b/databases/mongodb/Makefile
index a6552ffe0456..ad111f35af88 100644
--- a/databases/mongodb/Makefile
+++ b/databases/mongodb/Makefile
@@ -30,8 +30,8 @@ OPTIONS_DEFAULT=SSL
SM_DESC= Use SpiderMonkey instead of V8 for JavaScript
TEST_DESC= Add support for running regression test
-USE_SCONS= yes
-SCONS_ARGS= --prefix=${STAGEDIR}${PREFIX} --cc=${CC} --cxx=${CXX} \
+USES= scons
+MAKE_ARGS= --prefix=${STAGEDIR}${PREFIX} --cc=${CC} --cxx=${CXX} \
--use-system-pcre --use-system-snappy \
--full --sharedclient
@@ -45,32 +45,32 @@ PORTSCOUT= limitw:1,even
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSM}
-SCONS_ARGS+= --usesm --use-system-sm
+MAKE_ARGS+= --usesm --use-system-sm
LIB_DEPENDS+= libjs.so:${PORTSDIR}/lang/spidermonkey17
.else
-SCONS_ARGS+= --usev8 --use-system-v8
+MAKE_ARGS+= --usev8 --use-system-v8
LIB_DEPENDS+= libv8.so:${PORTSDIR}/lang/v8
.endif
.if ${PORT_OPTIONS:MSSL}
USE_OPENSSL= yes
-SCONS_ARGS+= --ssl
+MAKE_ARGS+= --ssl
.endif
.if ${PORT_OPTIONS:MSASL}
-SCONS_ARGS+= --use-sasl-client
+MAKE_ARGS+= --use-sasl-client
LIB_DEPENDS+= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
.endif
.if ${PORT_OPTIONS:MTEST}
BUILD_DEPENDS= pymongo>=2.5:${PORTSDIR}/databases/pymongo
-SCONS_TARGET= all
+MAKE_TARGET= all
SMOKE_TESTS= smokeAll smokeCppUnittests
. if ${PORT_OPTIONS:MSSL}
SMOKE_TESTS+= smokeSsl
. endif
.else
-SCONS_TARGET= core tools
+MAKE_TARGET= core tools
.endif
.if ${OSVERSION} >= 1000024
@@ -87,7 +87,7 @@ post-patch:
.if ${PORT_OPTIONS:MTEST}
test: build-depends build
@cd ${BUILD_WRKSRC} && \
- ${SCONS_BIN} ${SCONS_ENV} ${SCONS_ARGS} ${SMOKE_TESTS}
+ ${SCONS_BIN} ${SCONS_ENV} ${MAKE_ARGS} ${SMOKE_TESTS}
.endif
.include <bsd.port.mk>