aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2016-12-26 01:17:36 +0800
committerrakuco <rakuco@FreeBSD.org>2016-12-26 01:17:36 +0800
commit32b108b3dd928c12117d8e961b51f5a73e5d48f9 (patch)
tree21a37829ec03784228800698f9cfbb064d58ee20 /databases
parent5bd6b2926674bc26e07045a80fc5af7e0b9e4a1b (diff)
downloadfreebsd-ports-gnome-32b108b3dd928c12117d8e961b51f5a73e5d48f9.tar.gz
freebsd-ports-gnome-32b108b3dd928c12117d8e961b51f5a73e5d48f9.tar.zst
freebsd-ports-gnome-32b108b3dd928c12117d8e961b51f5a73e5d48f9.zip
Improve the way CFLAGS and CPPFLAGS are set.
":?" is not supported by fmake from FreeBSD 9, so replace it with an explicit version check. The end result was still the desired one (-DHAVE_STRCHRNUL=1 was not passed on FreeBSD 9). While here, also improve the version check by including DragonFly (which supports strchrnul(3) according to its online man page) and restricting the FreeBSD version check to the revision range after strchrnul(3) was added to base. Also stop passing -Os when building in debug mode, and set UNICODE61_CPPFLAGS to pet portlint. PR: 214608 Submitted by: Pavel Volkov <pavelivolkov@gmail.com> (maintainer) MFH: 2016Q4
Diffstat (limited to 'databases')
-rw-r--r--databases/sqlite3/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/databases/sqlite3/Makefile b/databases/sqlite3/Makefile
index bf9268108eb3..7c73f98571f5 100644
--- a/databases/sqlite3/Makefile
+++ b/databases/sqlite3/Makefile
@@ -18,11 +18,6 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-# Platform Configuration
-CFLAGS+= -Os
-CPPFLAGS+= -DHAVE_ISNAN=1 -DHAVE_MALLOC_USABLE_SIZE=1 -DHAVE_GMTIME_R=1 -DHAVE_LOCALTIME_R=1 -DHAVE_USLEEP=1
-CPPFLAGS+= ${OSVERSION<1000000:?:-DHAVE_STRCHRNUL=1}
-
MAKE_JOBS_UNSAFE= yes
# Compilation Options For SQLite https://www.sqlite.org/compile.html
@@ -174,6 +169,7 @@ ICU_LIB_DEPENDS= libicudata.so:devel/icu
ICU_CPPFLAGS= `${LOCALBASE}/bin/icu-config --cppflags` -DSQLITE_ENABLE_ICU=1
ICU_LIBS= `${LOCALBASE}/bin/icu-config --ldflags`
+UNICODE61_CPPFLAGS= ""
UNICODE61_CPPFLAGS_OFF= -DSQLITE_DISABLE_FTS3_UNICODE=1
READLINES_CONFIGURE_ON= --enable-readline
@@ -197,6 +193,15 @@ UNKNOWN_SQL_CPPFLAGS= -DSQLITE_ENABLE_UNKNOWN_SQL_FUNCTION=1
.include <bsd.port.options.mk>
+# Platform Configuration
+.if !defined(WITH_DEBUG)
+CFLAGS+= -Os
+.endif
+CPPFLAGS+= -DHAVE_ISNAN=1 -DHAVE_MALLOC_USABLE_SIZE=1 -DHAVE_GMTIME_R=1 -DHAVE_LOCALTIME_R=1 -DHAVE_USLEEP=1
+.if ${OPSYS} == DragonFly || (${OPSYS} == FreeBSD && ${OSVERSION} >= 1000029)
+CPPFLAGS+= -DHAVE_STRCHRNUL=1
+.endif
+
post-configure:
@${ECHO_MSG} "===> CONFIGURE_ARGS=${CONFIGURE_ARGS}"
@${ECHO_MSG} "===> CPPFLAGS=${CPPFLAGS}"