aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2014-07-14 00:40:24 +0800
committermi <mi@FreeBSD.org>2014-07-14 00:40:24 +0800
commit36dd1dda123cf5f3398162b3af07dbf5f609dbf2 (patch)
tree72ec3ce2a9df9e608b25e45b8030f95841ad085f /databases
parent3835729790b66a4a15ff6efee9b78be7f9f3b0d5 (diff)
downloadfreebsd-ports-gnome-36dd1dda123cf5f3398162b3af07dbf5f609dbf2.tar.gz
freebsd-ports-gnome-36dd1dda123cf5f3398162b3af07dbf5f609dbf2.tar.zst
freebsd-ports-gnome-36dd1dda123cf5f3398162b3af07dbf5f609dbf2.zip
Though I can not reproduce the error cited by the previous committer
in the commit log with neither g++, clang++, nor clang++33, I'll try to fix it anyway. Unbreak.
Diffstat (limited to 'databases')
-rw-r--r--databases/tcl-Mysql/Makefile1
-rw-r--r--databases/tcl-Mysql/files/patch-const-error9
2 files changed, 8 insertions, 2 deletions
diff --git a/databases/tcl-Mysql/Makefile b/databases/tcl-Mysql/Makefile
index dd258f036ff0..da89fb0ff1a9 100644
--- a/databases/tcl-Mysql/Makefile
+++ b/databases/tcl-Mysql/Makefile
@@ -16,7 +16,6 @@ OPTIONS_DEFINE= DOCS
PATCH_DEPENDS= rcsdiff:${PORTSDIR}/devel/rcs
-BROKEN= Does not build
USE_MYSQL= 41+
USES= tcl
TCL_NODOT= tcl${TCL_VER:S/.//}
diff --git a/databases/tcl-Mysql/files/patch-const-error b/databases/tcl-Mysql/files/patch-const-error
index 63de9b834062..110053695b5b 100644
--- a/databases/tcl-Mysql/files/patch-const-error
+++ b/databases/tcl-Mysql/files/patch-const-error
@@ -7,7 +7,14 @@
+ const char *getErrorMsg();
};
--- sql-interface.h Mon Sep 14 06:52:41 1998
-+++ sql-interface.h Wed Nov 10 17:43:15 2004
++++ sql-interface.h 2014-07-13 12:30:48.000000000 -0400
+@@ -13,4 +13,6 @@
+ #define SQL_INTERFACE_H
+
++#include <cstddef>
++
+ class Sql_row;
+
@@ -54,5 +54,5 @@
// Get the error message, if there was one, for the last message