aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorpst <pst@FreeBSD.org>1997-08-27 06:30:07 +0800
committerpst <pst@FreeBSD.org>1997-08-27 06:30:07 +0800
commit38bef9e900e5150ce4e0f3cb57730cf2cf37bf3e (patch)
treefb2687ffb2ed0bd000df34fb83a684e543a64ee0 /databases
parent115ec8e9a4c0c6815fae9b6ce2623e439a053cb8 (diff)
downloadfreebsd-ports-gnome-38bef9e900e5150ce4e0f3cb57730cf2cf37bf3e.tar.gz
freebsd-ports-gnome-38bef9e900e5150ce4e0f3cb57730cf2cf37bf3e.tar.zst
freebsd-ports-gnome-38bef9e900e5150ce4e0f3cb57730cf2cf37bf3e.zip
Update to 3.104 beta.
Warning: the directory structure has shifted again (lib/gnats -> libexec/gnats) Also, I am now compiling and configuring gnats with "with release based" which adds additional functionality and is backwards compatible, but adds new PR fields you may not expect to see.
Diffstat (limited to 'databases')
-rw-r--r--databases/gnats/Makefile14
-rw-r--r--databases/gnats/distinfo2
-rw-r--r--databases/gnats/files/patch-aa53
-rw-r--r--databases/gnats/files/patch-ab30
-rw-r--r--databases/gnats/pkg-plist28
5 files changed, 67 insertions, 60 deletions
diff --git a/databases/gnats/Makefile b/databases/gnats/Makefile
index e7730742f14f..b824b967d572 100644
--- a/databases/gnats/Makefile
+++ b/databases/gnats/Makefile
@@ -1,15 +1,15 @@
# New ports collection makefile for: gnats
-# Version required: 3.102-beta
+# Version required: 3.104-beta
# Date created: 10 November 1995
# Whom: pst
#
-# $Id: Makefile,v 1.12 1997/02/19 04:36:05 asami Exp $
+# $Id: Makefile,v 1.13 1997/06/30 07:11:02 peter Exp $
#
-DISTNAME= gnats-3.102-beta
-PKGNAME= gnats-3.102b
+DISTNAME= gnats-3.104-beta
+PKGNAME= gnats-3.104b
CATEGORIES= databases
-MASTER_SITES= ftp://ftp.cygnus.com/pub/
+MASTER_SITES= ftp://ftp.cygnus.com/pub/gnats/
MAINTAINER= pst@FreeBSD.org
@@ -19,7 +19,9 @@ NO_PACKAGE= "Requires gnats UID"
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
--with-lispdir=${PREFIX}/share/emacs/site-lisp \
- --with-full-gnats
+ --with-full-gnats \
+ --with-release-based
+
USE_GMAKE= yes
MAN1= edit-pr.1 gnats.1 query-pr.1 send-pr.1
MAN8= mkcat.8 rmcat.8 mkdist.8 queue-pr.8 file-pr.8 gen-index.8
diff --git a/databases/gnats/distinfo b/databases/gnats/distinfo
index 4b1953f30523..e0b4463eb19d 100644
--- a/databases/gnats/distinfo
+++ b/databases/gnats/distinfo
@@ -1 +1 @@
-MD5 (gnats-3.102-beta.tar.gz) = 13eb4968c892ead02e808c140274de55
+MD5 (gnats-3.104-beta.tar.gz) = 361c0ef5df2c9f02e44e1821da966b77
diff --git a/databases/gnats/files/patch-aa b/databases/gnats/files/patch-aa
index a5bfc8da519c..3d7397e9fe95 100644
--- a/databases/gnats/files/patch-aa
+++ b/databases/gnats/files/patch-aa
@@ -1,34 +1,47 @@
Use the FSF m4 instead of the BSD m4, because the BSD m4 is reporting problems
processing config.c.in.
---- Makefile.in Mon Dec 2 14:45:56 1996
-+++ Makefile.in Sun Feb 16 19:33:40 1997
-@@ -65,7 +65,7 @@
+--- Makefile.in Mon Aug 18 14:52:43 1997
++++ Makefile.in Tue Aug 26 14:14:44 1997
+@@ -68,7 +68,7 @@
+ HOST_PREFIX_1 = loser-
- # We don't specify -g -O because many compilers don't support -g -O,
- # and/or -O is broken in and of itself.
+ # These flag values are normally overridden by the configure script.
-CFLAGS = -g
-+CFLAGS += -g
++CFLAGS+= -g
+ CXXFLAGS = -g -O2
+
LIBCFLAGS = $(CFLAGS)
- CFLAGS_FOR_TARGET = $(CFLAGS)
- LIBCFLAGS_FOR_TARGET = $(CFLAGS_FOR_TARGET)
-@@ -104,7 +104,7 @@
+@@ -121,7 +121,7 @@
M4 = `if [ -f $$r/m4/m4 ] ; \
then echo $$r/m4/m4 ; \
- else echo m4 ; fi`
+ else echo gm4 ; fi`
- MAKEINFO = `if [ -f $$r/texinfo/makeinfo/makeinfo ] ; \
+ MAKEINFO = `if [ -f $$r/texinfo/makeinfo/Makefile ] ; \
then echo $$r/texinfo/makeinfo/makeinfo ; \
---- gnats/Makefile.in Mon Dec 2 14:45:57 1996
-+++ gnats/Makefile.in Sun Feb 16 19:32:25 1997
-@@ -126,7 +126,7 @@
- LIBS = @LIBS@
- KRBINCLUDE = @KRBINCLUDE@
-
--M4 = m4
-+M4 = gm4
- MAKEINFO = makeinfo
- TEXI2DVI = texi2dvi
+
+The top level Makefile overrides the use of BISON to just "bison" instead
+of bison -y, so use YACC, since that's what we're trying to define anyway.
+
+--- gnats/Makefile.in Mon Aug 18 14:52:44 1997
++++ gnats/Makefile.in Tue Aug 26 14:45:55 1997
+@@ -118,7 +118,7 @@
+ # Set RANLIB = echo if your system doesn't have or need ranlib.
+ RANLIB = @RANLIB@
+
+-BISON = @YACC@
++YACC = @YACC@
+ DIFFOPT = @DIFFOPT@
+
+ # These are set by autoconf.
+@@ -435,7 +435,7 @@
+
+ getdate.c: getdate.y
+ @echo expect 10 shift/reduce conflicts
+- $(BISON) -d $(srcdir)/getdate.y
++ $(YACC) -d $(srcdir)/getdate.y
+ mv y.tab.c getdate.c
+ mv y.tab.h getdate.h
diff --git a/databases/gnats/files/patch-ab b/databases/gnats/files/patch-ab
index 38018edd096b..f15cd62e931b 100644
--- a/databases/gnats/files/patch-ab
+++ b/databases/gnats/files/patch-ab
@@ -1,19 +1,11 @@
-*** gnats/edit-pr.sh.bak Tue Dec 3 01:46:08 1996
---- gnats/edit-pr.sh Thu Jun 19 12:37:34 1997
-***************
-*** 20,26 ****
- # the Free Software Foundation, 675 Mass Ave, Cambridge, MA 02139, USA.
-
- debug_print=false # or echo to get output.
-! DATE=`date`
- GNATS_ROOT=xGNATS_ROOTx
- LIBDIR=xLIBDIRx
- PATH=$PATH:$GNATS_ROOT/gnats-bin
---- 20,26 ----
- # the Free Software Foundation, 675 Mass Ave, Cambridge, MA 02139, USA.
-
- debug_print=false # or echo to get output.
-! DATE=`LC_TIME=C date`
- GNATS_ROOT=xGNATS_ROOTx
- LIBDIR=xLIBDIRx
- PATH=$PATH:$GNATS_ROOT/gnats-bin
+--- gnats/edit-pr.sh Mon Aug 18 14:52:53 1997
++++ gnats/edit-pr.sh Tue Aug 26 14:15:19 1997
+@@ -20,7 +20,7 @@
+ # the Free Software Foundation, 675 Mass Ave, Cambridge, MA 02139, USA.
+
+ debug_print=false # or echo to get output.
+-DATE=`date`
++DATE=`LC_TIME=C date`
+ GNATS_ROOT=xGNATS_ROOTx
+ LIBEXECDIR=xLIBEXECDIRx
+ PATH=$PATH:$GNATS_ROOT/gnats-bin
diff --git a/databases/gnats/pkg-plist b/databases/gnats/pkg-plist
index aca30e72404d..09a73f8426b7 100644
--- a/databases/gnats/pkg-plist
+++ b/databases/gnats/pkg-plist
@@ -12,20 +12,20 @@ info/gnats.info-2
info/gnats.info-3
info/gnats.info-4
info/send-pr.info
-lib/gnats/at-pr
-lib/gnats/file-pr
-lib/gnats/gen-index
-lib/gnats/gnatsd
-lib/gnats/mail-query
-lib/gnats/mkcat
-lib/gnats/mkdist
-lib/gnats/npr-edit
-lib/gnats/pr-addr
-lib/gnats/pr-age
-lib/gnats/pr-edit
-lib/gnats/pr-mail
-lib/gnats/queue-pr
-lib/gnats/rmcat
+libexec/gnats/at-pr
+libexec/gnats/file-pr
+libexec/gnats/gen-index
+libexec/gnats/gnatsd
+libexec/gnats/mail-query
+libexec/gnats/mkcat
+libexec/gnats/mkdist
+libexec/gnats/npr-edit
+libexec/gnats/pr-addr
+libexec/gnats/pr-age
+libexec/gnats/pr-edit
+libexec/gnats/pr-mail
+libexec/gnats/queue-pr
+libexec/gnats/rmcat
man/man1/edit-pr.1.gz
man/man1/gnats.1.gz
man/man1/query-pr.1.gz