aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2016-03-11 19:02:51 +0800
committerrakuco <rakuco@FreeBSD.org>2016-03-11 19:02:51 +0800
commit41ee4a3b3ee34cbda4ee739c690c53215ed6e291 (patch)
tree7746ca97b7c3be179839c53d617d6e8e995f2a3f /databases
parentce93fc7c80abfe08c0b2ac282e1e5c03e3c4ab85 (diff)
downloadfreebsd-ports-gnome-41ee4a3b3ee34cbda4ee739c690c53215ed6e291.tar.gz
freebsd-ports-gnome-41ee4a3b3ee34cbda4ee739c690c53215ed6e291.tar.zst
freebsd-ports-gnome-41ee4a3b3ee34cbda4ee739c690c53215ed6e291.zip
Add back some library flags lost in r410751.
Some .pri files still get some of their information from Qt4's configure script by default. Since we are not using it for the sqldriver ports, both qt4-odbc-plugin and qt4-sqlite3-plugin were no longer linking against libodbc.so and libsqlite3.so. Fix it by explicitly passing those via LDFLAGS. Thanks to Luca Pizzamiglio <luca.pizzamiglio@gmail.com> for the report.
Diffstat (limited to 'databases')
-rw-r--r--databases/qt4-odbc-plugin/Makefile4
-rw-r--r--databases/qt4-sqlite3-plugin/Makefile4
2 files changed, 6 insertions, 2 deletions
diff --git a/databases/qt4-odbc-plugin/Makefile b/databases/qt4-odbc-plugin/Makefile
index 60e93158b782..2b3bd4d7297e 100644
--- a/databases/qt4-odbc-plugin/Makefile
+++ b/databases/qt4-odbc-plugin/Makefile
@@ -1,11 +1,13 @@
# Created by: Michael Nottebrock <lofi@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 2
DB= odbc
COMMENT= Qt Open Database Connectivity plugin
LIB_DEPENDS= libodbc.so:${PORTSDIR}/databases/unixODBC
+LDFLAGS+= -lodbc
+
.include "${.CURDIR:H:H}/devel/qt4/Makefile.sqldrivers"
diff --git a/databases/qt4-sqlite3-plugin/Makefile b/databases/qt4-sqlite3-plugin/Makefile
index 0ef4f1287ddb..651f86d3903c 100644
--- a/databases/qt4-sqlite3-plugin/Makefile
+++ b/databases/qt4-sqlite3-plugin/Makefile
@@ -1,10 +1,12 @@
# Created by: Michael Nottebrock <lofi@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 2
COMMENT= Qt SQLite 3 database plugin
DB= sqlite
USES= sqlite:3
+LDFLAGS+= -lsqlite3
+
.include "${.CURDIR:H:H}/devel/qt4/Makefile.sqldrivers"